Jump to content


Photo

LXD75/Guiding problem

  • Please log in to reply
10 replies to this topic

#1 EricJD

EricJD

    Vanguard

  • -----
  • Posts: 2148
  • Joined: 24 Jul 2007
  • Loc: Chesapeake VA

Posted 03 March 2009 - 08:37 PM

I connect my LXD75 to my computer by plugging in an RJ12 cable into the handset which then plugs into a DB-9 adapter which connects to a serial-USB adapter that plugs into the laptop. Both the RJ12 cable and DB-9 adapter came with my DSI Pro so I assume that they're of the proper pin-out.

I have downloaded and installed ASCOM 4.1 and rebooted the PC. I have downloaded the updated pulse guide drivers for LX200/Autostar and replaced the ones that came with the default ASCOM drivers.

Here's my problem, after starting up PHD, clicking on the telescope icon, selecting Meade LX200 and Autostar, selecting COM5 (which is where my adapter shows up at) and clicking the pulse guide button then clicking OK, PHD thinks for a second then goes to 'Program Not Responding'.

I tried to use the Pictor Guiding in Autostar Suite and when trying to connect it says device not found.

Any ideas?

#2 Fish

Fish

    Viking 1

  • *****
  • Posts: 649
  • Joined: 13 Oct 2007
  • Loc: Norridgewock, ME

Posted 03 March 2009 - 09:32 PM

Eric,

A standard 6-pin to 6-pin cable will not interface the LXD75 - more accurately the AutoStar controller attached to it - to your PC serial port. The Meade #505 Connector Cable Set includes the necessary parts to do this.

But there's nothing all that special about it. Only TXD, RXD and GND are required; you just have to get the right wires in the right pins.

Rather than test the TOS I'll recommend you use a search engine to look for "LXD75 serial cable" and build one.

Regards, Marc

#3 EricJD

EricJD

    Vanguard

  • -----
  • Posts: 2148
  • Joined: 24 Jul 2007
  • Loc: Chesapeake VA

Posted 03 March 2009 - 10:35 PM

Thanks for the reply. I believe the cable that I have is the #505, it's one end is smaller than the other and only fits in the DB9 adapter, the other end is smaller and fits into the HC and it came with the DSI Pro that I bought. I checked the pinout on the DB9 and it's correct, I'll have to search for the proper cable pinout like you said to see if it's correct.

#4 Spoonsize

Spoonsize

    DURHAM 157494

  • *****
  • Posts: 4195
  • Joined: 27 Aug 2004
  • Loc: Stuck in a Time Warp.

Posted 04 March 2009 - 11:35 AM

It might be the USB/Serial adapter. I've no clue why, but some of them do not like to work with imaging. And I've no clue which ones.

#5 jgraham

jgraham

    Voyager 1

  • *****
  • Posts: 13657
  • Joined: 02 Dec 2004
  • Loc: Miami Valley Astronomical Society

Posted 04 March 2009 - 12:29 PM

Just for yucks see if you can connect to your AutoStar using either the Remote Hanbox function in the AutoStar Suite or the Envisage Telescope tab. That will at least tell you if you've got things connected correctly. I use Envisage to guide with using the same cable set (the ones that came with my DSI) and it sounds like you've got things set up right.

#6 Fish

Fish

    Viking 1

  • *****
  • Posts: 649
  • Joined: 13 Oct 2007
  • Loc: Norridgewock, ME

Posted 04 March 2009 - 02:08 PM

Eric,

Try this:
--> Connect the RJ-11 (6-pin) end of the #505 cable to the serial port DB-9 adapter and to the PC
--> Connect the RJ-6 end (4-pin) to the AutoStar and the AutoStar into the scope
--> Boot the scope and get past the initial screens
--> Open Hyperterminal (or equivalent) on the PC and connect to the scope using 9600,N,8,1 on the COM port.
--> In HyperTerminal, type :GL#

AutoStar should respond with the local time.

If you get garbage, check the protocol settings.
If you see responses but not what you type, tyrn on local echo.
If you get no reply, not even garbacge, check your cabling.
If you still get no reply, the USB-serial connection may be bad, although it should work with at least HyperTerminal.

Let me know,

Regards, Marc

#7 EricJD

EricJD

    Vanguard

  • -----
  • Posts: 2148
  • Joined: 24 Jul 2007
  • Loc: Chesapeake VA

Posted 04 March 2009 - 03:28 PM

Last night I read some similar steps to yours on the Weasner site. I connected everything up as you describe then opened up Hyperterm. His site said to type cntrl-f and look for a response, there was none. His site then recommended disconnecting everything except the usb/serial adapter, shorting out pins 2 and 3 with a screwdriver and then typing on the keyboard to see if it echoed in Hyperterm, it did not. So I'm assuming now that my usb/serial adapter is not working properly.

I'm using a Prolific adapter, guess I'll have to start the Windows/Drivers dance and see who wins. Someone suggested that I try a Keyspan adapter, which I have on my Mac. So I downloaded the Keyspan drivers and Windows wont recognize them as the appropriate drivers. Man I wish PHD/Autostar worked with Macs.

#8 hersey0308

hersey0308

    Vostok 1

  • -----
  • Posts: 102
  • Joined: 04 Dec 2008
  • Loc: Ontario Canada

Posted 04 March 2009 - 03:49 PM

hi eric - i second spoons idea that it is the adapter. i have five and only two will connect even though they all look the same.
also i think i have a prolific driver file that i can post on my website for you to download if you need (later today.) i know how frustrating this part can be - you will be up and imaging before long. i'll pm you

best
david

#9 EricJD

EricJD

    Vanguard

  • -----
  • Posts: 2148
  • Joined: 24 Jul 2007
  • Loc: Chesapeake VA

Posted 04 March 2009 - 03:53 PM

That would be fantastic, I'll look for the PM.

#10 EricJD

EricJD

    Vanguard

  • -----
  • Posts: 2148
  • Joined: 24 Jul 2007
  • Loc: Chesapeake VA

Posted 06 March 2009 - 07:31 AM

Did the drivers dance and finally got a Keyspan adapter to work with drivers that someone else provided for me. Was able to track last night, although Dec calibration failed for some reason, but hey, at least it's talking!

Thanks all for your fantastic help.

#11 yock1960

yock1960

    Gemini

  • *****
  • Posts: 3081
  • Joined: 22 Jun 2008
  • Loc: (Mostly Cloudy) Ohio, USA

Posted 06 March 2009 - 11:00 AM

Looks like I'm a little late here, but the Prolific adapter will work. You just have to hunt for an updated driver. Well, at least it works with my HP laptop. If you are interested at all, PM me and I can email the driver to you.


As far as the DEC calibration failing is concerned. I've had that. From what I have been able to dig up, it's due to backlash and/or poor polar alignment. I don't have enough experience to say, but there is a document (guiding.pdf)over on the 'LXD75telescopes' Yahoo group that has a strategy for good guiding with an LXD75 mount & PHD. I haven't been able to try it yet, but I can't wait!


Steve






Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics