Jump to content


Photo

Atlas mount problem

This topic has been archived. This means that you cannot reply to this topic.
2 replies to this topic

#1 Mike Conley

Mike Conley

    Viking 1

  • *****
  • Posts: 539
  • Joined: 23 Sep 2007

Posted 26 August 2009 - 06:34 AM

The RA quit working late last night. I pulled the inspection screws and the gears are turning, but the mount head isn't. I noticed it was moving slower than normal prior to not moving at all. This is a non goto model. Anyone had the same problem, and know the cause?

Thanks Mike

#2 Jeffrey Sugden

Jeffrey Sugden

    Viking 1

  • *****
  • Posts: 735
  • Joined: 04 May 2005

Posted 26 August 2009 - 05:03 PM

Try tightening the RA clutch.
1. Loosen the RA clutch handle
2. Remove the clutch handle (unscrew the center screw)
3, Tighten the bolt 1/4 turn or so
4. Replace the handle in the "loose" postion
5. Test

If that doen't work, you might have grease in the wrong place and that would make the clutch impossible to tighten.

#3 Mike Conley

Mike Conley

    Viking 1

  • *****
  • Posts: 539
  • Joined: 23 Sep 2007

Posted 28 August 2009 - 05:10 PM

Jeff,

Thanks for the reply. I had tried that, but ended up going a bit further. I took the small round disc out ( the one that the bolt tightens against the drum/clutch ). I turned it over and cleaned it and , there was some grease ( not my doing ) and that seems to have fixed it. I have always noticed that I had to really snug it to keep from slipping. I've have the mount for several years. The small round disc was flat on both sides. Sure seems like it should be rounded to match the clutch hub or whatever its called.

Mike






Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics