Jump to content


Photo

Bad NEQ6 Controllers

This topic has been archived. This means that you cannot reply to this topic.
1 reply to this topic

#1 Richard Scott

Richard Scott

    Viking 1

  • -----
  • Posts: 935
  • Joined: 25 Jul 2006

Posted 12 September 2009 - 07:42 AM

Has anyone else heard of this?

I bought an NEQ6 Pro from a vendor in Canada, and had the hand controller go crazy within a week. Real nutty stuff, like profound misspellings, odd broken charters, not English not Chinese, just odd. And eventually nothing but a blank illuminated screen.

I sent the controller back to my vendor, he replaced it with a new unit, and within 2 days it too went completely out. Just an illuminated screen, but no text whatsoever would display.

Upon contacting him again he informed me that the manufacturer in China has released a batch of faulty controllers. And that he had 3 other guys that were having the same trouble.

Have any of you heard anything about this?

p.s.
While they were working, I checked the voltage coming in to the units, I had 14 volts 2 amps from an AC 120v / DC 12v converter, and I also tried two different 12V power tanks as well. I don’t think it is me.

Might it be two bad controllers in a row???!!! Or the board on the mount… thoughts?

Clear skies
Richard

#2 Charlie Hein

Charlie Hein

    Voyager 1

  • *****
  • Administrators
  • Posts: 12359
  • Joined: 02 Nov 2003

Posted 12 September 2009 - 07:48 AM

Hi Richard - at this point I'd take the dealer at his word on this one... funny thing, IIRC there have been reports from some CGEM owners of apparently identical problems with their HC's. Wonder if they are related somehow?






Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics