Jump to content


Photo

LXD75 runaway RA, and solution

  • Please log in to reply
1 reply to this topic

#1 deSitter

deSitter

    Still in Old School

  • -----
  • Posts: 6879
  • Joined: 09 Dec 2004

Posted 15 March 2010 - 07:39 PM

Ok a little drama finally from my old LXD75. I invoked a motor calibration and directly afterward, the mount ran away in RA at full speed. After that, it was permanently going like mad in RA. I dug up my backup Autostar and the problem went away, until I did motor calibration on that one, same result. So it's in both the Autostar and the motor box. Resetting did not help. Flashing in safe mode did not help.

Well my mount is more than 5 years old and I've never cleaned the encoder wheels or sensors. I could see a very fine layer of dust that had been deposited in a circular pattern, as if the air dragged by the encoder wheel helped to put down the dust. I am telling you, it was VERY fine grained dust - only directly visible by its removal.

After re-assembly the problem was still present, But this time, reset worked - everything back to normal. Try the other Autostar, problem returns - reset - it's gone. Now calibration works on both Autostars. No problems.

SO - my guess is that a glitch in the firmware for the motor calibration can result in permanent runaway by storing a bad value inside the Autostar. Since it survived normal and safe flashing, it was in that part of flash ROM that is independent of the firmware.

Upshot - if you get sudden runaways, the first thing to check is the state of the encoder wheel and sensors. Clean them carefully with alcohol.

-drl

#2 Gregk

Gregk

    Vanguard

  • *****
  • Posts: 2420
  • Joined: 19 Nov 2006
  • Loc: San Tan Valley, Az,

Posted 15 March 2010 - 10:34 PM

Good Debug Never heard of this one.. I did own that mount for a while though

Regards

Greg






Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics