Jump to content


Photo

Intermittent Power

  • Please log in to reply
2 replies to this topic

#1 stephen63

stephen63

    Messenger

  • *****
  • Posts: 428
  • Joined: 19 May 2010
  • Loc: Central Pa

Posted 23 June 2010 - 09:38 AM

I'm a newbie so please bear with me. My CGEM has intermittent power when the power cable is jiggled or touched at all. The CGEM has a threaded DC plug but the AC adapter plug I bought from Celestron is the standard push in plug. Is this a common problem? It's pretty frustrating to lose power in the middle of an alignment and having to start over, not to mention this can't be doing the HC any good. Is this a radio shack threaded plug/splice fix? Anyone else have this problem? Thanks.

#2 SFGagnon

SFGagnon

    Vostok 1

  • -----
  • Posts: 112
  • Joined: 02 Aug 2009
  • Loc: Carrollton, VA

Posted 23 June 2010 - 10:24 AM

I had the same problem with mine. The male part of the power connection is cut lengthwise. I carefully spread the two halves apart very slightly using a knife blade. This resulted in a tighter fit and no more power problems.

Good luck!

#3 RTLR 12

RTLR 12

    Aurora

  • *****
  • Posts: 4559
  • Joined: 04 Dec 2008
  • Loc: The Great Pacific NorthWest

Posted 23 June 2010 - 10:46 AM

I have 4 of the Celestron power cords and have had nothing but trouble with all 4! I switched to these power cords and have had no trouble at all. They are fused, coiled, have a power switch, and also have a 90° connector at the scope end. I no longer have intermitent power problems and the cord has never come out of the mount! I power all my scopes (4) with these.

http://www.radioshac...oductId=3889594

Stan






Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics