Jump to content


Photo

Please help my LDX75 is not working properly

  • Please log in to reply
6 replies to this topic

#1 tamiyatanks

tamiyatanks

    Mariner 2

  • -----
  • Posts: 244
  • Joined: 27 Aug 2010
  • Loc: East Ferris Ontario

Posted 23 February 2011 - 09:32 PM

Hi eveyone, I need help with my LDX75. Here are the symptoms:

First off, I have aligned this mount countless times, so the polar alignment and date/time ect are all good.

Before the big problems started I would align the scope and while it was tracking the autostar would go black and I could not get it back on unless I powered off the LDX75 and then powered it back on.

Then the BIG issues occured :bawling::
1. On an easy align to sirrus only one axis turns then I get a motor fault error on the autostar. Choosing to test motors results in both axis turinig okay

2. If I choose the star to align to, say Capella both axis motors work, but the telescope aims to the ground (should be aiming up at the sky!!) and will jam itself into the mount if I do not hit the power button

3. If I skip the align I can use the autostar to move both the axis motors with the keypad

FINALLY after months of clouds we are starting to get clear skys. If anyone knows what is going on so I can get back up and running your advice would be much appreciated :help:

#2 Phil Wheeler

Phil Wheeler

    Vanguard

  • -----
  • Posts: 2018
  • Joined: 31 Dec 2005
  • Loc: 3 miles WNW of Celestron

Posted 23 February 2011 - 09:38 PM

Have you tried updating the Autostar hand controller?

#3 David Pavlich

David Pavlich

    Transmographied

  • *****
  • Administrators
  • Posts: 27760
  • Joined: 18 May 2005
  • Loc: Mandeville, LA USA

Posted 23 February 2011 - 10:08 PM

Have you tried resetting to the default settings and entering the information and retraining the drives? When my 75 gives me kniptions, that's what I do and it's never failed to get everything back on an even keel.

David

#4 Eddgie

Eddgie

    Voyager 1

  • *****
  • Posts: 12937
  • Joined: 01 Feb 2006

Posted 23 February 2011 - 10:16 PM

First, using the tip of a small screwdriver, or the end of a fine blade knife, very gently spread the male pin in the mount's power plug apart. The pin has a split down the middle. This can cause the power to be interrupted even by the vibrations of the mount slewing. This is a first step in correcting just about any kind of error in the LXD-75 and most other mounts that use a similar style power plug.

Next, do a factory reset on the hand controller. This will fix about 90% of the problems 90% of the time.

Next, re-plug the cords several times to whipe the contacts on the phone style jacks. These jacks are designed to be self wiping when plugged and unplugged.

Finally, open the access ports on the sides of the Dec and RA housing. Watch the end of the shaft inside the hole in the gears. With the mount powered on, drive the motors and reverse them a few times while watching that the shaft is not turning even slightly inside the gears. This can be a sign tht the setscrews on the gears can back out. This is a common problem and can cause lots of errors.

If it is none of those things, then at least you know what it isn't and the problem may in that case be internal.

Good luck.

#5 tamiyatanks

tamiyatanks

    Mariner 2

  • -----
  • Posts: 244
  • Joined: 27 Aug 2010
  • Loc: East Ferris Ontario

Posted 23 February 2011 - 10:23 PM

Excellent advice everyone, thank you. The Autostar is up to date, so I will give the reset and other methods a try.

#6 tamiyatanks

tamiyatanks

    Mariner 2

  • -----
  • Posts: 244
  • Joined: 27 Aug 2010
  • Loc: East Ferris Ontario

Posted 24 February 2011 - 08:46 AM

Well I did the reset on the autostar and then did a simulated alignment in my living room and it looks like the LDX75 is now back to normal!

I just hope that when the scope jammed against the tripod the gears did not get damaged. I will see how well it tracks on the next clear night.

Thanks everyone!

#7 MawkHawk

MawkHawk

    Messenger

  • *****
  • Posts: 416
  • Joined: 23 Aug 2009
  • Loc: SE Michigan, USA

Posted 24 February 2011 - 02:35 PM

For what it's worth, sometimes the autostar cable goes bad as well. My Autostar started giving me problems and I replaced the cable with a Scopestuff cable and it fixd it.






Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics