Jump to content


Photo

CG5 Hyperturne

  • Please log in to reply
7 replies to this topic

#1 LateViewer

LateViewer

    Apollo

  • *****
  • Posts: 1211
  • Joined: 17 Nov 2005
  • Loc: Pelham NY

Posted 21 August 2012 - 06:20 PM

I have come back into contact with my CG5 and have been thinking of either tuning it or doing the hypertune to it. As is upgrading the bearings etc.

I have read through a bunch of threads and wonder if spending the money on the new bearings is worth it or will taking it apart, de-burring, sanding and re-lubing be enough to satisfy.

I am going to work on it, I just don't know if I want to spend another $175.00 to $225.00 on this mount.

Opinions?

Thanks

Al

#2 wolfman_4_ever

wolfman_4_ever

    Apollo

  • -----
  • Posts: 1245
  • Joined: 15 Jul 2011
  • Loc: El Segundo, Ca, So. Cal

Posted 21 August 2012 - 11:59 PM

I had Ed Hypertune mine.. Money well spent.. I'm quite surprised how well it tracks..

#3 jchoy46

jchoy46

    Vostok 1

  • -----
  • Posts: 128
  • Joined: 08 Feb 2012
  • Loc: Port Orange, FL

Posted 22 August 2012 - 06:26 AM

if ya got the cash i would since it makes a big difference

#4 Alph

Alph

    Surveyor 1

  • -----
  • Posts: 1767
  • Joined: 23 Nov 2006
  • Loc: Melmac

Posted 22 August 2012 - 10:48 AM

I had Ed Hypertune mine.. Money well spent.. I'm quite surprised how well it tracks..

Hmm? Isn't Celestron working on your mount right now. :question:

#5 Alph

Alph

    Surveyor 1

  • -----
  • Posts: 1767
  • Joined: 23 Nov 2006
  • Loc: Melmac

Posted 22 August 2012 - 10:52 AM

I have read through a bunch of threads and wonder if spending the money on the new bearings is worth it or will taking it apart, de-burring, sanding and re-lubing be enough to satisfy.


Don't expect miracles. Roll up your sleeves and do it yourself. Unless there is something visibly wrong with the bearing I would not replace them.

#6 wolfman_4_ever

wolfman_4_ever

    Apollo

  • -----
  • Posts: 1245
  • Joined: 15 Jul 2011
  • Loc: El Segundo, Ca, So. Cal

Posted 22 August 2012 - 04:00 PM

I had Ed Hypertune mine.. Money well spent.. I'm quite surprised how well it tracks..

Hmm? Isn't Celestron working on your mount right now. :question:


My Cge-Pro.. Not my CG5.. I just got my cge-pro back yesterday.. I have some tests to run..

#7 wolfman_4_ever

wolfman_4_ever

    Apollo

  • -----
  • Posts: 1245
  • Joined: 15 Jul 2011
  • Loc: El Segundo, Ca, So. Cal

Posted 22 August 2012 - 06:09 PM


I have some tests to run..


Epic Failure.... Sigh...

#8 LateViewer

LateViewer

    Apollo

  • *****
  • Posts: 1211
  • Joined: 17 Nov 2005
  • Loc: Pelham NY

Posted 22 August 2012 - 07:24 PM

Epic Failure.... Sigh...



Well that's not good.






Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics