Jump to content


Photo

G11 Digital Drive System

  • Please log in to reply
2 replies to this topic

#1 dmilone

dmilone

    Sputnik

  • -----
  • Posts: 44
  • Joined: 22 Feb 2008

Posted 24 December 2012 - 10:00 AM

It's been a couple of years since I've done any astronomy. But now I'm trying to get back in the game. My push-to G11 seems to have a bit of a problem. It doesn't want to start. I have to turn the switch on off on off on off on off many times before it comes to life. I remember having this issue before, but it would come on after the second or third try. Now the problem is a lot worse. Maybe it sat around too long. It's like trying to start up an old car. I can't find any loose connections. The battery is fairly new. Once it's on it stays on. What should I do? Is this thing eventually going to die on me?
BTW, Merry Xmas everybody.
David

#2 Startraffic

Startraffic

    Viking 1

  • *****
  • Posts: 744
  • Joined: 12 Feb 2006
  • Loc: Lat. 39.143345, Long. -77.174802

Posted 24 December 2012 - 04:27 PM

David,
Sounds like maybe the switch is going bad. Very repairable, You "can" send it back into Losmandy & let them fixit. Best guess >$25 + shipping. Give them a call, they don't bite.

Clear Dark Skies
Startraffic
39.138274 -77.168898

#3 gnowellsct

gnowellsct

    Fly Me to the Moon

  • *****
  • Posts: 6666
  • Joined: 24 Jun 2009

Posted 25 December 2012 - 01:23 PM

You can get some contact cleaner at a computer store. Might buy you some time with the switch. GN






Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics