Jump to content


Photo

Win 8 driver for Paramount MX

  • Please log in to reply
10 replies to this topic

#1 CharlesW

CharlesW

    Apollo

  • -----
  • Posts: 1325
  • Joined: 01 Nov 2012
  • Loc: Chula Vista & Indio, CA

Posted 05 March 2013 - 11:10 PM

Tonight I tried o power up my MX for the first time and install the driver. My Win 8 laptop will not accept the non-signed driver. I have done the update and daily build from SB. I cannot find an updated driver on their website. Between not being able to sign into my SB account without switching my computer to some "compatibility mode" and having an $8400 brick sitting on my kitchen floor, I'm losing a little patience. Does anyone have a fix for this driver problem? Thanks,

#2 CharlesW

CharlesW

    Apollo

  • -----
  • Posts: 1325
  • Joined: 01 Nov 2012
  • Loc: Chula Vista & Indio, CA

Posted 06 March 2013 - 12:25 AM

A very kind gent on the Software Bisque site suggested getting into the advanced start up menus for Win 8 and disabling the signed drivers requirement. That did work but it took two restarts to drill down to that menu.

#3 frolinmod

frolinmod

    Surveyor 1

  • -----
  • Posts: 1891
  • Joined: 06 Aug 2010
  • Loc: Southern California

Posted 06 March 2013 - 12:42 AM

You gotta love Microsoft.

#4 Bob Moore

Bob Moore

    Apollo

  • *****
  • Posts: 1234
  • Joined: 07 Apr 2006
  • Loc: New York

Posted 06 March 2013 - 12:48 AM

sounds like a lot of trouble to me, I'll take the MX off you hands for 5K.

your going to love the mount, I have used all kinds of mounts, the PMX blows them all away.

Attached Files



#5 PGW Steve

PGW Steve

    Apollo

  • -----
  • Posts: 1341
  • Joined: 03 Oct 2006
  • Loc: Winnipeg, Canada

Posted 06 March 2013 - 11:08 AM

I had an issue with a serial card in my Windows 8 machine that I use for an SBIG All Sky Cam.

My IT guy got this procedure from the maker of the serial card, and it worked fine. Glad to see that you got it sorted out!!!!

++++++++++++++++++
1. From the Desktop move your mouse to the top right hand corner of the screen. This will pull up the "Charm Bar" and select "Settings".

2. From the "Settings Menu" select "Change PC settings". This will pull up a new Window.

3. From the "PC Settings" windows select "General".

4. At the bottom of the General Settings Page, you will find "Advanced Startup". In this section click on "Restart Now". Don't worry there are still plenty of steps left.

5. From this new Window select Trouble Shooting > Advanced Options > Startup Settings and finally Restart.

6. At this point your system will reboot and present you with a series of options allowing you to enable or disable several startup options.

7. Within this first page you should see a F-Key that refers to "Disable Driver Signature Enforcement". Once you enter the appropriate F-key, the system will startup, allowing you to install hardware that hasn't been digitally signed.
++++++++++++

#6 oo_void

oo_void

    Viking 1

  • *****
  • Posts: 597
  • Joined: 13 Nov 2009
  • Loc: San Francisco, CA

Posted 06 March 2013 - 02:06 PM

You could also just right click on the installer and "Run as Administrator".

#7 PGW Steve

PGW Steve

    Apollo

  • -----
  • Posts: 1341
  • Joined: 03 Oct 2006
  • Loc: Winnipeg, Canada

Posted 07 March 2013 - 01:24 AM

You could also just right click on the installer and "Run as Administrator".


You've actually had this work with Windows 8?

#8 frolinmod

frolinmod

    Surveyor 1

  • -----
  • Posts: 1891
  • Joined: 06 Aug 2010
  • Loc: Southern California

Posted 07 March 2013 - 02:38 AM

I was under the impression that all installers on Windows 7/8 automatically run as administrator whether you explicitly run them that way or not. Not that this has anything to do with Windows Test Mode that allows one to run unsigned drivers. Test mode can be turned on permanently. I run in Test Mode at all times because I run with home brew (developer) drivers that will never be signed by Microsoft.

#9 PGW Steve

PGW Steve

    Apollo

  • -----
  • Posts: 1341
  • Joined: 03 Oct 2006
  • Loc: Winnipeg, Canada

Posted 07 March 2013 - 08:39 AM

The problem isn't the installer. It has to do with the 'digital certificate' not being signed. Thus the detailed procedure to get around the issue and install a driver.

#10 blueman

blueman

    Photon Catcher

  • *****
  • Posts: 5429
  • Joined: 20 Jul 2007
  • Loc: California

Posted 07 March 2013 - 02:05 PM

This is the main reason that I bought another Win7 laptop this month. I just do not want to deal with Win8 and all the problems associated with it. Plus I am not a fan of the new interface.
Win9 will be out soon and then Win8 will be another Vista. I just don't see the need to get into the Microsoft point of view on opperating systems.
Blueman

#11 WesC

WesC

    Vanguard

  • *****
  • Posts: 2119
  • Joined: 06 Feb 2013
  • Loc: La Crescenta, CA

Posted 29 March 2013 - 11:34 AM

I've had driver problems like this going all the way back to Win95... this is not a new problem. ;)






Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics