Jump to content


Photo

iOptron firmware update and SkySafari

  • Please log in to reply
8 replies to this topic

#1 rkayakr

rkayakr

    Messenger

  • *****
  • Posts: 455
  • Joined: 27 Oct 2010
  • Loc: Northeast Ohio

Posted 11 April 2013 - 07:47 PM

The latest 8407 controller firmware upgrade (HC-EQ_V130401) adds new features:

Added Polar Align function for those who can’t see the pole star
Added an option to allow a mount to keep tracking even an object is below horizon

and appears to have fixed the issue with mount control with SkySafari.
For my iEQ45 with SkyWire, SkySafari can now connect to the mount and control it to slew and goto. The display align and lock features also appear to function.
I say appear because it is, of course, cloudy here in NE Ohio. The mount appears to respond as expected to SkySafari commands and after a goto the handbox reports a position that agrees with the SkySafari goto target position.
Clear Skies
Bob

#2 Astronewb

Astronewb

    Apollo

  • *****
  • Posts: 1303
  • Joined: 19 Sep 2011
  • Loc: Connecticut

Posted 11 April 2013 - 09:55 PM

I'll second what Bob said,the iEQ45/8407 works fine with Sky Safari wirelessly now. But the firmware update didn't have anything to do with it, because I didn't update the firmware on my iEQ45.

Whatever happened must have been between Southern Stars and iOptron behind the scenes..?

I did update the firmware on the SmartEQ Pro 8408 hand controller, and it does have the new menu items like the 8407 firmware. But the 8408 mounts still do not function in Sky Safari.

I guess it would help if there were a telescope menu selection for the SmartEQ/ZEQ25 and iEQ30 mounts in SkySafari??

Hopefully, the last few snags with the 8408 HC will get sorted out in a timely fashion. Kudos to iOptron for finally getting the iEQ45/8407 working in Sky Safari...I love it.

Cheers,

paul

#3 timmbottoni

timmbottoni

    Surveyor 1

  • -----
  • Posts: 1751
  • Joined: 25 Aug 2005
  • Loc: W Chicago suburbs, IL USA

Posted 12 April 2013 - 12:20 PM

Thanks for the info.

I'm buying an ieq45 soon so I'm planning on becoming best friends with you soon Paul. ;)

Timm

#4 Jim langley

Jim langley

    Vostok 1

  • -----
  • Posts: 177
  • Joined: 02 Jul 2011
  • Loc: New Holland, PA

Posted 05 May 2013 - 08:51 PM

I'm buying an ieq45 soon so I'm planning on becoming best friends with you soon Paul. ;)


I have one now, and he is already my best friend, whether he knows it or not... :)

#5 ylpp

ylpp

    Lift Off

  • -----
  • Posts: 4
  • Joined: 19 Jul 2012

Posted 16 June 2013 - 10:12 PM

How to connect ieq30 with Skyfi?
I've connected through serial on 8407 controller and Skysafari doesn't connect with mount. I've also tried the RS232 on mount base, and result is the same

#6 Astronewb

Astronewb

    Apollo

  • *****
  • Posts: 1303
  • Joined: 19 Sep 2011
  • Loc: Connecticut

Posted 16 June 2013 - 11:36 PM

How to connect ieq30 with Skyfi?
I've connected through serial on 8407 controller and Skysafari doesn't connect with mount. I've also tried the RS232 on mount base, and result is the same


Don't have an iEQ30, just iEQ45 that works but the sequence is the same.

You can only connect using the rs232 port on the mount, the 4 pin serial port on the hand controller is for firmware update of the HC only.

Connect your tablet or smart phone to the Sky Fi receiver in the Wireless settings, you should see 'Sky Fi' to connect to.

The Sky Fi receiver should be connected to the mount via the supplied short usb to serial port cable, then the iOptron serial port (rs232) to serial port (rs232) cable to the mount's rs 232 connector.

You should be able to select the iEQ30/iEQ45 selection and connect?

Make sure you have the latest firmware updates for the mount, they are available at iOptron's website, along with the latest updater and instructions.

If you're still having a problem, contact Southern Stars' or iOptron's customer service.

Clear skies,

Paul

#7 ylpp

ylpp

    Lift Off

  • -----
  • Posts: 4
  • Joined: 19 Jul 2012

Posted 17 June 2013 - 01:50 PM

Paul, thank you for your instructions.
I didn't receive any USB to serial cable with Skyfi, only Skyfi serial adapter
(RJ-11 to DB9M). So I've tried this cable + serial cable connected to RS232 socket on the mount, and no response from the mount. Checked Skyfi on PC through hyper terminal and can see that Skyfi is sending some data from SkySafari.
Unfortunately response from Ioptron was too general, something like: We are trying to identify the bugs,too.
Not much information.
Some questions:
1. Should I configure baud rate for serial protocol inside Skyfi?
2. Some mounts has to be aligned before connecting with Skysafari. Is this true for IEQ30/45?

Thanks you again,
Iouri

#8 Astronewb

Astronewb

    Apollo

  • *****
  • Posts: 1303
  • Joined: 19 Sep 2011
  • Loc: Connecticut

Posted 17 June 2013 - 10:10 PM

Some questions:
1. Should I configure baud rate for serial protocol inside Skyfi?
2. Some mounts has to be aligned before connecting with Skysafari. Is this true for IEQ30/45?


No Iouri, you don't have to configure any baud rate, the standard setting works fine.

You will have to do your polar align and at least a One Star align before connecting to Sky Safari. Actually, you can do while your connected, because the HC works in conjunction with it, I just always align first.

Also, when finished slewing for the session, you will have to use the HC to return to the park or zero position before shutting down the mount.

All the best,

Paul

#9 ylpp

ylpp

    Lift Off

  • -----
  • Posts: 4
  • Joined: 19 Jul 2012

Posted 22 June 2013 - 09:40 AM

Thank you it's working.
1. SkyFi has to be connected to RS232 on the mount house
2. The mount has to be aligned
After that the Skysafari can connect and Goto is working.
But if I click Disconnect telescope and then press Connect again the mount stop responding, so I probably have to align again. Obviously, it's a bug.
Thank you again for your help.

Iouri






Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics