Jump to content


Photo

CPC Deluxe power failure :(

  • Please log in to reply
5 replies to this topic

#1 Seiko4169

Seiko4169

    Mariner 2

  • -----
  • Posts: 259
  • Joined: 04 Jul 2009

Posted 10 May 2013 - 09:41 AM

Well I've had my new CPC 1100 deluxe HD for 3 days and the power supply seems to have failed! :(

I turn the scope on and the power light doesn't come on. I've ensured that the connection is tight and my power tank is charged. No light, no sound and no power :(

It was making a strange high pitched and whistling / hissing sounds since I first used it but I had hoped that was just normal. Appears its not and was the start of something more serious.

Sigh, so much for my dream scope. Now I have to wait for the dealer to either organise a swap or send me a new main board. :(

Not the greatest of starts for Celestrons flagship cpc.

:bawling:

#2 Sorny

Sorny

    Viking 1

  • -----
  • Posts: 772
  • Joined: 15 Mar 2012
  • Loc: Southern MN

Posted 10 May 2013 - 09:58 AM

The CPC Deluxe makes a whine when hooked up to power due to the switching power supply.

Now, not getting anything could be that the central pin needs to be gently spread open a bit for a good contact. Give that a shot.

#3 Seiko4169

Seiko4169

    Mariner 2

  • -----
  • Posts: 259
  • Joined: 04 Jul 2009

Posted 10 May 2013 - 10:11 AM

Yes, tried that. Nothing. It's definately making contact but no light. :(

#4 mclewis1

mclewis1

    Thread Killer

  • *****
  • Posts: 10753
  • Joined: 25 Feb 2006
  • Loc: New Brunswick, Canada

Posted 10 May 2013 - 02:47 PM

Do you have a multimeter/ohm meter to check your voltages and the integrity of your DC power cable?
Do you have another DC power cable?
How about a whole different power supply? If not one of your own can you borrow one?

There really is no "main board" in a CPC (or any other Celestron mount). There's a small board that has the power connection, a small GPS board in a fork arm, and then there's a motor controller board in the base (which has lots of connectors because it has the connections from the hand controller and the two motors). The smarts for the mount are actually in the hand controller.

#5 Stacy

Stacy

    Star Partyer

  • *****
  • Posts: 5022
  • Joined: 15 Sep 2002
  • Loc: Seattle, WA

Posted 10 May 2013 - 07:07 PM

Do you have an AC adapter?

#6 Seiko4169

Seiko4169

    Mariner 2

  • -----
  • Posts: 259
  • Joined: 04 Jul 2009

Posted 11 May 2013 - 02:04 AM

Hi guys,

Yes I've tried other sources and the scope won't turn on. The original noise was coming from the silver plate area where it says CPC deluxe. It's not making any noise at all now so I'm assuming that's where the problem was/is.

Have to wait for supplier on Monday to organize a replacement.

:(






Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics