Jump to content


Photo

PHD and KWIQ Guider (QHY5) not cooperating

  • Please log in to reply
4 replies to this topic

#1 christurner

christurner

    Mariner 2

  • -----
  • Posts: 261
  • Joined: 24 Jun 2008
  • Loc: Nova Scotia, Canada

Posted 06 August 2013 - 03:00 PM

Any help folks would be truly appreciated....

Issue: Cannot get PHD/guider to function with ASCOM and thereforecannot guide scope for imaging.
Plat form details:
Mount: EQ6 Pro Mount
Guider: KWIQ guider, QHY5
Laptop: 32 bit machine running Windows Starter.
Software: ASCOM/EQMOD 5/6 v1.24g, PHD v1.1.14.0

Drivers Downloaded: QHY5ASCOM-V40, QHY5Drv64V13-05-30, QHY5UPDATE (THEY ARE ALL ZIPPED FILES).

Procedure:
First a bit of maintenance: I uninstalled any existing driver versions of QHY5. Went through this whole procedure maybe 5 or 6 times.
Then I went to the QHYCCD website and from their download link, I did a “save as” from the QHY5 category. I downloaded 3 zipfiles namely the Driver, its update and then the ASCOM file. After the download,I installed them in this order 1) Driver zip file 2)Driver Update zip file and then 3) the ASCOM zip file. Before installing them I made sure the guider was NOT connected as per the instructions.

After installing them I then hooked everything up to the mount and the laptop. I turned on the EQ6Pro mount and set it to PC direct mode. Then I started Cartes Du Ciel and gained access to the mount through EQMOD.Telescope initialization. No problem with controlling the mount with EQMOD.

When I started PHD from its icon desktop (not through BYE) I clicked on the camera icon and I selected "ASCOM (late) camera" as usual. It then goes to the ASCOM Camera Chooser and in the list is my guider (CMOS QHY5 Camera). I select it, click "properties" and click ok and then I get this ERROR: ASCOM driver problem during connection. I also have checked all cables and connections and everything is in its rightful place. Any ideas would be greatly appreciated....

#2 piaras

piaras

    Viking 1

  • -----
  • Posts: 827
  • Joined: 26 Jan 2009
  • Loc: Niagara Region

Posted 06 August 2013 - 04:14 PM

Did you enable Server something or other in PHD? See page 8.
Pierre
Backyard EOS Quick Start Guide
.


#3 Falcon-

Falcon-

    Aurora

  • *****
  • Posts: 4932
  • Joined: 11 Sep 2009
  • Loc: Gambier Island, BC, Canada

Posted 06 August 2013 - 04:23 PM

Do you have the latest version of the Ascom platform installed?

When you say you installed the zip files, I assume you mean you extracted the files from the zip archive and then ran the installer executable from the folder created when the zip archive was extracted?

If you go into Device Manager do you see any unrecognized devices? (in other words, is the system recognizing the QHY5 as a known device)

Have you tried using PHD's internal QHY5 selection instead of the ASCOM selection? (you can still use the Ascom option for connecting to the mount/eqmod)

#4 jsrj98

jsrj98

    Sputnik

  • -----
  • Posts: 29
  • Joined: 21 Feb 2008

Posted 06 August 2013 - 07:44 PM

Although I've moved on to the QHY5L-II (a much more sensitive camera I now need for OAG on an Edge8) I used the KWIQ/QHY5 for years with your setup. I never used the ASCOM driver, but selected "CCD-Labs Q-Guider" from the list of camera's in PHD. Works perfectly. Maybe try that before you continue to beat your head on the ASCOM route? If the little red light is "on" then you know the basic device driver is working on your PC. If it's not, then the issue is not ASCOM but a device driver problem.

#5 Tom and Beth

Tom and Beth

    Soyuz

  • -----
  • Posts: 3777
  • Joined: 08 Jan 2007
  • Loc: Tucson, AZ

Posted 07 August 2013 - 01:08 AM

Besides making sure you are running SP2 of ASCOM, are you using the latest Beta of PHD, which fixed an issue with the QHY camera?






Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics