Jump to content

  •  

CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.

Photo

HELP! Talking LX200 to a Mach1

  • Please log in to reply
1 reply to this topic

#1 orlyandico

orlyandico

    Fly Me to the Moon

  • *****
  • Moderators
  • topic starter
  • Posts: 7395
  • Joined: 10 Aug 2009
  • Loc: Singapore

Posted 19 December 2013 - 01:56 PM

I'm writing some Perl scripts to implement a ProTrack-like functionality for the Mach1.

My problem is I can't talk to the T%$%#! mount.

I have an FTDI USB to serial adapter. This works just fine with Ray Gralak's ASCOM v2 driver.

Now if I try to connect directly to the COM port (in Windows) with say Putty or Hyperterminal, with 9600/8N1 port settings, the mount won't talk to me.

But.. if I run the ASCOM setup and query the mount, after shutting down the ASCOM driver I can now connect with Putty etc. and I can talk to the mount... so long as I don't type in any "wrong" command.

The minute I type in a "wrong" command the terminal session freezes, and restarting Putty doesn't help - I have to reconnect the ASCOM driver.

Anybody...?

#2 orlyandico

orlyandico

    Fly Me to the Moon

  • *****
  • Moderators
  • topic starter
  • Posts: 7395
  • Joined: 10 Aug 2009
  • Loc: Singapore

Posted 19 December 2013 - 02:19 PM

ok solved my own problem. repeatedly sending a correct command will (eventually) shake the mount out of its stupor.


EDIT: arrggh. Spoke too soon. This trick works on Windows, but not on Linux. I want to eventually run my software on a small headless low-power Linux box (kind of like Anat's iAstroHub) so I need it working on Linux...


CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.


Recent Topics






Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics