Jump to content


Photo

AVX mount RA clutch lever

  • Please log in to reply
7 replies to this topic

#1 cruling

cruling

    Vostok 1

  • *****
  • Posts: 115
  • Joined: 23 Dec 2012
  • Loc: Jersey City, NJ

Posted 25 December 2013 - 12:57 AM

Hi,
i just got a AVX mount, the RA axis could not lock very well.
when i tighten the RA clutch lever really hard, i can still turn the RA axis with my bare hands, not very easily, i mean when i grab the CW shaft and push it a little harder, i can still turn it.
i remember my CG5 doesn't behave like this, when i tighten the clutch lever, i cannot turn that axis at all.
is there anything wrong with the mount?
Thanks!

Fan

#2 RTLR 12

RTLR 12

    Aurora

  • *****
  • Posts: 4569
  • Joined: 04 Dec 2008
  • Loc: The Great Pacific NorthWest

Posted 25 December 2013 - 01:02 AM

Remove the screw and the lever and "re-clock" (rotate) it so that you have more travel in the "Lock" position.

Stan

#3 cruling

cruling

    Vostok 1

  • *****
  • Posts: 115
  • Joined: 23 Dec 2012
  • Loc: Jersey City, NJ

Posted 25 December 2013 - 01:24 AM

Hi Stan, i have done that, it's didn't work.
i mean i have tighten the clutch lever really hard, it won't be any more tighter unless i change to a bigger lever. then if i grab the CW shaft at the middle, i can still turn the axis.

#4 mistyridge

mistyridge

    Gemini

  • *****
  • Posts: 3036
  • Joined: 28 Oct 2005
  • Loc: Loomis, CA

Posted 25 December 2013 - 01:36 AM

Remove ths lever and screw out the clutch bolt. you will find a black derlin plug on the tip. Clean the grease of the plug and reinstll the plug and bolt. The clutch should provide enough friction now.

#5 RTLR 12

RTLR 12

    Aurora

  • *****
  • Posts: 4569
  • Joined: 04 Dec 2008
  • Loc: The Great Pacific NorthWest

Posted 25 December 2013 - 02:51 AM

I had to go to the longer ADM clutch levers on my CGEMs in order to get a good lock on the clutches.

Stan

#6 cruling

cruling

    Vostok 1

  • *****
  • Posts: 115
  • Joined: 23 Dec 2012
  • Loc: Jersey City, NJ

Posted 25 December 2013 - 12:09 PM

Remove ths lever and screw out the clutch bolt. you will find a black derlin plug on the tip. Clean the grease of the plug and reinstll the plug and bolt. The clutch should provide enough friction now.

Hi Mike, i tried clean the grease on the plug, it didn't help, maybe some grease got onto the surface of the barrel inside the housing.
have to think of a way to clean it :question:

#7 cruling

cruling

    Vostok 1

  • *****
  • Posts: 115
  • Joined: 23 Dec 2012
  • Loc: Jersey City, NJ

Posted 25 December 2013 - 12:27 PM

I had to go to the longer ADM clutch levers on my CGEMs in order to get a good lock on the clutches.

Stan

Hi Stan, i try to remove the lever on my CG5, it's a little bigger, but something bad just happened, see here: http://www.cloudynig...6272113/page...

#8 dragonslayer1

dragonslayer1

    Apollo

  • -----
  • Posts: 1027
  • Joined: 25 Feb 2012
  • Loc: SLC, UT

Posted 25 December 2013 - 12:39 PM

is the square block and large threaded piece all one piece? or are they 2 pieces held together by the piece of remaining broken screw? Kasey






Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics