Jump to content


Photo

iAstroHub: Tablet astrophotography comes true!

  • Please log in to reply
428 replies to this topic

#426 anat

anat

    Viking 1

  • -----
  • Posts: 747
  • Joined: 03 Jun 2004

Posted 16 January 2015 - 07:04 PM

Yves,

 

Thanks for your update. Does gphoto2 2.5.6 also work? I don't have a DSLR to test it. Could you please try these steps?

 

sudo apt-get install subversion dh-autoreconf libusb-dev libusb-1.0-0-dev libexif-dev libpopt-dev libfuse-dev mono-devel monodoc-base libmono-2.0.1 mono-gmcs python-pyrex libglib2.0-dev

sudo mkdir /home/pi/gphoto
cd /home/pi/gphoto

wget http://sourceforge.n...o2-2.5.6.tar.gz
tar xvf libgphoto2-2.5.6.tar.gz
cd libgphoto2-2.5.6/
./configure --prefix=/usr
make
make install

wget http://sourceforge.n...o2-2.5.6.tar.gz
tar xvf gphoto2-2.5.6.tar.gz
cd gphoto2-2.5.6/
./configure --prefix=/usr
make
make install

ldconfig

 

 

Thank you. 

 

Best regards,

Anat



#427 uvphoton

uvphoton

    Lift Off

  • -----
  • Posts: 4
  • Joined: 30 Dec 2014

Posted 17 January 2015 - 10:11 AM

Hi Anat,

 

Gphoto2 does not work in your distribution (micro sd card) with my 1100D. I got the error reported in the last post. That is why I compiled 2.5.4.

I also get the same error when I compile by myself 2.5.6 on a fresh distribution of Linux installed on the NAND. I have followed the same commands as you suggested in the post.

I have also tried via the old procedure you have recommended in iastrohub v1 (gphoto-suite, then change dir gphoto2 and libgphoto2 and do a autoreconf) and only gphoto 2.5.4 works.

 

I will try again in a more recent version of ubuntu, but I believe that it is a bug for some dslr (reported elsewhere, but I don't remember where). I have tried a patch but it does not work either.

 

By the way, a good thing could be also to add the group plugdev for the current user (sudo adduser linuxium plugdev). Without plugdev, you have to be in sudo mode for running gphoto. While it is not mandatory for the web interface, it could be interesting if your need to try gphoto2 in ssh mode for example without using sudo.

 

If I remember well, I have also to modify your dslr.php script and uncomment the first line pasted below:

 

//passthru("sudo ./dslr &");
passthru("echo dslr > startdslr");

 

All the best

Yves



#428 Ed S

Ed S

    Lift Off

  • -----
  • Posts: 6
  • Joined: 26 Nov 2010

Posted 17 January 2015 - 11:06 AM

I'm happy to report that my CX919 is working now.  I haven't had a chance to hook anything up to it, but it connects to the router and my iPad is loading all of the iAstroHub pages.

 

I'm sure that I will have more questions, but things look good right now.

 

Thanks again for helping me out!



#429 Ed S

Ed S

    Lift Off

  • -----
  • Posts: 6
  • Joined: 26 Nov 2010

Posted 18 January 2015 - 12:04 PM

Does anyone know of (or would anyone be willing to make) some online video tutorials for iAstroHub? I have watched most of Anat's videos which are helpful, but since I'm generally new to astrophotography, there is only so much that I can learn without understanding the language. Alternatively, are there any plans for some more detailed documentation? If I actually knew how to use the software properly, I would be happy to help. I'm still happy to help proofread and check for accuracy.  I'm just curious if this has ever been planned or discussed.  I searched this thread for "tutorial", but only found one reference and that was to an older page and wasn't really a true IAH tutorial.

 

I'm loving this software and I'm committed to learning it because I think it's really going to pay off for me once I figure it all out.

 

Thanks!








Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics