Return to the Cloudy Nights Telescope Reviews home pageAstronomics discounts for Cloudy Nights members
· Get a Cloudy Nights T-Shirt · Submit a Review / Article

Click here if you are having trouble logging into the forums

Privacy Policy | Please read our Terms of Service | Signup and Troubleshooting FAQ | Problems? PM a Red or a Green Gu… uh, User

Astrophotography and Sketching >> DSLR & Digital Camera Astro Imaging & Processing

Pages: 1 | 2 | 3 | 4 | 5 | (show all)
srosenfraz
Post Laureate
*****

Reged: 03/06/11

Loc: United States
Re: I am doing something very very wrong new [Re: ICallHimGamblor]
      #6121375 - 10/06/13 09:49 PM

Quote:

Are you sure? I am looking at my bias frames, and they are all dark, and I look at the master offset in DSS and it is dark as dark can be.

As I recall, I took them at 1/2000 shutter speed with the lens cap on in my office, captured using BackyardEOS. I am not sure if somehow somewhere they got mixed up, but they look fine in the directory on my drive.




Your procedure you describe for capturing your bias sounds correct. However, if you look at the file you posted on your Google drive named "MasterOffset_ISO800.tif", its definitely not a dark file.

I'm not sure if somehow you may have posted the wrong file or named it incorrectly, but I think you'll want to figure out why the file you posted as a Master bias is not a dark file. Perhaps its related to the problem, perhaps not. But, if you used the file you posted on Google as a bias frame, it would definitely have ill effects on your stacked image.


Post Extras: Print Post   Remind Me!   Notify Moderator  
akulapanam
super member


Reged: 08/27/12

Re: I am doing something very very wrong new [Re: Tonk]
      #6121377 - 10/06/13 09:52 PM

Quote:

First don't save your file from DSS instead make a copy of the autosave.tif and then use imagemagick to convert it to 16 bit. My understanding is that DSS has a bug in the 16bit save routine.




Reference is below. I have seen a huge improvement using the method suggested to bypass the bug.

http://www.astronomyforum.net/astrophotography-image-processing-forum/154722-...




Edited by akulapanam (10/06/13 09:53 PM)


Post Extras: Print Post   Remind Me!   Notify Moderator  
srosenfraz
Post Laureate
*****

Reged: 03/06/11

Loc: United States
Re: I am doing something very very wrong new [Re: ICallHimGamblor]
      #6121388 - 10/06/13 10:03 PM

Quote:

Here is a link to a screen shot of my master offset in DSS:

https://drive.google.com/#folders/0By0hG91nGRL9ckxUeXAxUXdTLTQ




Yes, that looks exactly like the image when I debayered your MasterOffset.tif file. The 8 bit RGB values SHOULD be (0,0,0), but the RGB values for your Masteroffset.png file are (96,38,54). I suspect you've been using an invalid bias frame since 6/28/13 (date on your file).

Just for giggles, why don't you try restacking your Stephan's Quintet without using the bias frame. Its not optimal, but I suspect it would be better than what you have. Alternatively, take a minute and try recapturing 30 or so bias frames with the camera and create a new Master Bias. Then restack your Stephan's Quintet.


Post Extras: Print Post   Remind Me!   Notify Moderator  
ICallHimGamblor
super member


Reged: 06/24/13

Re: I am doing something very very wrong new [Re: akulapanam]
      #6121432 - 10/06/13 10:34 PM

Quote:

Quote:

First don't save your file from DSS instead make a copy of the autosave.tif and then use imagemagick to convert it to 16 bit. My understanding is that DSS has a bug in the 16bit save routine.




Reference is below. I have seen a huge improvement using the method suggested to bypass the bug.

http://www.astronomyforum.net/astrophotography-image-processing-forum/154722-...







I couldn't get past the disgusting ad for toenail fungus.


Post Extras: Print Post   Remind Me!   Notify Moderator  
ICallHimGamblor
super member


Reged: 06/24/13

Re: I am doing something very very wrong new [Re: srosenfraz]
      #6121471 - 10/06/13 10:56 PM

I restacked everything with unchecked biases and posted to the folder: https://docs.google.com/file/d/0By0hG91nGRL9SkVmUGJJWW4zQ2s/edit?usp=sharing

My 'other job' is a sports handicapper and involves buying shots and drinking with sports betters, so I no longer have the appropriate blood alcohol level to process it myself but I will give it a shot tomorrow after work, and I will retake my biases if someone can tell me what I did wrong... I thought biases were the easy ones.


Post Extras: Print Post   Remind Me!   Notify Moderator  
Tonk
Postmaster
*****

Reged: 08/19/04

Loc: Leeds, UK, 54N
Re: I am doing something very very wrong new [Re: ICallHimGamblor]
      #6121722 - 10/07/13 04:39 AM

Quote:

Reference is below. I have seen a huge improvement using the method suggested to bypass the bug.





Thanks for the link - but it turns out I can't actually see what is said as the site blocks me unless I sell my soul to them. I'm not going to play that game unfortunately

Meantime I suspect the bug may be related to not disabling the application of DSS's stretch function - its an option that is frequently missed by users that don't follow the ins and outs of DSS. This stretch isn't applied to the autosave TIFF - however if you tick the right option boxes is also NOT applied to the 16 bit TIFF save command.

It is well known (to a degree) that DSS's stretch function is far from optimal and degrades the ability to perform further downstream post processing. So the simple solution is to turn it off and not do the long walk around the block

One thing you haven't said - which DSS version was this problem reported and which were you using? I do not use the latest as the newest versions have broken part of the comet stacking (the frames which have been comet marked are no longer displayed with the (C) markers on the user interface - which is a pity)


Post Extras: Print Post   Remind Me!   Notify Moderator  
shawnhar
Postmaster
*****

Reged: 06/25/10

Loc: Knoxville, TN
Re: I am doing something very very wrong new [Re: Tonk]
      #6122306 - 10/07/13 12:14 PM

Here ya go Tonk, formt he link listed above:
I've received a few requests for this information so I thought I'd post this mini-tutorial.

Things you need to know:

1) Because of a bug in DSS, the "File - Save As" command does not create a high-quality file. It creates a 16-bit tif wrapper with 8-bit data inside it. Eventually this bug should get fixed. Until it does, for the best possible data out of DSS you need to use the Autosave.tif file that it creates automatically after stacking is completed.

2) The Autosave.tif file is itself problematic. It contains 16-bits of real data + 16-bits of zeroes within a 32-bit tif wrapper (quite why it does this is unclear).

3) Some editing/AP packages can handle this format without any problems... PixInsight for example. Photoshop can also handle it UP TO A POINT although presumably it will think that the 32-bit data indicates an HDR (High Dynamic Range) image file that it can open for display purposes but do nothing else with until it is converted to 16-bit data (within Photoshop itself).

4) Some editing/AP packages will not open the Autosave.tif file at all.

5) Unless you use an Editing/AP package that can handle the 32-bit Autosave.tif file your best course of action is to convert the file to a true 16-bit tif file. A convenient tool for doing this conversion with no quality loss is ImageMagick


Using ImageMagick

I am no expert in IM. I only use it for this one specific task (in fact, to be honest I don't use it at all because I use PixInsight... but it is a handy tool to have around).

To install IM, go to the ImageMagick site and follow the download and install instructions. There are separate versions for Win32 and Win64 - make sure you get the correct one - see first attachment. Also get the "static" versions (ignore the other versions).

IM is a powerful suite of tools of which we are going to use precisely one; the "Convert" tool.

IM runs from the Windows command line - no fancy GUI here!

To use IM, do the following:

1) open a Windows Command session (type "CMD" into the "search programs and files" box on the Start Menu)
navigate to the Drive/folder containing your autosave.tif file using trusty old DOS commands (I'm going to assume you know how to do this...)

2) type: convert autosave.tif -depth 16 yournewfilename.tif (then hit "enter")

3) wait a few seconds (you may get some warning messages - you can completely ignore them... they are caused by the way that DSS creates the autosave.tif file)

4) a DIR command will show you the new file which will be ~half the size of the original, as you would expect

See second attachment.

That's it. Done. Enjoy
Phil


Post Extras: Print Post   Remind Me!   Notify Moderator  
Pete GLA
sage


Reged: 12/20/07

Loc: South of Detroit MI
Re: I am doing something very very wrong new [Re: ICallHimGamblor]
      #6123168 - 10/07/13 05:31 PM

Quote:






Can someone do an autopsy on this image to figure out what I am doing wrong?

Thanks.




I am not a regular imager, but being in a red-white zone myself, and if trying the Quintet (or any other DSO), i'd get the same result.

Your 3 minutes @ ISO 400 closely matches my settings...

A typical session allows me to do 3'.5 @ ISO 400, 2'.5 @ 640 and around 2' @ 800.

Going 5' @ ISO 800... well the peak on the histogram is going be at least 66%...

What you could try is image opposite light domes...I have Downtown Detroit 2 miles west of me, so I don't do any imaging to the west.

You're doing nothing wrong...just wrong place!!!

This is my experience.

Pete

OOPS...Didn't read all of the responses...

Edited by Pete GLA (10/07/13 06:00 PM)


Post Extras: Print Post   Remind Me!   Notify Moderator  
Tonk
Postmaster
*****

Reged: 08/19/04

Loc: Leeds, UK, 54N
Re: I am doing something very very wrong new [Re: shawnhar]
      #6123237 - 10/07/13 05:52 PM

Quote:

The Autosave.tif file is itself problematic. It contains 16-bits of real data + 16-bits of zeroes within a 32-bit tif wrapper (quite why it does this is unclear).




Quote:

Some editing/AP packages will not open the Autosave.tif file at all.




Why this is so is easy - its a private TIFF format that DSS uses to cache intermediate data during stacking and for reloading once the stacking is done - its not designed for users to play with. Hence many programs can't deal with it.

Quote:

Because of a bug in DSS, the "File - Save As" command does not create a high-quality file. It creates a 16-bit tif wrapper with 8-bit data inside it.




I find this troubling as this is not my experience at all. At least the evidence when opening a 16 bit in Images plus is contrary to this - e.g. the histogram data statistics do not concur and there are no gaps (combing) which is what you would expect with an 8 bit depth file maskerading as a 16 bit file.

If this is really the case then posterization of brightness data after even a basic stretch would be very evident (like it is in GIMP which is still stuck at 8 bits). I don't see this after any sort of stretching in Images Plus ... so it is now greatly puzzling me why we are just hearing of this.

Which makes me think that if there is a bug it may be down to specific types of RAW file input (i.e. from a particular camera model) The only thing I can think might be an issue is if some has been using a newer model camera and hasn't picked up the DSS beta with the newest DCRaw program - i.e. the problem actually lies with using an too old version of the DCraw program that DSS uses.

It would be interesting if more information was available - camera used etc


I've just done an intensive Google on this issue and I can find nothing else reported or said by anyone. The nearest is Sander Pool (DSS Yahoo Groups guru) mentioning that post processing in GIMP is limited by it 8 bit depth. I would have though if anyone was going to make a song+dance of this bug Sander would!



Post Extras: Print Post   Remind Me!   Notify Moderator  
ICallHimGamblor
super member


Reged: 06/24/13

Re: I am doing something very very wrong new [Re: Tonk]
      #6123610 - 10/07/13 09:05 PM

I created a new set of biases and restacked it.

Here is the new master offset: https://docs.google.com/file/d/0By0hG91nGRL9VDBuamdHN3dGMXc/edit?usp=sharing

And the new stack: https://docs.google.com/file/d/0By0hG91nGRL9QzJaOWpBQlJ6X2s/edit?usp=sharing

It looks better to me, but I really am not sure.

Did this solve the calibration issue?


Post Extras: Print Post   Remind Me!   Notify Moderator  
bunyon
Post Laureate
*****

Reged: 10/23/10

Loc: Winston-Salem, NC
Re: I am doing something very very wrong new [Re: ICallHimGamblor]
      #6123633 - 10/07/13 09:18 PM

I'm no expert, but I'd try just stacking the lights and see how it looks. That is, no calibration. That would tell you if the calibration frames are a problem.

Post Extras: Print Post   Remind Me!   Notify Moderator  
akulapanam
super member


Reged: 08/27/12

Re: I am doing something very very wrong new [Re: Tonk]
      #6123762 - 10/07/13 10:53 PM

Quote:

Quote:

The Autosave.tif file is itself problematic. It contains 16-bits of real data + 16-bits of zeroes within a 32-bit tif wrapper (quite why it does this is unclear).




Quote:

Some editing/AP packages will not open the Autosave.tif file at all.




Why this is so is easy - its a private TIFF format that DSS uses to cache intermediate data during stacking and for reloading once the stacking is done - its not designed for users to play with. Hence many programs can't deal with it.

Quote:

Because of a bug in DSS, the "File - Save As" command does not create a high-quality file. It creates a 16-bit tif wrapper with 8-bit data inside it.




I find this troubling as this is not my experience at all. At least the evidence when opening a 16 bit in Images plus is contrary to this - e.g. the histogram data statistics do not concur and there are no gaps (combing) which is what you would expect with an 8 bit depth file maskerading as a 16 bit file.

If this is really the case then posterization of brightness data after even a basic stretch would be very evident (like it is in GIMP which is still stuck at 8 bits). I don't see this after any sort of stretching in Images Plus ... so it is now greatly puzzling me why we are just hearing of this.

Which makes me think that if there is a bug it may be down to specific types of RAW file input (i.e. from a particular camera model) The only thing I can think might be an issue is if some has been using a newer model camera and hasn't picked up the DSS beta with the newest DCRaw program - i.e. the problem actually lies with using an too old version of the DCraw program that DSS uses.

It would be interesting if more information was available - camera used etc


I've just done an intensive Google on this issue and I can find nothing else reported or said by anyone. The nearest is Sander Pool (DSS Yahoo Groups guru) mentioning that post processing in GIMP is limited by it 8 bit depth. I would have though if anyone was going to make a song+dance of this bug Sander would!






There are several threads on astronomyforum that detail the issue with photos. I'm sure that their is at least one in DSS on yahoo because I believe I posted in the thread. When I get a sec I'll post links for you but you will have to register.


Post Extras: Print Post   Remind Me!   Notify Moderator  
Tonk
Postmaster
*****

Reged: 08/19/04

Loc: Leeds, UK, 54N
Re: I am doing something very very wrong new [Re: akulapanam]
      #6124109 - 10/08/13 04:05 AM

Quote:

Eventually this bug should get fixed. Until it does, for the best possible data out of DSS you need to use the Autosave.tif file that it creates automatically after stacking is completed.




So has Luc acknowledged this bug and given a indication of when it will be fixed? Do you have a link to the bug report?


Post Extras: Print Post   Remind Me!   Notify Moderator  
shawnhar
Postmaster
*****

Reged: 06/25/10

Loc: Knoxville, TN
Re: I am doing something very very wrong new [Re: Tonk]
      #6124981 - 10/08/13 01:45 PM

I'm with Tonk, I think this is mis-informed info, someone is confused about 8bit vs 16bit. I tried the "fix" of converting the autosave from DSS to a 16bit tiff and saw no difference whatsoever at 100% zoom between that and the regular output tiff.
8 bit sucks, even when in a 16 bit wrapper, you will know 8 bit instantly when you stretch because it looks like Nintendo, the 1st one.


Post Extras: Print Post   Remind Me!   Notify Moderator  
Tonk
Postmaster
*****

Reged: 08/19/04

Loc: Leeds, UK, 54N
Re: I am doing something very very wrong new [Re: shawnhar]
      #6126465 - 10/09/13 07:42 AM

Quote:

I think this is mis-informed info, someone is confused about 8bit vs 16bit.




+1. The so called bug is bogus. Just done my own checks via the data "fix" - like you no difference found.


Post Extras: Print Post   Remind Me!   Notify Moderator  
ICallHimGamblor
super member


Reged: 06/24/13

Re: I am doing something very very wrong new [Re: Tonk]
      #6126525 - 10/09/13 08:36 AM

So did my new biases fix my calibration issue? It looks better when I auto-dev in StarTools, but I still can't get much data out of it.

Post Extras: Print Post   Remind Me!   Notify Moderator  
shawnhar
Postmaster
*****

Reged: 06/25/10

Loc: Knoxville, TN
Re: I am doing something very very wrong new [Re: ICallHimGamblor]
      #6126898 - 10/09/13 12:29 PM

I tried it and it has the same gradients...

Post Extras: Print Post   Remind Me!   Notify Moderator  
ICallHimGamblor
super member


Reged: 06/24/13

Re: I am doing something very very wrong new [Re: shawnhar]
      #6126957 - 10/09/13 01:04 PM

In that case, I am kinda stuck. I don't know what to try next. Any suggestions would be greatly appreciated.

Can I go longer on subs? Should I bump ISO to 800? How important is the pointer that I read that the histogram of the subs should be about 1/3 of the spectrum?


Post Extras: Print Post   Remind Me!   Notify Moderator  
pfile
Post Laureate


Reged: 06/14/09

Re: I am doing something very very wrong new [Re: ICallHimGamblor]
      #6127073 - 10/09/13 01:59 PM

the gradients in this image are completely wild... are you sure that the subs were not taken thru clouds or that some of the subs have trees or a house or something in them?

Post Extras: Print Post   Remind Me!   Notify Moderator  
shawnhar
Postmaster
*****

Reged: 06/25/10

Loc: Knoxville, TN
Re: I am doing something very very wrong new [Re: pfile]
      #6127235 - 10/09/13 03:13 PM Attachment (2 downloads)

1st, stack without the flats, I would start there, have taken more than my share of bad flats, they are easy to get wrong.
2nd, I have taken pics where the histo was over half and ones where it was on the left wall. The ones one the left wall will be noisy as all get out, the ones over half will have a horrible washed out look that can be difficult to deal with, but it's better than being jammed up against the wall or limited to 2 minute subs. I have also dropped to iso 400 to get 10 minute subs and they came out fine.
Try iso 400 and go as long as you can without going over halfway on the histo and you will be fine.
Those gradients on the other hand...you gotta figure out what is causing that. Start with the flats, if that ain't it, maybe what is in your area that is casting light on your lens? My money is now on the flats.
Other than the gradient I think you are getting good data.


Post Extras: Print Post   Remind Me!   Notify Moderator  
Pages: 1 | 2 | 3 | 4 | 5 | (show all)


Extra information
8 registered and 21 anonymous users are browsing this forum.

Moderator:  Dave M, WOBentley, tecmage 

Print Thread

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled


Thread views: 1957

Jump to

CN Forums Home


Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics