Return to the Cloudy Nights Telescope Reviews home page


Telescope Specific Forums >> Meade Computerized Telescopes

Pages: 1 | 2 | (show all)
TheWabbit
journeyman


Reged: 05/31/11

12" LX200 classic with fuse problems
      #4613953 - 05/31/11 10:32 PM

First post here so howdy everyone.

I have a 12" LX200 Classic that has not been used for a few years. My son is now old enough to enjoy the night sky so I pulled it out last night. Unfortunately, the scope is having some electrical issues. The scope keypad died then the base unit stopped worked. While I was checking the power cord, the fuse box was really hot. After it cooled, it was obvious the external fuse blew. I pulled the base circuit board out and the interior fuse looks to be okay.

After reviewing the net for possible fixes, I found:

http://www.bbcl03736.pwp.blueyonder.co.uk/LX200%20Faults.htm

"Symptom:- Fuse blowing, either externally or the fuse mounted behind the Power Panel.

This is most probably caused by the failure of one of five components, all of which should be replaced to effect a lasting repair. It is the result of component failure of C1 on the Power Panel and/or C8 on the Processor Card (near the 5v regulator) and/or C2 in the hand controller and/or C1 on the DEC/RA motor control board. These are Tantalum Capacitors, normally fawn in colour, and are polarity conscious. Replace with 10uF 35volt working Tantalum or Electrolytic. (Please note that the capacitor in the hand controller has a tendency to burn through the keypad membrane when it goes faulty, rendering the handset useless and unrepairable..."

Before I begin surgery on my LX200, I want to confirm that this is a known problem and replacing the capacitors with 10uF 35v will fix the problem.

The site has a bunch of other suggestions to do to the board but I'm not familiar enough with electronics to do them. Are they critical?


Post Extras: Print Post   Remind Me!   Notify Moderator  
George D
Vendor
*****

Reged: 04/13/10

Loc: So Cal
Re: 12" LX200 classic with fuse problems new [Re: TheWabbit]
      #4614282 - 06/01/11 03:58 AM

It's common to have tantalum capacitors fail in the LX200 Classic. It could be due to age but also due to the fact that most of the original caps were only rated for 25 VDC. That should have been fine, but for the fact that the 18 VDC power unit is unregulated and often spikes or stabilizes at voltages higher than 25 volts.
When the caps fail, they often short out. They also go up in flames at times, doing some very major damage.
You can replace them with any type of electrolytic that is at least 10uf and 35 VDC. The tolerance isn't critical but the size/fit may be a challenge with higher rated caps.

Go for it! They're easy to replace and relatively inexpensive.

My three rules to live by;
1. Elephants have the right of way.
2. Stay away from women with tattoos.
3. There's nothing I can break so badly that a new one wouldn't fix.

OK; Number two is no longer valid and number three is the main one for this topic.
Good luck!


Post Extras: Print Post   Remind Me!   Notify Moderator  
TheWabbit
journeyman


Reged: 05/31/11

Re: 12" LX200 classic with fuse problems new [Re: George D]
      #4614599 - 06/01/11 10:04 AM

Thanks for the response. This goes from bad to worse. I was disassembling the parts of my scope to replace the capacitors when I found the one that exploded. It was the hand controller capacitor at C2 and it burned through the membrane.

Link to oversize picture

(Edit to link due to image dimensions exceeding TOS. BRisley)

Has anyone figure out a solution to repair the handset? Others have said it make the handset unusable but hoping someone has figured out a workaround.

If I use the RS232 port, can a computer still drive the scope without the handset?

Edited by BRisley (09/20/11 10:08 AM)


Post Extras: Print Post   Remind Me!   Notify Moderator  
StarGeazer
sage


Reged: 11/23/10

Loc: Cross Junction, VA, USA
Re: 12" LX200 classic with fuse problems new [Re: TheWabbit]
      #4614941 - 06/01/11 01:13 PM

OUCH!!!!!!!

Bummer dude!

I believe that you can. Actually I think Stellarium will drive it. Hopefully someone more experienced will give you a definitive answer on that.

Actually there is another option. George D has an upgrade kit that I think uses the updated Autostar controller.

George D? Calling Dr. George!

Anyone....anyone....

Bueller......Bueller.....


Post Extras: Print Post   Remind Me!   Notify Moderator  
TheWabbit
journeyman


Reged: 05/31/11

Re: 12" LX200 classic with fuse problems new [Re: StarGeazer]
      #4614962 - 06/01/11 01:21 PM

Thanks StarGeazer. I just talked to George via email. I also talked to Meade and they said sorry and how about paying us $2339 and give us your scope for a new 12". I don't think so. Once all this gets settled; repair or upgrade, no more Meade anything for me.

Post Extras: Print Post   Remind Me!   Notify Moderator  
StarGeazer
sage


Reged: 11/23/10

Loc: Cross Junction, VA, USA
Re: 12" LX200 classic with fuse problems new [Re: TheWabbit]
      #4614994 - 06/01/11 01:33 PM

Yeah, Meade doesn't have a great rep on their support side. Sorry to hear that. I do still love my classic though. I just know I am on my own when it comes to repairs. But then, I do have a 12 year old scope.

There are some other folks out there that do repairs. You might want to check on the Yahoo LX200 group for more information if you would want to go that route.

Seems to me I have seen the old handset on eBay too. You just never know what you can find out there.


Post Extras: Print Post   Remind Me!   Notify Moderator  
Naturlich
Carpal Tunnel


Reged: 10/30/09

Loc: Dukinfield, Cheshire, UK
Re: 12" LX200 classic with fuse problems new [Re: StarGeazer]
      #4615000 - 06/01/11 01:36 PM

Hey wabbit, I had the same thing with my 10" classic, replacement handsets are very rare and not cheap, the solution I chose is part of my signature block (link there), I upgraded the control systems with Georges most excellent Autostar Upgrade Kit, so now my LX200 Classic is running Autostar 497. It does exactly what it says on the tin, it replaces your Classic control boards/handset with a new control system and 497 handset. I was one of the first group of people to get this upgrade and it's worked flawlessly since the day I installed it, ofcourse George never sits back, and his latest version is even better and with extra functionality. I believe it's worth you checking out for sure, especially with how bad things have gotten for your LX.

I'll be keeping my fingers crossed for you breathing life back into your Classic!

Nat


Post Extras: Print Post   Remind Me!   Notify Moderator  
Naturlich
Carpal Tunnel


Reged: 10/30/09

Loc: Dukinfield, Cheshire, UK
Re: 12" LX200 classic with fuse problems new [Re: StarGeazer]
      #4615011 - 06/01/11 01:44 PM

Quote:

Yeah, Meade doesn't have a great rep on their support side. Sorry to hear that. I do still love my classic though. I just know I am on my own when it comes to repairs. But then, I do have a 12 year old scope.

There are some other folks out there that do repairs. You might want to check on the Yahoo LX200 group for more information if you would want to go that route.

Seems to me I have seen the old handset on eBay too. You just never know what you can find out there.




Yeah the Classics are so old now even with bad support to start with, at this age, there just isn't any at all from Meade.

I'm starting my Bearing upgrade and just finished stripping them down ready to take to the machine shop for boring out, that'll sort out the Dec axis and get it realy smooth. When my LX200 died I couldn't find any handsets anywhere so I went ahead and upgraded with George, and although I later found a handset, it was half the price of my complete upgrade! So glad I did the upgrade though, because my "support" is now George, who is infinately more helpful and reliable even my handset isn't running meade firmware anymore LOL

But I've put alot of effort into this Classic, and I fully believe it's worth it, the gears and overal setup is rock solid, with my bearing upgrade to needle instead of crapy plastic sleeves, and the upgraded electronics, I've got the solid Classic running very modern bearings and controls, couldn't ask for more (other than a bigger telescope!)


Post Extras: Print Post   Remind Me!   Notify Moderator  
George D
Vendor
*****

Reged: 04/13/10

Loc: So Cal
Re: 12" LX200 classic with fuse problems new [Re: Naturlich]
      #4615076 - 06/01/11 02:20 PM

The Meade products are actually pretty good these days. Remember, you're dealing with 90's technology there.
As for their customer relations and service, they seem to be in a state of flux. I think they are struggling in this poor economy, just like many "specialty" companies are. They would do well to get some good marketing advice and follow it.

I think you can repair that handset. You'll have to cobble something together on the ribbon cable but it can at least get you working again I'll bet. That cap is most likely shorting your power system.


Post Extras: Print Post   Remind Me!   Notify Moderator  
TheWabbit
journeyman


Reged: 05/31/11

Re: 12" LX200 classic with fuse problems new [Re: George D]
      #4615666 - 06/01/11 09:22 PM

Good news. The wife understands that my scope needs to be fixed so I'll be emailing you tonight George.

Post Extras: Print Post   Remind Me!   Notify Moderator  
StarGeazer
sage


Reged: 11/23/10

Loc: Cross Junction, VA, USA
Re: 12" LX200 classic with fuse problems new [Re: TheWabbit]
      #4616492 - 06/02/11 11:37 AM

Even with all the optics upgrades and coma corection in the newer scopes, I keep hearing these old Classics are a solid overall product. I think mine will be with me for a long time to come. If the elecronics ever finally blows a major cork, I guess it will be new mount time.

Of course, these are my current feelings, only having about a years worth of ownership and still having been through the cap replacement thing.


Post Extras: Print Post   Remind Me!   Notify Moderator  
altair1956
sage
*****

Reged: 07/05/09

Loc: Light polluted central Mass
Re: 12" LX200 classic with fuse problems new [Re: StarGeazer]
      #4617261 - 06/02/11 07:17 PM

There is a guy in Massachusetts who has been repairing LX200's for years. He also has a supplier who can provide new handset overlays. I just had him go thru my 12 inch electronics and replace all the capacitors for me and install a new overlay. VERY nice work, very reliable. The overlay and cable can be gotten from him for around $50 or you can send him the electronics and he can repair for you.
His name is Ron Sampson, rsampsonus@yahoo.com.
He has been doing this type of repair work for about 10+ years and has 3 LX200's of his own.Also try the LX200 users yahoo group. Ron is on that a lot and can be reached that way also.

Edited by altair1956 (06/02/11 07:23 PM)


Post Extras: Print Post   Remind Me!   Notify Moderator  
erniewan
member


Reged: 11/08/10

Loc: Rocky River, Ohio
Re: 12" LX200 classic with fuse problems new [Re: altair1956]
      #4617594 - 06/02/11 10:48 PM

+1 for Ron's work. Ron has upgraded the caps on my 10 and 12 inch classics, as well as replacing the main cap on both of my AC adaptors.

Great work, and quick turnaround.


Post Extras: Print Post   Remind Me!   Notify Moderator  
TheWabbit
journeyman


Reged: 05/31/11

Re: 12" LX200 classic with fuse problems new [Re: erniewan]
      #4628180 - 06/08/11 01:06 PM

Thanks for the advice everyone. I purchased George's upgrade and the scope is working like a charm. Unfortunately, the mosquitoes had a feast on me when I took the scope out to test it.

The Autostar will take getting used to but what it does so far.


Post Extras: Print Post   Remind Me!   Notify Moderator  
Naturlich
Carpal Tunnel


Reged: 10/30/09

Loc: Dukinfield, Cheshire, UK
Re: 12" LX200 classic with fuse problems new [Re: TheWabbit]
      #4628265 - 06/08/11 01:38 PM

Cool Wabbit! So as per system requirements, the minute you get somthing for astronomy, the weather turns bad LOL I'm sure you'll be real happy with it once you get it under some stars

Clear Skies!

Nat


Post Extras: Print Post   Remind Me!   Notify Moderator  
LoveChina61
scholastic sledgehammer
*****

Reged: 06/20/09

Re: 12" LX200 classic with fuse problems new [Re: TheWabbit]
      #4665659 - 06/29/11 08:26 PM

I replaced the same capacitors on my handset before they blew out. The best advice I received before attempting that was simply to clip the old capacitor off high up on the legs and then solder the new capacitor onto the protruding legs of the old one.

A similar ribbon on my latop burnt through like that, and some local Chinese guy at the computer store fixed it for me. He used very thin plastic-coated copper wires to bridge the burn gap for each and every tiny circuitry thread/trail. Then he just taped the wires down with a piece of electrical tape so they would not easily come loose. It was nigh unto performing surgery, but the final results were fantastic and I have not had any problem with it since.

I'm not sure that I would be brave enough to try it, but it can be done. Since the handset is worthless without it anyway, if you want to mail the ribbon over here to me via snail-mail to give it a try, I can run it on over to the computer store for some emergency surgery to see if he can perform surgery on it. He probably wouldn't charge me more than a few bucks so I'm not worried about the cost on my end.


Post Extras: Print Post   Remind Me!   Notify Moderator  
jcarr
newbie


Reged: 06/12/11

Loc: Sandusky, Ohio
Re: 12" LX200 classic with fuse problems new [Re: LoveChina61]
      #4817081 - 09/19/11 08:53 PM

My 12" LX200 classic will be arriving within the next few days. Currently all the electronics are functional. Is there a setup I should do to thwart the dreaded "tantalum capacitor" issue? (I would rather have $50 worth of preventative maintenance than $500 of repair/replacement!)
Thanks!


Post Extras: Print Post   Remind Me!   Notify Moderator  
Christopher EricksonModerator
Carpal Tunnel
*****

Reged: 05/08/06

Loc: Waikoloa Village, Hawaii
Re: 12" LX200 classic with fuse problems new [Re: jcarr]
      #4817100 - 09/19/11 09:10 PM

Quote:

My 12" LX200 classic will be arriving within the next few days. Currently all the electronics are functional. Is there a setup I should do to thwart the dreaded "tantalum capacitor" issue? (I would rather have $50 worth of preventative maintenance than $500 of repair/replacement!)
Thanks!




You can open up the hand controller and replace the caps with higher-voltage versions before powering up the scope for the first time.


Post Extras: Print Post   Remind Me!   Notify Moderator  
jcarr
newbie


Reged: 06/12/11

Loc: Sandusky, Ohio
Re: 12" LX200 classic with fuse problems new [Re: Christopher Erickson]
      #4817838 - 09/20/11 10:37 AM

Thanks Chris for the quick reply... I did some electronics about 20 years ago in the Navy surface fleet, but was really hoping for something along the hardware side I guess (I think I have a soldering iron around here somewhere, oh wait that's a propane torch... this is going to be ugly)...

Post Extras: Print Post   Remind Me!   Notify Moderator  
Christopher EricksonModerator
Carpal Tunnel
*****

Reged: 05/08/06

Loc: Waikoloa Village, Hawaii
Re: 12" LX200 classic with fuse problems new [Re: jcarr]
      #4818272 - 09/20/11 02:02 PM

Quote:

Thanks Chris for the quick reply... I did some electronics about 20 years ago in the Navy surface fleet, but was really hoping for something along the hardware side I guess (I think I have a soldering iron around here somewhere, oh wait that's a propane torch... this is going to be ugly)...




Do you have any nearby friends who are into ham radio or general electronics?


Post Extras: Print Post   Remind Me!   Notify Moderator  
Pages: 1 | 2 | (show all)


Extra information
4 registered and 6 anonymous users are browsing this forum.

Moderator:  Starman27, Christopher Erickson, Starman81 

Print Thread

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled


Thread views: 7050

Jump to

CN Forums Home




Cloudy Nights Sponsor: Astronomics