Return to the Cloudy Nights Telescope Reviews home pageAstronomics discounts for Cloudy Nights members
· Get a Cloudy Nights T-Shirt · Submit a Review / Article

Click here if you are having trouble logging into the forums

Privacy Policy | Please read our Terms of Service | Signup and Troubleshooting FAQ | Problems? PM a Red or a Green Gu… uh, User

Equipment Discussions >> Mounts

Pages: 1 | 2 | (show all)
slookabill
member


Reged: 11/08/13

Loc: Little Rock, AR, USA
AHHH! Broke my CGEM
      #6324870 - 01/20/14 07:56 PM

Well, just as I finished setting up tonight and starting the 2 star polar alignment on my CGEM, I tripped over the AC power cord, yanking it out.

After inspection, it appears the ring that screws on has both pulled off, and part of it broke inside the power socket, and the rod in the middle is now bent.

Does anyone have any advice on how to get it fixed? I might be able to fix it with glue and some needle nose pliers, but I'm not sure if a) I should, and b) how to do it completely correctly. (I bought it at the end of November)


Post Extras: Print Post   Remind Me!   Notify Moderator  
Skunky
sage


Reged: 09/16/13

Re: AHHH! Broke my CGEM new [Re: slookabill]
      #6324877 - 01/20/14 08:00 PM

Call celestron and see if they will fix it? Try to fiddle with it?

That part is not cheap.. the power connector is part of the CGEM MC Board

http://www.celestron.com/astronomy/cgem-mc-compatible-only-for-the-cgem-serie...


Post Extras: Print Post   Remind Me!   Notify Moderator  
payner
scholastic sledgehammer
*****

Reged: 03/22/07

Loc: Bluegrass Region, Kentucky
Re: AHHH! Broke my CGEM new [Re: slookabill]
      #6324883 - 01/20/14 08:01 PM

Scott: Without seeing and assessing it I can't offer a fix. Obviously if you can set the rod straight and rewire then you should be good to go (I know, you realize that). Anyway, I'm sorry the accident happened and hope you get it in good order soon. Someone will chime-in with real help.

Best,
Randy


Post Extras: Print Post   Remind Me!   Notify Moderator  
slookabill
member


Reged: 11/08/13

Loc: Little Rock, AR, USA
Re: AHHH! Broke my CGEM new [Re: payner]
      #6324914 - 01/20/14 08:13 PM Attachment (56 downloads)

Here's a few of the pictures

Post Extras: Print Post   Remind Me!   Notify Moderator  
Falcon-
Post Laureate
*****

Reged: 09/11/09

Loc: Gambier Island, BC, Canada
Re: AHHH! Broke my CGEM new [Re: slookabill]
      #6325013 - 01/20/14 08:48 PM

Quote:

Here's a few of the pictures




Ouch. That does look like the part needs replacing rather then just trying to straiten the inner pin. That outer ring that broke off is the negative contact while the inner pin is positive, you do need both.

How are you with soldering? Looking at the picture of the board the power connector is attached to it appears to be a relatively simple re-solder job. That power connector is a relatively standard part you can order from a local electronics store or from a supplier like digikey. Cost would be something in the general area of of $5 for the part.

There is a chance that the board behind suffered damage as well, but my guess would be that this is not the case (would have to open and inspect to be sure).

If you (or someone you know) is not up a de-solder of the old part and solder on of the replacement then you are going to have to replace the whole MC board I think.


Post Extras: Print Post   Remind Me!   Notify Moderator  
dragonslayer1
scholastic sledgehammer


Reged: 02/25/12

Loc: SLC, UT
Re: AHHH! Broke my CGEM new [Re: Falcon-]
      #6325078 - 01/20/14 09:25 PM

If your by a college or high school electronics class you may check with them or a tv store on fixing it, ie replacing broken part, Kasey

Post Extras: Print Post   Remind Me!   Notify Moderator  
RTLR 12
Post Laureate
*****

Reged: 12/04/08

Loc: The Great Pacific NorthWest
Re: AHHH! Broke my CGEM new [Re: Falcon-]
      #6325103 - 01/20/14 09:39 PM

I think before I spent $342 on a co-axle socket I would take the MC board to an electronics shop (TV, Audio, RC, etc.) and have someone replace the socket. Its a fairly standard socket and this time don't get the screw-on kind. I always though it was a bad idea. I don't use them just for that reason.

Stan


Post Extras: Print Post   Remind Me!   Notify Moderator  
Starhawk
Space Ranger
*****

Reged: 09/16/08

Loc: Tucson, Arizona
Re: AHHH! Broke my CGEM new [Re: RTLR 12]
      #6325203 - 01/20/14 10:38 PM

It's certainly a standard socket if you don't get it with threads. It seems there are worse things than having it come unplugged.

-Rich


Post Extras: Print Post   Remind Me!   Notify Moderator  
slookabill
member


Reged: 11/08/13

Loc: Little Rock, AR, USA
Re: AHHH! Broke my CGEM new [Re: Starhawk]
      #6325210 - 01/20/14 10:45 PM

Well it broke the threads for the socket. I have put in an e-mail to Celestron, to see what they might have to say. I really am hoping I don't have to replace the whole board, as I was really hoping to order my first scope here shortly. I'll start looking around and seeing if any electronics shops can hopefully replace the socket... I'm really hoping there's no damage to the actual board though....

Post Extras: Print Post   Remind Me!   Notify Moderator  
Skunky
sage


Reged: 09/16/13

Re: AHHH! Broke my CGEM new [Re: slookabill]
      #6325384 - 01/21/14 01:04 AM

There is ways to rig something up. U could also find a dead cgem mount head cheaper than buying that part.

Post Extras: Print Post   Remind Me!   Notify Moderator  
orlyandico
Post Laureate
*****

Reged: 08/10/09

Loc: Singapore
Re: AHHH! Broke my CGEM new [Re: Skunky]
      #6325473 - 01/21/14 02:27 AM

You don't need to buy a new board, just have the socket replaced. And where did the $342 figure come from?

You just need to buy something like this..

http://www.newark.com/mcm/27-4365/connector-2-5mm-dc-power-jack/dp/96C7917

also I have never seen a dead CGEM mount. It is sufficiently beefy that it's worth repairing (unless the entire casting cracked).


Post Extras: Print Post   Remind Me!   Notify Moderator  
RTLR 12
Post Laureate
*****

Reged: 12/04/08

Loc: The Great Pacific NorthWest
Re: AHHH! Broke my CGEM new [Re: orlyandico]
      #6325511 - 01/21/14 03:13 AM

You don't get to see this where you are...

http://www.celestron.com/astronomy/cgem-mc-compatible-only-for-the-cgem-serie...

Stan


Post Extras: Print Post   Remind Me!   Notify Moderator  
orlyandico
Post Laureate
*****

Reged: 08/10/09

Loc: Singapore
Re: AHHH! Broke my CGEM new [Re: RTLR 12]
      #6325545 - 01/21/14 05:12 AM

That's probably the board... not just the coaxial connector. Which you can buy for $1.69 from the link I posted above.

Post Extras: Print Post   Remind Me!   Notify Moderator  
RTLR 12
Post Laureate
*****

Reged: 12/04/08

Loc: The Great Pacific NorthWest
Re: AHHH! Broke my CGEM new [Re: orlyandico]
      #6325623 - 01/21/14 07:47 AM

Well, yes of course that is the board. Did you open the link?That was my point! Not to spend $342 to replace a $2 connector.

Stan


Post Extras: Print Post   Remind Me!   Notify Moderator  
Skunky
sage


Reged: 09/16/13

Re: AHHH! Broke my CGEM new [Re: RTLR 12]
      #6325785 - 01/21/14 09:44 AM

You people find anything to disagree about and argue/squabble over it.

Post Extras: Print Post   Remind Me!   Notify Moderator  
EFT
Vendor - Deep Space Products
*****

Reged: 05/07/07

Loc: Phoenix, AZ
Re: AHHH! Broke my CGEM new [Re: slookabill]
      #6325851 - 01/21/14 10:23 AM

I have replaced several of these that people have broken. A standard socket will not work because it is not long/deep enough so you have to find a longer one which will cost a few bucks more (e.g., $5 instead of $2.50). Once you have the new socket, you need to remove the board from the face plate and desolder the original socket. In order to get the spacing correct for the new socket you then need to attach the new socket to the face plate, and reattach the board to the face plate. Then you can solder the new socket in place. Note that there should be at least one plastic washer between the face plate and the socket when you first take it apart and this washer needs to be in place when you put it together. The desoldering of the broken socket is the worst part of this job because the three pins of the socket are held in with a lot of solder and the large holes must be cleared in order to attach the new socket.

The part that I have used can be found here: Alliedelec.

This of course represents the risk of using a power connector that screws into the socket. It's nice that it does not easily come out, but if you trip on the cord, disaster results. Same problem that they use to have with laptops.


Post Extras: Print Post   Remind Me!   Notify Moderator  
brokenwave
sage


Reged: 05/10/11

Loc: Scottsdale, AZ
Re: AHHH! Broke my CGEM new [Re: EFT]
      #6325964 - 01/21/14 11:44 AM

I use a Velcro strap to keep the cord on the tripod leg. Keeps it from getting tripped over, also use a carpet mat to keep all cords under it.

Post Extras: Print Post   Remind Me!   Notify Moderator  
Falcon-
Post Laureate
*****

Reged: 09/11/09

Loc: Gambier Island, BC, Canada
Re: AHHH! Broke my CGEM new [Re: RTLR 12]
      #6326018 - 01/21/14 12:15 PM

Quote:

Well, yes of course that is the board. Did you open the link?That was my point! Not to spend $342 to replace a $2 connector.

Stan




It is worth noting that Celestron does not sell parts directly outside of the US and the web site knows this. So for those of us outside of the US such as orlyandico and I that link shows a picture of the board but no price.

Thus the confusion.


Post Extras: Print Post   Remind Me!   Notify Moderator  
Geo.
Carpal Tunnel
*****

Reged: 10/01/08

Loc: Upstate NY
Re: AHHH! Broke my CGEM new [Re: Falcon-]
      #6326037 - 01/21/14 12:27 PM

Personally, I'd ditch the OEM socket and replace it with a coiled power cord and a cord restraint at the panel rather than risk ripping up traces on the board. Or you could put a second restraint for the cord a few inches out from the connector. On the whole I think Celestron made a mistake when they stopped unsing Cinch-Jones connectors.

Post Extras: Print Post   Remind Me!   Notify Moderator  
andysea
Pooh-Bah
*****

Reged: 09/03/10

Loc: Seattle, WA
Re: AHHH! Broke my CGEM new [Re: Geo.]
      #6327392 - 01/21/14 11:55 PM

Hmm there's an opportunity. Someone should come up with a magsafe type connector for a mount, just like my mac laptops.

Post Extras: Print Post   Remind Me!   Notify Moderator  
Pages: 1 | 2 | (show all)


Extra information
12 registered and 29 anonymous users are browsing this forum.

Moderator:  Dave M, richard7, bilgebay, iceblaze 

Print Thread

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled


Thread views: 1237

Jump to

CN Forums Home


Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics