Return to the Cloudy Nights Telescope Reviews home page


Telescope Specific Forums >> Celestron NexStar

Pages: 1
Lord Beowulf
Pooh-Bah
*****

Reged: 10/13/08

Loc: Cedar Park, TX
Lots of play in 11" Edge HD CPC El/Dec axis
      #5507755 - 11/07/12 12:13 AM

Hi all,

I have a new 11" Edge HD CPC that has a lot of play (several degrees) in the elevation/declination axis when the clutch is tightened down. I'm not sure how the linkages are configured there, but this is way too much play to just be typical gear slop. It feels like there's a nut loose or linkage that's slipping. It could also be a screw gear shifting back and forth. Anyone else had an experience like this? I really hate the thought of having to ship this back to Celestron to try to get this fixed.

Thanks,

Beo


Post Extras: Print Post   Remind Me!   Notify Moderator  
Lord Beowulf
Pooh-Bah
*****

Reged: 10/13/08

Loc: Cedar Park, TX
Re: Lots of play in 11" Edge HD CPC El/Dec axis new [Re: Lord Beowulf]
      #5507811 - 11/07/12 01:15 AM

Well, one thing that's apparent is that the play is between the clutch and the OTA. When the clutch is tight and you wobble across this play, the clutch knob doesn't move at all. I suspect there's a nut inside that holds the OTA clamp to the clutch. I'll have to remove the OTA to adjust it, but that shouldn't be too difficult.

Beo


Post Extras: Print Post   Remind Me!   Notify Moderator  
Digital Don
Carpal Tunnel
*****

Reged: 01/20/04

Loc: Manteno, IL
Re: Lots of play in 11" Edge HD CPC El/Dec axis new [Re: Lord Beowulf]
      #5507816 - 11/07/12 01:21 AM

Hi Beo,

If the scope is new, you might want to contact the dealer and see what his response is.

Also, if you're already a member of the Yahoo! CPC Group, check these pictures of the altitude motor/gear assembly for reference. If you're not a member, you might consider joining since there is a wealth of information there.

Don


Post Extras: Print Post   Remind Me!   Notify Moderator  
Peter in Reno
Postmaster
*****

Reged: 07/15/08

Loc: Reno, NV
Re: Lots of play in 11" Edge HD CPC El/Dec axis new [Re: Digital Don]
      #5508133 - 11/07/12 10:10 AM

A friend of mine had the exact same issue in his regular CPC1100. I personally saw it myself and it didn't look right to me. He exchanged it for another one and the replacement did not have any play. Contact your dealer for an exchange.

Peter


Post Extras: Print Post   Remind Me!   Notify Moderator  
barbarosa
scholastic sledgehammer


Reged: 04/11/10

Loc: "lamorinda", CA
Re: Lots of play in 11" Edge HD CPC El/Dec axis new [Re: Lord Beowulf]
      #5508519 - 11/07/12 03:09 PM

Most dealers will do an exchange, but if you have problems Celestron will pay the shipping both ways for the first 30 days. But that should be your last resort--it likely will take more than 30 work days plus shipping time and FedEx Ground and UPS both have ingenious ways to drop test any shipment over 70lbs.

Post Extras: Print Post   Remind Me!   Notify Moderator  
Lord Beowulf
Pooh-Bah
*****

Reged: 10/13/08

Loc: Cedar Park, TX
Re: Lots of play in 11" Edge HD CPC El/Dec axis new [Re: barbarosa]
      #5509022 - 11/07/12 08:54 PM

Well, unfortunately we're more than 30 days past the purchase date, so I'm out of luck both with the dealer and presumably with Celestron as well, as far as the shipping. More importantly, I just don't want to ship it. I know it's just a linkage that needs tightening. I've been in my NexStar 8SE for a similar problem years ago. It's just annoying they don't do a better assembly job at the factory.

BTW David, looks like you've been to the Celestron HQ given your avatar. I got a picture of that on a visit there a while back.



Beo


Post Extras: Print Post   Remind Me!   Notify Moderator  
Lord Beowulf
Pooh-Bah
*****

Reged: 10/13/08

Loc: Cedar Park, TX
Re: Lots of play in 11" Edge HD CPC El/Dec axis new [Re: Lord Beowulf]
      #5509067 - 11/07/12 09:26 PM

HAH! Easy fix. The Celestron FAQ gives a guide for cleaning a slipping clutch. In the middle of the clutch assembly is a (rather small for the task) socket head cap screw that holds the clutch assembly to the OTA. Tightening this down with a LOT of torque solves the problem.

Beo


Post Extras: Print Post   Remind Me!   Notify Moderator  
kargan
member


Reged: 07/06/06

Re: Lots of play in 11" Edge HD CPC El/Dec axis new [Re: Lord Beowulf]
      #5767207 - 03/30/13 05:25 PM

I think I may have this issue in the Dec clutch of my new 11 Edge HD. I am new to polar scopes so not sure exactly how to follow that guide -- am I back out the screw holding the clutch handle and removing the handle? Underneath it looks like a brass nut is there, is that what I am tightening? Thanks for any help!

Post Extras: Print Post   Remind Me!   Notify Moderator  
Pages: 1


Extra information
11 registered and 22 anonymous users are browsing this forum.

Moderator:  Brian Risley, panhard, mayidunk 

Print Thread

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled


Thread views: 1032

Jump to

CN Forums Home




Cloudy Nights Sponsor: Astronomics