Return to the Cloudy Nights Telescope Reviews home pageAstronomics discounts for Cloudy Nights members
· Get a Cloudy Nights T-Shirt · Submit a Review / Article

Click here if you are having trouble logging into the forums

Privacy Policy | Please read our Terms of Service | Signup and Troubleshooting FAQ | Problems? PM a Red or a Green Gu… uh, User

Equipment Discussions >> Mounts

Pages: 1
Alan S
professor emeritus


Reged: 10/27/07

CGEM...RTC...again
      #5515036 - 11/11/12 08:26 PM

Now this is a new one on me...I hibernated my mount and when I woke it up, (after a few days), it had the time wrong but the date correct! Occasionally, the RTC fails on me, but usually the time and date both need to be re-set...

Anyone have this happen to them?


Post Extras: Print Post   Remind Me!   Notify Moderator  
Raginar
Postmaster
*****

Reged: 10/19/10

Loc: Rapid CIty, SD
Re: CGEM...RTC...again new [Re: Alan S]
      #5515320 - 11/11/12 11:56 PM

I haven't! Assuming it was at like a default value like 12:00am 1/1/1990 or something similarly far off, it's probably the RTC battery. While I never replaced mine; it sounded easy enough. I believe you unscrew the 'power' panel and it's hiding back there.

Good luck!


Post Extras: Print Post   Remind Me!   Notify Moderator  
wolfman_4_ever
Pooh-Bah


Reged: 07/15/11

Loc: El Segundo, Ca, So. Cal
Re: CGEM...RTC...again new [Re: Raginar]
      #5515348 - 11/12/12 12:20 AM

Was it off by an hour? There was the time change...

Post Extras: Print Post   Remind Me!   Notify Moderator  
RTLR 12
Post Laureate
*****

Reged: 12/04/08

Loc: The Great Pacific NorthWest
Re: CGEM...RTC...again new [Re: wolfman_4_ever]
      #5515395 - 11/12/12 12:57 AM

Alan,

Given that your temporary fix would indicate that there may be a connection problem with the battery. It could just be some oxidation or perhaps a problem with the board.

That gets us back to the 'Remove the panel' scenario we talked about before or send it to Celestron repair. How much longer is your warranty good for? The board is very pricey for the CGEM. $342.00

Stan


Post Extras: Print Post   Remind Me!   Notify Moderator  
Alan S
professor emeritus


Reged: 10/27/07

Re: CGEM...RTC...again new [Re: RTLR 12]
      #5515886 - 11/12/12 12:05 PM

Hi Stan-

Warranty period is until mid-May. I think the problem may actually be the battery holder...the battery is not as snug as it should be, compared to my other CGEM. I can stick my finger in there and slightly jiggle the battery.

To be honest, I am not inclined to send the mount back to Celestron, but if there is a board issue...wow those are pricey!

Alan


Post Extras: Print Post   Remind Me!   Notify Moderator  
RTLR 12
Post Laureate
*****

Reged: 12/04/08

Loc: The Great Pacific NorthWest
Re: CGEM...RTC...again new [Re: Alan S]
      #5516135 - 11/12/12 02:41 PM

Well you need to take the control panel off and look and see what you can find. I'm thinking it could be a simple fix. I have faith in you. Just do it. (Now or after warranty)

Stan


Post Extras: Print Post   Remind Me!   Notify Moderator  
Pages: 1


Extra information
25 registered and 49 anonymous users are browsing this forum.

Moderator:  Dave M, richard7, bilgebay 

Print Thread

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled


Thread views: 588

Jump to

CN Forums Home


Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics