Return to the Cloudy Nights Telescope Reviews home page


Telescope Specific Forums >> Meade LX

Pages: 1
nytecam
Postmaster


Reged: 08/20/05

Loc: London UK
LX200 power adapter fault
      #5535270 - 11/23/12 11:15 AM Attachment (42 downloads)

Hi - my recent post here reporting the death of my Classic LX200 seems mercifully premature After a fortnight in the house [away from damp obsy] the scope fired up unexpectedly this morning via a substitute mains to 18VDC adapter of similar rating.

However I'd like to resurrect the original larger air-cooled Meade LX200 power adapter [below] but a simple continuity test across the power[?] fuse [highlighted] indicates it's blown. Is the fuse soldered in? What rating fuse replaces it? Don't want to poke around and damage things without advise. TIA


Post Extras: Print Post   Remind Me!   Notify Moderator  
nytecam
Postmaster


Reged: 08/20/05

Loc: London UK
Re: LX200 power adapter fault new [Re: nytecam]
      #5535287 - 11/23/12 11:25 AM Attachment (37 downloads)

enlarged right = mains end

Post Extras: Print Post   Remind Me!   Notify Moderator  
nytecam
Postmaster


Reged: 08/20/05

Loc: London UK
Re: LX200 power adapter fault new [Re: nytecam]
      #5535290 - 11/23/12 11:26 AM Attachment (35 downloads)

enlarged left = 18VDC out end

Post Extras: Print Post   Remind Me!   Notify Moderator  
Cliff Hipsher
Pooh-Bah
***

Reged: 12/31/08

Loc: North Chesterfield, VA
Re: LX200 power adapter fault new [Re: nytecam]
      #5535474 - 11/23/12 01:07 PM

The fuse is soldered in. It is rated at 2 AMPS, 250 volts.

HINT: Its printed on the circuit board....


Post Extras: Print Post   Remind Me!   Notify Moderator  
nytecam
Postmaster


Reged: 08/20/05

Loc: London UK
Re: LX200 power adapter fault new [Re: Cliff Hipsher]
      #5535815 - 11/23/12 04:13 PM

Quote:

The fuse is soldered in. It is rated at 2 AMPS, 250 volts.HINT: Its printed on the circuit board....


Thanks Cliff - shame about soldered in fuse Yes - did spot CB legend soon after posting

Post Extras: Print Post   Remind Me!   Notify Moderator  
niteman1946
sage


Reged: 02/16/08

Loc: Fort Worth, TX
Re: LX200 power adapter fault new [Re: nytecam]
      #5541703 - 11/27/12 09:18 AM

Hi nytecam,

Glad to hear your Classic survived, and the problem was with the power source. I've enjoyed reading your posts and seeing your images, and hope you continue.

FWIW, My 12" has been a good performer, and I expect it to outlive me.

I do have a bit of a concern about your resurrecting the factory(?) power source. More than once I've read that these devices are a catastrophe just waiting to happen. So around April I bought a 16v regulated power source from Jim at Scopestuff and have had no problems. In fairness I had had no problems before either. But Jim's quite adamant that the old PS is dangerous to life and limb.
Just some thoughts.

Mark


Post Extras: Print Post   Remind Me!   Notify Moderator  
nytecam
Postmaster


Reged: 08/20/05

Loc: London UK
Re: LX200 power adapter fault new [Re: niteman1946]
      #5545864 - 11/29/12 05:14 PM

Quote:

Hi nytecam,Glad to hear your Classic survived, and the problem was with the power source. I've enjoyed reading your posts and seeing your images, and hope you continue. FWIW, My 12" has been a good performer, and I expect it to outlive me. I do have a bit of a concern about your resurrecting the factory(?) power source. More than once I've read that these devices are a catastrophe just waiting to happen. So around April I bought a 16v regulated power source from Jim at Scopestuff and have had no problems. In fairness I had had no problems before either. But Jim's quite adamant that the old PS is dangerous to life and limb. Just some thoughts.
Mark


Thanks Mark - did temp repair on fuse but it blew again on power-up. I suspect its CB is fried so back to my replacement unit today with dummy goto to M15/M31/M33/NGC 7331 etc all fine. Will reinstall scope on pier when my helpers are around

BTW - opened dome today to find floor rain soaked and shutter missing -it was in bushes 50ft away with little or no damage and now refitted. Must have been absent for over a week but luckily no gear in obsy


Post Extras: Print Post   Remind Me!   Notify Moderator  
niteman1946
sage


Reged: 02/16/08

Loc: Fort Worth, TX
Re: LX200 power adapter fault new [Re: nytecam]
      #5547444 - 11/30/12 03:59 PM

That's got to be scary, opening the observatory and seeing sky (and a wet floor).

Hope your refit holds up.

Mark


Post Extras: Print Post   Remind Me!   Notify Moderator  
Pages: 1


Extra information
0 registered and 5 anonymous users are browsing this forum.

Moderator:  Starman27, Christopher Erickson, Starman81 

Print Thread

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled


Thread views: 980

Jump to

CN Forums Home




Cloudy Nights Sponsor: Astronomics