Return to the Cloudy Nights Telescope Reviews home pageAstronomics discounts for Cloudy Nights members
· Get a Cloudy Nights T-Shirt · Submit a Review / Article

Click here if you are having trouble logging into the forums

Privacy Policy | Please read our Terms of Service | Signup and Troubleshooting FAQ | Problems? PM a Red or a Green Gu… uh, User

Equipment Discussions >> Mounts

Pages: 1 | 2 | 3 | 4 | (show all)
nganga
super member


Reged: 03/16/08

CGEM motor cogging
      #5537628 - 11/24/12 06:17 PM

Hello,

A firmware fix was supposedly in the works to fix this problem. Does anyone know the status of this?

Clem


Post Extras: Print Post   Remind Me!   Notify Moderator  
Stew57
Carpal Tunnel
*****

Reged: 05/03/09

Loc: Silsbee Texas
Re: CGEM motor cogging new [Re: nganga]
      #5537705 - 11/24/12 07:09 PM

Supposed to be ready early next year.

Post Extras: Print Post   Remind Me!   Notify Moderator  
nganga
super member


Reged: 03/16/08

Re: CGEM motor cogging new [Re: Stew57]
      #5537919 - 11/24/12 10:04 PM

Quote:

Supposed to be ready early next year.




Thanks Mark.

Clem


Post Extras: Print Post   Remind Me!   Notify Moderator  
svtdoug
sage


Reged: 02/07/11

Loc: Gig Harbor, WA, USA
Re: CGEM motor cogging new [Re: nganga]
      #5554760 - 12/04/12 10:21 PM

Supposedly very soon. Most issues have been solved, waiting for beta release to test.

Post Extras: Print Post   Remind Me!   Notify Moderator  
orlyandico
Postmaster
*****

Reged: 08/10/09

Loc: Singapore
Re: CGEM motor cogging new [Re: svtdoug]
      #5554931 - 12/05/12 12:41 AM

I've finally seen this cogging for myself.

I suspect the fix will entail keeping the motor powered even when its not moving so it doesn't slip back to one of the cog positions.


Post Extras: Print Post   Remind Me!   Notify Moderator  
svtdoug
sage


Reged: 02/07/11

Loc: Gig Harbor, WA, USA
Re: CGEM motor cogging new [Re: orlyandico]
      #5743888 - 03/19/13 08:01 PM

I, along with other beta testers, have been working with Derek of Celestron, on
a firmware fix for this Dec Cogging issue for over a year now. Derek has been
most helpful, but he has not been allowed to finish the fix. He has been pulled
off the project for months at a time, to work on new products, etc. Last month
we were told that Derek was back on the project and it was his highest priority,
and that we should have something to test this month (March of 2013). This week
we found out he has been taken off this project once again, and that it will be
"next" inline. We have heard this so many times before.

I just wrote Celestron telling them of my frustration - that I am unable to use
my mount for any serious imaging until this fix is accomplished, and with star
party season fast approaching, my satisfaction with the CGEM is quickly eroding.

If you have a CGEM or CGEM DX mount with the saw tooth dec cogging issue, and
are frustrated with the delay in getting a fix, it may be helpful for you to
email Celestron Tech Support, and let them know that you are interested in getting this issue solved quickly. You can write to them at -
http://www.celestron.com/c3/support3/index.php?_m=tickets&_a=submit

I am sure this issue is affecting their sales, and their reputation. Hopefully
some pressure upstream in management will help them to rethink their priorities.

Doug


Post Extras: Print Post   Remind Me!   Notify Moderator  
svtdoug
sage


Reged: 02/07/11

Loc: Gig Harbor, WA, USA
Re: CGEM motor cogging new [Re: svtdoug]
      #5743994 - 03/19/13 08:59 PM

Update: I just had some feedback and encouragement - that the more folks who let Celestron know about this issue - and the delay in getting it fixed, and how it is affecting them and their use of the CGEM, the more likely it is to get fixed soon.

Thanks,

Doug


Post Extras: Print Post   Remind Me!   Notify Moderator  
orlyandico
Postmaster
*****

Reged: 08/10/09

Loc: Singapore
Re: CGEM motor cogging new [Re: svtdoug]
      #5744146 - 03/19/13 10:27 PM

IMNSHO.. Celestron probably cares less about us CGEM owners because they already got their money from us. And I understand the AVX doesn't have this problem, so going forward, if ever they come out with a CGEM AVX, the pressure to fix this DEC cogging will vanish. After all, we are not new sales.

Given that a very good polar alignment would allow minimal to no DEC guiding at typical focal lengths, maybe the DEC cogging is not as severe an issue as we all think? for me the 8/3 is a more severe issue..


Post Extras: Print Post   Remind Me!   Notify Moderator  
svtdoug
sage


Reged: 02/07/11

Loc: Gig Harbor, WA, USA
Re: CGEM motor cogging new [Re: orlyandico]
      #5744423 - 03/20/13 03:16 AM

Orlyandico,

Celeston HAS committed to fixing this issue, as evidenced by the amount of work and several firmware beta versions already produced. That has been established. They just have not committed the resources to finish the job.

A good polar alignment is great for those fortunate to have a permanent mount, but for those like me who do not, a near perfect polar alignment is energy and time consuming. And for what ever reason, I find that it works for a while, but eventually the drift rate increases, requiring more fussing with the polar alignment.

I own a 2 axis auto guider and a mount that was designed and advertised to guide in two axis for one reason - that is to use it for guiding in two axis. Anything short of that, in my opinion, is not getting what you paid for.

FWIW, I do not have any probables with the 8/3 issue.

Doug


Post Extras: Print Post   Remind Me!   Notify Moderator  
dickbill
scholastic sledgehammer


Reged: 09/30/08

Re: CGEM motor cogging new [Re: orlyandico]
      #5744855 - 03/20/13 10:50 AM

Quote:

I've finally seen this cogging for myself.

I suspect the fix will entail keeping the motor powered even when its not moving so it doesn't slip back to one of the cog positions.




what does it look like, oscillations in dec?


Post Extras: Print Post   Remind Me!   Notify Moderator  
orlyandico
Postmaster
*****

Reged: 08/10/09

Loc: Singapore
Re: CGEM motor cogging new [Re: dickbill]
      #5745055 - 03/20/13 12:30 PM

Sawtooth pattern.

Generally with DEC guiding, there is a lot of backlash, a dead spot if you will. So by deliberately mis-aligning the azimuth a little bit, you can ensure that all DEC corrections are in one direction only. So once the slack has been taken up, DEC corrections should be "instantaneous."

The problem with the CGEM is that the motor has 5 lobes on its armature, and it "cogs" i.e. if you command the motor to move a very small amount, it will not move that amount unless the amount is at least one rotor lobe. This is because the rotor lobes are attracted to the magnet.

You can feel this cogging effect on stepper motors - if you turn them by hand, you can feel the "grittiness." But - a stepper motor has 200 lobes on its armature.

So what happens with the CGEM is, as your DEC drifts off, the guider commands a correction. But until that correction is big enough (i.e. long enough, i.e. the DEC drift is big enough) for the motor to rotate by one cog, the motor won't rotate. Or it might, but it "snaps" back to the previous position.

The net effect is your DEC error has to grow to a certain level before the DEC axis moves back. It is exactly the same effect as stiction. On my mount (AP600) the axis won't move until a substantial-enough torque is applied. This is mechanical and is an axis problem, rather than a motor problem. But the effect is the same, the DEC error has to build up to enough of a level before it gets corrected.

I spent a Mach1 to banish the DEC stiction on my AP600. But after doing a very good polar align of the AP600 (2' from the pole) I discovered that I can get away with not guiding in DEC at all, for up to 10 minutes. So this is one possible solution to cogging or stiction.

This solution isn't good enough for 20 minutes, and I don't think it would work for a CGEM. The AP600 has very stiff axes (which contributes to the stiction) but the effect is, whatever small DEC backlash it has, it doesn't move very often due to wind etc.

My CGEM has real bearings in DEC, so this means the slightest wind or cable drag will cause it to bump up against its limits (since the worm and ring gear can't be 100% tight against each other). When that happens, you need to correct in DEC right away.

Some people have used a string to deal with the cogging. I'm not entirely sure about the details of that.


Post Extras: Print Post   Remind Me!   Notify Moderator  
svtdoug
sage


Reged: 02/07/11

Loc: Gig Harbor, WA, USA
Re: CGEM motor cogging new [Re: dickbill]
      #5745180 - 03/20/13 01:45 PM

Quote:


what does it look like, oscillations in dec?




There are at least two ways to determine if you have this issue with your mount.

1st way: If you have a phd guiding graph that looks like this - a very
pronounced saw tooth pattern:
http://edhiker.blogspot.com/2011_10_01_archive.html#2779568578551726255

2nd Way: Using the hand controller, select "GET RA & DEC" from the main menu or
"GET AXIS POSITION" under the "UTILITIES" menu. Set the slew rate to 1 or 2
(0.5X or 1X sidereal rate, the kind of rate you would use in guiding) and press
the north or south button for about half a second. Normally, the DEC position
will change by a few arcseconds. But if you continue short steps in the same
direction, you may find a point at which the displayed dec position will no
longer advance. The numbers might change a bit in response to pressing the
button, but then come back to about the same value. The same thing happens when
you are trying to guide. The result is that if you limit the pulse to half a
second (500 milliseconds) and keep going in the same direction it will never get
past this "bad spot", until the size of the correct gets large enough to
overcome this "bad spot" or cog of the motor. I looked at the drive signals to
the DEC motor and saw that each time I pressed the button the motor would be
driven, but then the voltage would go to zero, even though the position slipped
back. This is not how a traditional servo system works...
Pasted from <http://www.cloudynights.com/item.php?item_id=2702>

Here is a video I made of checking the dec using this method -
http://www.youtube.com/watch?v=bVqW8ZGi7_4 Note, this video was made with the
dec motor removed, but the same check can be made without taking the mount
apart.

The result of this problem with imaging is that you will end up with inaccurate
guiding, resulting in oblong stars and blurred images.

Doug


Post Extras: Print Post   Remind Me!   Notify Moderator  
dickbill
scholastic sledgehammer


Reged: 09/30/08

Re: CGEM motor cogging new [Re: svtdoug]
      #5745248 - 03/20/13 02:18 PM

Thanks Orlyandico and good video Doug, with a very clear reccord of the 'spring back'.
Your video suggests the easiest (the only?) solution might be to change the slew rate to 3 or 4, to break the cogg, but the guiding software might not give this option.
I think phD guides at a slew rate of 1 or 2, is it imposed by the mount?


Post Extras: Print Post   Remind Me!   Notify Moderator  
orlyandico
Postmaster
*****

Reged: 08/10/09

Loc: Singapore
Re: CGEM motor cogging new [Re: dickbill]
      #5746106 - 03/20/13 08:06 PM

If you increase the speed of the guide rate, PHD calibration will notice this increased speed. So PHD will use shorter pulses ( speed X time = distance )

So the cogging will still be there.

Only option is wait for a firmware fix, or don't buy a CGEM or CGEM DX.

Or don't guide in DEC.


Post Extras: Print Post   Remind Me!   Notify Moderator  
dickbill
scholastic sledgehammer


Reged: 09/30/08

Re: CGEM motor cogging new [Re: orlyandico]
      #5747201 - 03/21/13 09:36 AM

but then, it could be a fix in the guiding software (phd...) as much as in the celestron firmware.
For example, an option to change the rates or guide pulses in dec only.

I use phd with short pulses (400ms), which is well enough to move the star 24 pixels during the North Dec calibration, in ~10-20 steps, but barely enough to move the star back south a few pixels.
Is this due to backlash, cogging or both?


Post Extras: Print Post   Remind Me!   Notify Moderator  
svtdoug
sage


Reged: 02/07/11

Loc: Gig Harbor, WA, USA
Re: CGEM motor cogging new [Re: dickbill]
      #5747751 - 03/21/13 02:39 PM

Quote:

but then, it could be a fix in the guiding software (phd...) as much as in the celestron firmware.
For example, an option to change the rates or guide pulses in dec only.

I use phd with short pulses (400ms), which is well enough to move the star 24 pixels during the North Dec calibration, in ~10-20 steps, but barely enough to move the star back south a few pixels.
Is this due to backlash, cogging or both?




That is due to backlash. I looked into this once with PHD, by communicating with the developer. When PHD does the calibration routine in dec, I wondered if that information about backlash (the amount of guiding pulses needed to reverse the direction in Dec) is used during guiding to reverse the dec guiding pulses, if there were an occasion to reverse corrections due to wind or whatever. The answer is no, PHD does not take that into consideration. Therefore, at least with my mount, if there is a need to reverse the direction of dec guiding, there is a LONG wait to get that reversal done, and a large deviation in the dec guiding graph. But my backlash is larger than what is suggested by the post above.

Doug


Post Extras: Print Post   Remind Me!   Notify Moderator  
orlyandico
Postmaster
*****

Reged: 08/10/09

Loc: Singapore
Re: CGEM motor cogging new [Re: svtdoug]
      #5747983 - 03/21/13 04:25 PM

MaximDL can overcome the backlash when guiding in DEC. You can define how long a pulse to send when reversing direction. For example if it takes 10 seconds worth of DEC guiding pulses to take up the backlash, you can define this so if a reversal is needed Maxim will immediately send a 10 second long pulse.

The problem then is.. will a 10-second long pulse result in elongated stars. If you're doing narrowband, then no. But if unfiltered, you would almost certainly get elongated stars.

There is really no way to totally solve declination guiding issues except to buy a high-end mount.


Post Extras: Print Post   Remind Me!   Notify Moderator  
dickbill
scholastic sledgehammer


Reged: 09/30/08

Re: CGEM motor cogging new [Re: svtdoug]
      #5748222 - 03/21/13 06:18 PM

Quote:

I wondered if that information about backlash (the amount of guiding pulses needed to reverse the direction in Dec) is used during guiding to reverse the dec guiding pulses, if there were an occasion to reverse corrections due to wind or whatever. The answer is no, PHD does not take that into consideration. Doug




Have you tried with high backlash setting in the hand controler and/or with PEC on?

I tried two times to guide with PEC ON, and found it might be better (slightly). I got to try again...


Post Extras: Print Post   Remind Me!   Notify Moderator  
andysea
Pooh-Bah
*****

Reged: 09/03/10

Loc: Seattle, WA
Re: CGEM motor cogging new [Re: dickbill]
      #5749448 - 03/22/13 10:54 AM

You guys have far more patience than I have for sub standard equipment!! Typically I just get rid of it and swear off that manufacturer.
I'm impressed with your perseverance!!


Post Extras: Print Post   Remind Me!   Notify Moderator  
Patrick
Postmaster
*****

Reged: 05/16/03

Loc: Franklin, Ohio
Re: CGEM motor cogging [Re: andysea]
      #5749577 - 03/22/13 12:25 PM

Quote:

You guys have far more patience than I have for sub standard equipment!! Typically I just get rid of it and swear off that manufacturer.
I'm impressed with your perseverance!!




Not everyone can afford to swear off the cost leaders...

Patrick


Post Extras: Print Post   Remind Me!   Notify Moderator  
Pages: 1 | 2 | 3 | 4 | (show all)


Extra information
29 registered and 22 anonymous users are browsing this forum.

Moderator:  Dave M, richard7, bilgebay 

Print Thread

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled


Thread views: 5258

Jump to

CN Forums Home


Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics