Return to the Cloudy Nights Telescope Reviews home pageAstronomics discounts for Cloudy Nights members
· Get a Cloudy Nights T-Shirt · Submit a Review / Article

Click here if you are having trouble logging into the forums

Privacy Policy | Please read our Terms of Service | Signup and Troubleshooting FAQ | Problems? PM a Red or a Green Gu… uh, User

Equipment Discussions >> Mounts

Pages: 1
dgcms
member


Reged: 03/15/13

VX Mount Hand Controller Died on New Telescope new
      #5757329 - 03/26/13 12:58 AM

Just got a C8N newtonian with the new VX mount. Out for the second time last night and during alignment the hand controller failed. Blank screen with no response from any of the buttons. Completely dead. Connecting cable was checked and it was properly seated on the VX mount control panel. Red power light was ON on the mount. Power supply voltage was checked and it was 12.3 volts. Powered down the mount, disconnected power supply, reconnected hand control, powered back up and it was still completely dead.

Any one else had any problems with these hand controllers? I hope it is the hand controller and not the electronics in the mount. Looks like I'll be down for awhile.


Post Extras: Print Post   Remind Me!   Notify Moderator  
johnpd
sage


Reged: 04/13/08

Re: VX Mount Hand Controller Died on New Telescope new [Re: dgcms]
      #5757463 - 03/26/13 03:18 AM

Hi dgcms,

I believe others have had this problem. Check some of the other VX related posts here.

JohnD


Post Extras: Print Post   Remind Me!   Notify Moderator  
beammeup
member


Reged: 12/22/08

Loc: Straight of Gibraltar
Re: VX Mount Hand Controller Died on New Telescope new [Re: johnpd]
      #5757565 - 03/26/13 06:57 AM

I wonder if maybe it is still possible to use the mount via Nexremote or Skyfi and Skysafari, even with the HC not working?

Post Extras: Print Post   Remind Me!   Notify Moderator  
Raginar
Postmaster
*****

Reged: 10/19/10

Loc: Rapid CIty, SD
Re: VX Mount Hand Controller Died on New Telescope new [Re: beammeup]
      #5757752 - 03/26/13 09:21 AM

Beameup,

No, it requires you to connect through the HC. If you had the out-of-production AUX port you could. Apparently some guys posted you can build the device required; plans are over in the CG-5 Yahoo! Group.

Celestron has been forthcoming about replacing the HCs. Give em a call and good luck with your new mount.


Post Extras: Print Post   Remind Me!   Notify Moderator  
jerwin
scholastic sledgehammer
*****

Reged: 05/17/12

Loc: Romeoville IL
Re: VX Mount Hand Controller Died on New Telescope new [Re: Raginar]
      #5758359 - 03/26/13 02:36 PM

VERY similar problem on my VX, however mine gave me a no response 17 and 16 on the hand controller first and the next time I power cycled the mount it started doing the same thing as yours, blank screen. The no repose 17/16 was on my second use. I have a few other Celestron scopes and found the no response 17/16 followed the hand controller, but the blank screen was on the VX, as it gave the same blank screen to my other hand controllers.

I was 1 day outside of my 30 day warranty with the seller so I called Celestron tech support directly. They just issued me an RMA to send the entire mount back. Tripod, counterweight, everything, so I don't know if they're giving me a brand new one or what. I'd think if you were going to just do a repair you wouldn't want the tripod or counter weight. They said their standard turn around was 30 days, but since the mount was new, they typically try to turn give a little priority to the person that got the lemon, so he said they'd probably turn it around in 10.

The tech thought it was probably the motor control board.

I'd suggest calling the reseller right away and see what they can do, and if your past their warranty, call Celestron. They wanted a copy of my receipt before they issued the RMA.

Sucks big time but it seems like they are trying to make it right as quick as they can.

Good luck,
Jim


Post Extras: Print Post   Remind Me!   Notify Moderator  
jerwin
scholastic sledgehammer
*****

Reged: 05/17/12

Loc: Romeoville IL
Re: VX Mount Hand Controller Died on New Telescope new [Re: beammeup]
      #5758360 - 03/26/13 02:37 PM

Quote:

I wonder if maybe it is still possible to use the mount via Nexremote or Skyfi and Skysafari, even with the HC not working?




The Nexremote would not work on mine.

Jim


Post Extras: Print Post   Remind Me!   Notify Moderator  
Jeff2011
Carpal Tunnel
*****

Reged: 01/01/13

Loc: Sugar Land, TX
Re: VX Mount Hand Controller Died on New Telescope new [Re: jerwin]
      #5758713 - 03/26/13 05:30 PM

I should be getting my VX mount tomorrow. Will let you know if I have a problem with it. You guys got me concerned a bit.

Post Extras: Print Post   Remind Me!   Notify Moderator  
jerwin
scholastic sledgehammer
*****

Reged: 05/17/12

Loc: Romeoville IL
Re: VX Mount Hand Controller Died on New Telescope new [Re: Jeff2011]
      #5758739 - 03/26/13 05:41 PM

My first night was great. this was my first EQ mount so I was trying to learn as I went. (first thing I learned was to put the tripod legs up higher otherwise I was in some terrible positions with the c6 refractor. (my CPC1100 I've never needed the legs extended at all for comfortable viewing).

My problem occurred sometime as it sat idle in my dining room. After 3 weeks of clouds, I finally took it back outside, got everything setup, manually aligned it polar north, and upon turning it on was when I got the kick in the pants that my night was ruined.

Jim


Post Extras: Print Post   Remind Me!   Notify Moderator  
dgcms
member


Reged: 03/15/13

Re: VX Mount Hand Controller Died on New Telescope new [Re: dgcms]
      #5758817 - 03/26/13 06:30 PM

Called the company I bought the scope from and they immediately shipped a new hand controller to me. No questions asked. They just want to make sure I get squared away as soon as possible. Outstanding service. They will include a box and shipping label to send the bad one back to them after I get the new one. Should have it by Thursday.

Post Extras: Print Post   Remind Me!   Notify Moderator  
dgcms
member


Reged: 03/15/13

Re: VX Mount Hand Controller Died on New Telescope new [Re: dgcms]
      #5758830 - 03/26/13 06:37 PM

Jim I just read your post stating that the VX mount gave a blank screen to your other hand controllers. I may find out that the hew hand controller I am getting doesn't solve my problem. I'll keep you folks posted.

Edited by dgcms (03/26/13 06:43 PM)


Post Extras: Print Post   Remind Me!   Notify Moderator  
jerwin
scholastic sledgehammer
*****

Reged: 05/17/12

Loc: Romeoville IL
Re: VX Mount Hand Controller Died on New Telescope new [Re: dgcms]
      #5758859 - 03/26/13 06:51 PM

dgcms, Just curious, who you ordered your VX from. I got mine from OPT. Order was placed February 12th, and it arrived the 19th. Wonder if a batch went out with bad motor control boards.

Jim


Post Extras: Print Post   Remind Me!   Notify Moderator  
Mkofski
Pooh-Bah
*****

Reged: 07/19/11

Loc: Greenfield, Indiana, USA
Re: VX Mount Hand Controller Died on New Telescope new [Re: dgcms]
      #5758908 - 03/26/13 07:10 PM

Quote:

Called the company I bought the scope from and they immediately shipped a new hand controller to me. No questions asked. They just want to make sure I get squared away as soon as possible. Outstanding service. They will include a box and shipping label to send the bad one back to them after I get the new one. Should have it by Thursday.




With that kind of great service it wouldn't be bad to mention the seller by name.


Post Extras: Print Post   Remind Me!   Notify Moderator  
dgcms
member


Reged: 03/15/13

Re: VX Mount Hand Controller Died on New Telescope new [Re: jerwin]
      #5759013 - 03/26/13 08:02 PM

Quote:

dgcms, Just curious, who you ordered your VX from. I got mine from OPT. Order was placed February 12th, and it arrived the 19th. Wonder if a batch went out with bad motor control boards.

Jim




I bought it from High Point Scientific. Glad I did. They have really good customer service. A pleasure to talk to and like I said, they really care that I am satisfied with my scope and mount. After reading your post Jim I called them back and explained the problem may be in the VX mount. The gentleman I was talking to said no problem. If the new hand controller doesn't solve my problem, they will immediately ship me a new VX mount. My experience with them has been all positive.


Post Extras: Print Post   Remind Me!   Notify Moderator  
Senator48
member


Reged: 03/12/12

Loc: New Jersey
Re: VX Mount Hand Controller Died on New Telescope new [Re: dgcms]
      #5759251 - 03/26/13 09:43 PM

I'm lucky to live within an hour of High Point Scientific. Dave and his team do an excellent job of taking care of customers, pre and post-sale. If you're not sure who to buy from, I recommend them without hesitation.

Post Extras: Print Post   Remind Me!   Notify Moderator  
Whichwayisnorth
Pooh-Bah
*****

Reged: 07/04/11

Loc: Southern California
Re: VX Mount Hand Controller Died on New Telescope new [Re: Senator48]
      #5759403 - 03/26/13 11:28 PM

I bought my VX mount from Woodland Hills. I ended up dealing with Celestron to resolve the dead HC. They sent me one within the week and it has worked the last few times I've used it. I may end up buying a second hand controller just to have a spare. Who wants to be out at a remote location and have it die on them? Not I!

Post Extras: Print Post   Remind Me!   Notify Moderator  
dgcms
member


Reged: 03/15/13

Re: VX Mount Hand Controller Died on New Telescope new [Re: johnpd]
      #5772098 - 04/02/13 02:16 AM

Got the new hand controller and all is well again. I initially got the "bootloader invalid package" message but that was quickly resolved by running CFM and updating the firmware. The controller worked flawlessly tonight. 2 Star alignment + 1 cal star was all I needed tonight. Had a lot of dew tonight and seeing wasn't great but my scope got a good workout.
Rotating the newtonian OTA to get the eyepiece and finder scope at a convenient location was a frequent issue as I viewed different objects. Rotating the OTA resulted in perturbing my goto results also. Got to put rotating rings on the tube.


Post Extras: Print Post   Remind Me!   Notify Moderator  
zawijava
scholastic sledgehammer
*****

Reged: 10/06/07

Loc: Wells, Maine 04090
Re: VX Mount Hand Controller Died on New Telescope [Re: dgcms]
      #5772491 - 04/02/13 10:09 AM

I've had my AVX for a couple weeks, seems to be functioning fine but I'm curious, is there a firmware update for my hand control and/or motor control that I should be doing already? I looked on the celestron Tech Support site but didn't locate anything for the AVX...did I miss it?

thanks, Tim

Quote:

Got the new hand controller and all is well again. I initially got the "bootloader invalid package" message but that was quickly resolved by running CFM and updating the firmware.




Post Extras: Print Post   Remind Me!   Notify Moderator  
Pages: 1


Extra information
27 registered and 32 anonymous users are browsing this forum.

Moderator:  Dave M, richard7, bilgebay 

Print Thread

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled


Thread views: 993

Jump to

CN Forums Home


Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics