Return to the Cloudy Nights Telescope Reviews home page


Telescope Specific Forums >> Meade LX

Pages: 1
steve girard
member


Reged: 05/30/07

Loc: Ardmore, OK
need help connecting to Pempro V2
      #6108199 - 09/29/13 09:00 PM

Hi everyone

Is anyone using Pempro V2 with an LX200GPS? I have downloaded the program but can’t get it to connect to my mount.



These are the steps that I performed this evening with the hopes of getting the PemPro to connect to my scope. I am still having difficulties getting this connection established. Any help would be greatly appreciated.

1) Verified that .NET Framework 3.5.1 is selected and running (The OS is Windows7 Professional 64-bit)
2) Downloaded and Installed: ASCOM Platform 6 with Service Pack 3 (6SP3) – From ASCOM website
3) Downloaded and Installed: MeadeLX200GPS(5.0.0) driver – From ASCOM website (does this driver need to be located in a specific directory).

After performing these steps in order….PemPro was opened, and I was able to connect my camera. Making sure that the correct COM port is selected, I have selected the correct ASCOM driver (as the instructions have said to do), and when I try to connect to the scope, it pauses for 5 to 10 seconds and then comes back with the error message that “Connect Failed: Timed out waiting for received data.”

I can still connect to everything using my other programs (CCDSoft, and TheSky 6) as I normally would. Please advise on what else I can try to get this working. I have tried to use PemPro while connected to TheSky6 and it tells me that the COM port is busy. So I know that the connection is correct on that aspect, but I’m having trouble getting the PemPro program to connect to the scope.

Just to clarify, My SBig camera connects to the computer with USB, My LX200GPS connects to the computer from one of the RS232 ports on the scope base to USB on the computer (using the Meade supplied cable that came with the scope). I also have a cable from my camera to the Autoguider port on the scope base. I have one unused RS232 port on the scope. I have a Shoestring Astronomy GPSUB box but it is not hooked up at all (I don’t know if I should be using it or not, and if so, how).

I placed this post on Pempro support forum but didn’t get much help

Don’t know what to do now, can anyone please help.

Thanks
Steve


Post Extras: Print Post   Remind Me!   Notify Moderator  
OzAndrewJ
scholastic sledgehammer
*****

Reged: 11/30/10

Re: need help connecting to Pempro V2 new [Re: steve girard]
      #6108233 - 09/29/13 09:24 PM

Gday Steve

If other ( not utilising ASCOM ) apps connect without problem,
but via ASCOM, you get the timeout error,
this normally means the scopes memory is filling up with redundant data links,
and hence lookups for certain data is exceeding 5 seconds.
The Meade ASCOM driver is not very good at handling timeouts, so dies rather disgracefully.
( If you go to the ASCOM Yahoo group and search for "garbage" you will see several recent threads on this. )
You could also turn on the ASCOM tracing function to confirm the command that locks you up is a std meade command, and it times out at 5 secs.

Based on the number of reports for this recently, my first guess is to just try a "garbage collect" via Meades ASU utility. ( this clears out all the redundant data elements and
hence speeds up lookups to well below 5 seconds )

If that doesnt fix it, come back for a second round of diagnosis.

Andrew Johansen Melbourne Australia


Post Extras: Print Post   Remind Me!   Notify Moderator  
steve girard
member


Reged: 05/30/07

Loc: Ardmore, OK
Re: need help connecting to Pempro V2 new [Re: OzAndrewJ]
      #6111541 - 10/01/13 04:39 PM

Hi Andrew
Thanks for responding, this should not be this difficult but I don’t understand enough I guess to make it work. First off, this ASU utility and “garbage collect”, exactly where do I find this? I am running 4.2g and I looked at the options on my hand box and did not see it. I also looked in the manual under the program “tree” and saw nothing. Also can this garbage collect be run without changing anything else? Or will I have to download 4.2g again and reset everything. I will keep it simple (for me) and quit here for now. You have to understand when it comes to this type of computer stuff you’re dealing with an unarmed man.
Thanks
Steve


Post Extras: Print Post   Remind Me!   Notify Moderator  
OzAndrewJ
scholastic sledgehammer
*****

Reged: 11/30/10

Re: need help connecting to Pempro V2 new [Re: steve girard]
      #6111655 - 10/01/13 05:55 PM

Gday Steve
Quote:

First off, this ASU utility and “garbage collect”, exactly where do I find this?




ASU is Meades "Autostar Update Utility" and can be downloaded from their site if reqd.
http://www.meade.com/support/auto.html
Get the 6.0 version and load it then start it up.
I note your sig says you have ASSuite installed, and ASU is actually in that app as well, but i dont know what version you have.
If it has the garbage collect there already, it will run OK.

Under the Tools menu is an option "Garbage collect" and you can read what it does in the help. Basically start your scope.
Start ASU and use the connect button to find your scope
( you may need to set the correct com port in ASU )
Once connected, use the "Garbage collect" menu and wait for it to finish.
Close down ASU and try to connect to PEMPro.
It doesnt require any reloading of firmware or access to the Hbx.

Andrew Johansen Melbourne Australia


Post Extras: Print Post   Remind Me!   Notify Moderator  
steve girard
member


Reged: 05/30/07

Loc: Ardmore, OK
Re: need help connecting to Pempro V2 new [Re: OzAndrewJ]
      #6112085 - 10/01/13 10:07 PM

Andrew

THAT WORKED!! Thanks much, I never would have figured that out. Now I can start to figure out the pempro program.

Do you know anything about Pempro V2 in case I have problems?

Thanks again
Steve


Post Extras: Print Post   Remind Me!   Notify Moderator  
OzAndrewJ
scholastic sledgehammer
*****

Reged: 11/30/10

Re: need help connecting to Pempro V2 new [Re: steve girard]
      #6112104 - 10/01/13 10:18 PM

Gday Steve

Quote:

I never would have figured that out



Dont worry, it took us a long time to figure it out when it first started appearing.
ASCOM really need to get someone to fix their drivers, but im not holding my breath.

Quote:

Do you know anything about Pempro V2 in case I have problems



Not enough to be usefull.

Andrew Johansen Melbourne Australia


Post Extras: Print Post   Remind Me!   Notify Moderator  
Pages: 1


Extra information
2 registered and 3 anonymous users are browsing this forum.

Moderator:  Starman27, Christopher Erickson, Starman81 

Print Thread

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled


Thread views: 440

Jump to

CN Forums Home




Cloudy Nights Sponsor: Astronomics