Jump to content

  •  

CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.

Photo

Stellarium 0.10.5 has been released

This topic has been archived. This means that you cannot reply to this topic.
133 replies to this topic

#51 treaves

treaves

    Vostok 1

  • *****
  • Posts: 108
  • Joined: 27 Jan 2009

Posted 08 June 2010 - 07:00 PM

I tried the ocular plugin with scaling on and off. No real difference. The FOV circle changes in size, but the image of the selected object (Saturn) does not change in size.

When I first heard about the ocular plugin my first thought was, "Wow, this should be way cool." However, (and this may be entirely on me), the plugin is not meeting my expectations, so I'm just gonna ignore it. The ocular plugin is a great idea, but it lacks in execution.


Then you have it configured incorrectly. I used screen shots of the moon for the WIKI page, and it clearly works. It shows the effect both of scaling and not scaling. I can put up images of Saturn too.

#52 treaves

treaves

    Vostok 1

  • *****
  • Posts: 108
  • Joined: 27 Jan 2009

Posted 08 June 2010 - 07:06 PM

I installed Stellarium 0.10.4 and Kstars on my Lenovo S10 netbook running Ubuntu 10.04 and I liked Stellarium on this hardware running much better. What is missing though, is someting to record observation session. Kstars has this function.
I found a probosal to build it:
http://www.stellariu...ervation_Logger

Was there any work done in this area?

Alex


Yes, I have this working. It's just not linked in to the app at the moment; you would have to put it there manually.

I've been working on this a good deal over the last two weeks, trying to make it better. I'll get the WIKI page for it done this week, with screen shots to solicit feedback. Unfortunately, I'm not the best UI person, so that needs work. The initial release will be just basic recording. In the future, I plan on screen overlays (so you can see icons as you pan around the sky), reporting, and hopefully planning too.

#53 csa/montana

csa/montana

    Den Mama & Gold Star Award Winner

  • *****
  • Moderators
  • Posts: 111,470
  • Joined: 14 May 2005

Posted 08 June 2010 - 10:25 PM

Does the latest release have the capability of printing charts?

#54 avarakin

avarakin

    Vanguard

  • *****
  • Posts: 2,431
  • Joined: 13 Jul 2009

Posted 08 June 2010 - 11:16 PM

I installed Stellarium 0.10.4 and Kstars on my Lenovo S10 netbook running Ubuntu 10.04 and I liked Stellarium on this hardware running much better. What is missing though, is someting to record observation session. Kstars has this function.
I found a probosal to build it:
http://www.stellariu...ervation_Logger

Was there any work done in this area?

Alex


Yes, I have this working. It's just not linked in to the app at the moment; you would have to put it there manually.

I've been working on this a good deal over the last two weeks, trying to make it better. I'll get the WIKI page for it done this week, with screen shots to solicit feedback. Unfortunately, I'm not the best UI person, so that needs work. The initial release will be just basic recording. In the future, I plan on screen overlays (so you can see icons as you pan around the sky), reporting, and hopefully planning too.


Great news!
I can help with testing. How do I get the code? Pull from Bazaar?

Alex

#55 Bagged Star

Bagged Star

    Explorer 1

  • -----
  • topic starter
  • Posts: 70
  • Joined: 15 Mar 2010

Posted 09 June 2010 - 01:03 AM

Great news!
I can help with testing. How do I get the code? Pull from Bazaar?


There's a Bazaar branch at Stellarium's Launchpad site, but it's only a read-only mirror of the main Subversion repository at SourceForge:
http://sourceforge.n...llarium/develop

#56 Bagged Star

Bagged Star

    Explorer 1

  • -----
  • topic starter
  • Posts: 70
  • Joined: 15 Mar 2010

Posted 09 June 2010 - 01:06 AM

Does the latest release have the capability of printing charts?


No. You can make screenshots (Ctrl+S, there's an option to invert the colours) and print them, but there's no built-in option to print directly.

#57 Cliff Hipsher

Cliff Hipsher

    Apollo

  • ***--
  • Posts: 1,158
  • Joined: 31 Dec 2008

Posted 09 June 2010 - 09:25 AM

OK, I read the Ocular section in the Wiki and I think I understand what it says about exit circle and all of that. I guess I need to take a look at the .INI file and then I need to dig out the specs for my motley crew of EPs and maybe ask some questions over in the EPs forum.

Thanks...

#58 Cliff Hipsher

Cliff Hipsher

    Apollo

  • ***--
  • Posts: 1,158
  • Joined: 31 Dec 2008

Posted 09 June 2010 - 01:29 PM

I got it working.....

I had Scaling turned on for one thing (tried it with and without earlier), and I did tweak my EP settings. Works MUCHO better now...

Many thanks....

#59 Edward E

Edward E

    Apollo

  • *****
  • Posts: 1,449
  • Joined: 26 Mar 2006

Posted 09 June 2010 - 03:55 PM

I came across this .xls sheet from Thierry in France that has most of the specs on a huge collection of eyepieces; thought it might be of help to us setting up the ocular plugin.

eyepieces.xls

#60 treaves

treaves

    Vostok 1

  • *****
  • Posts: 108
  • Joined: 27 Jan 2009

Posted 09 June 2010 - 09:28 PM

Does the latest release have the capability of printing charts?


No, but it is in the works. :)

#61 treaves

treaves

    Vostok 1

  • *****
  • Posts: 108
  • Joined: 27 Jan 2009

Posted 09 June 2010 - 09:29 PM

I got it working.....

I had Scaling turned on for one thing (tried it with and without earlier), and I did tweak my EP settings. Works MUCHO better now...

Many thanks....


Cool; glad to hear that.

Please let me know of any ideas for improvement.

#62 treaves

treaves

    Vostok 1

  • *****
  • Posts: 108
  • Joined: 27 Jan 2009

Posted 09 June 2010 - 09:34 PM

Great news!
I can help with testing. How do I get the code? Pull from Bazaar?


There's a Bazaar branch at Stellarium's Launchpad site, but it's only a read-only mirror of the main Subversion repository at SourceForge:
http://sourceforge.n...llarium/develop


We may go to Bazaar in the next couple of weeks. Please feel free to e-mail me directly, or join the IRC channel, and I'll help you get going.

#63 avarakin

avarakin

    Vanguard

  • *****
  • Posts: 2,431
  • Joined: 13 Jul 2009

Posted 09 June 2010 - 10:29 PM

Great news!
I can help with testing. How do I get the code? Pull from Bazaar?


There's a Bazaar branch at Stellarium's Launchpad site, but it's only a read-only mirror of the main Subversion repository at SourceForge:
http://sourceforge.n...llarium/develop


We may go to Bazaar in the next couple of weeks. Please feel free to e-mail me directly, or join the IRC channel, and I'll help you get going.


I was not aware you are using svn instead of bzr as your primary repo.
I guess you have the feature in a branch in svn? If yes, then I guess I should be able to pull it from there, just give me name of the branch.

#64 pfile

pfile

    Fly Me to the Moon

  • -----
  • Posts: 5,747
  • Joined: 14 Jun 2009

Posted 05 July 2010 - 11:04 PM

i just upgraded to 0.10.5 (OSX 10.6) and for some reason i can't get the ocular plugin to load. i get this in the log:

Loaded plugin "Oculars" .
Ocular plugin - press Command-o to toggle eyepiece view mode. Press ALT-o for configuration.
Oculars::validateIniFile ocular.ini exists at: "/Volumes/newLeopard/Users/pfile/Library/Application Support/Stellarium/modules/Oculars/ocular.ini" . Checking version...
Oculars::validateIniFile found existing ini file version 0.12
QSqlDatabase: QSQLITE driver not loaded
QSqlDatabase: available drivers:
Oculars could not open its database; disabling module.

when reverting back to 0.10.4 oculars loads fine. is something messed up with the build of 0.10.5? or could this be some incompatibility with macports?


thanks for any ideas.

edit: oh yeah, after this failure, the plugin seems to be partially registered somewhere, because stellarium crashes while trying to call the oculars destructor on exit:

Thread 0 Crashed: Dispatch queue: com.apple.main-thread
0 org.stellarium.Stellarium 0x002fab94 Oculars::~Oculars() + 36
1 org.stellarium.Stellarium 0x0007b690 StelModuleMgr::unloadModule(QString const&, bool) + 144
2 org.stellarium.Stellarium 0x0007c6b7 StelModuleMgr::unloadAllPlugins() + 167
3 org.stellarium.Stellarium 0x001be78f StelMainGraphicsView::deinitGL() + 79
4 org.stellarium.Stellarium 0x001e9f97 main + 6951
5 org.stellarium.Stellarium 0x00008992 _start + 216
6 org.stellarium.Stellarium 0x000088b9 start + 41


#65 Bagged Star

Bagged Star

    Explorer 1

  • -----
  • topic starter
  • Posts: 70
  • Joined: 15 Mar 2010

Posted 06 July 2010 - 08:24 AM

i just upgraded to 0.10.5 (OSX 10.6) and for some reason i can't get the ocular plugin to load. i get this in the log:

Loaded plugin "Oculars" .
Ocular plugin - press Command-o to toggle eyepiece view mode. Press ALT-o for configuration.
Oculars::validateIniFile ocular.ini exists at: "/Volumes/newLeopard/Users/pfile/Library/Application Support/Stellarium/modules/Oculars/ocular.ini" . Checking version...
Oculars::validateIniFile found existing ini file version 0.12
QSqlDatabase: QSQLITE driver not loaded
QSqlDatabase: available drivers:
Oculars could not open its database; disabling module.


It seems that for some reason you are missing Qt's SQLite driver or Stellarium can't find it. I am not sure how things are on Mac OS X, but on Windows, it is included in the installation package. Perhaps the person who packaged 0.10.5 for Mac OS X forgot to include it?

#66 John_G

John_G

    Viking 1

  • -----
  • Posts: 710
  • Joined: 18 Jan 2010

Posted 06 July 2010 - 09:29 AM

I just installed version 0.10.5 on my 64 bit Windows 7 and it runs great for me. Very smooth. After reinstalling Voyageur 4.5 on my laptop and old Vista desktop, my license ran out for the number of installations I'm allowed, so Stellarium's a keeper along with SkyTools 3.

#67 pfile

pfile

    Fly Me to the Moon

  • -----
  • Posts: 5,747
  • Joined: 14 Jun 2009

Posted 06 July 2010 - 10:49 AM

thanks DS, i'll take a look in the application bundle and see what's different between 0.10.4 and 0.10.5.

#68 Laurent Michel

Laurent Michel

    Lift Off

  • -----
  • Posts: 18
  • Joined: 20 Apr 2010

Posted 21 July 2010 - 02:33 PM

That's because the compiled version of the SQLite driver refers to QT 4.7.
I did not have it installed on my machine either and it wouldn't have been in that directory anyway. To check, navigate to the sqldriver directory under the Application bundle inside Contents/MacOS. If you have the developer tools installed, you can issue the command "otool" which will produce the following output:

slive: ldm$ otool -L libqsqlite.dylib 
libqsqlite.dylib (architecture i386):
	libqsqlite.dylib (compatibility version 0.0.0, current version 0.0.0)
	/usr/local/Trolltech/Qt-4.7.0/lib/QtSql.framework/Versions/4/QtSql (compatibility version 4.7.0, current version 4.7.0)
	/usr/local/Trolltech/Qt-4.7.0/lib/QtCore.framework/Versions/4/QtCore (compatibility version 4.7.0, current version 4.7.0)
	/usr/lib/libstdc++.6.dylib (compatibility version 7.0.0, current version 7.4.0)
	/usr/lib/libgcc_s.1.dylib (compatibility version 1.0.0, current version 1.0.0)
	/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 111.1.5)
libqsqlite.dylib (architecture ppc):
	libqsqlite.dylib (compatibility version 0.0.0, current version 0.0.0)
	/usr/local/Trolltech/Qt-4.7.0/lib/QtSql.framework/Versions/4/QtSql (compatibility version 4.7.0, current version 4.7.0)
	/usr/local/Trolltech/Qt-4.7.0/lib/QtCore.framework/Versions/4/QtCore (compatibility version 4.7.0, current version 4.7.0)
	/usr/lib/libstdc++.6.dylib (compatibility version 7.0.0, current version 7.4.0)
	/usr/lib/libgcc_s.1.dylib (compatibility version 1.0.0, current version 1.0.0)
	/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 111.1.5)

You can clearly see the problem. So either you get QT 4.7 and install it exactly at that location.... Or you cheat like me by picking up the libsqlite.dylib from Stellarium 0.10.4 which works like a charm!

You can copy the dylib file in place and the same otool command should now dutifully report:


libqsqlite.dylib (architecture i386):
	libqsqlite.dylib (compatibility version 0.0.0, current version 0.0.0)
	@executable_path/../Frameworks/QtSql.framework/Versions/4/QtSql (compatibility version 4.6.0, current version 4.6.0)
	@executable_path/../Frameworks/QtCore.framework/Versions/4/QtCore (compatibility version 4.6.0, current version 4.6.0)
	/usr/lib/libstdc++.6.dylib (compatibility version 7.0.0, current version 7.4.0)
	/usr/lib/libgcc_s.1.dylib (compatibility version 1.0.0, current version 1.0.0)
	/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 88.3.11)
libqsqlite.dylib (architecture ppc):
	libqsqlite.dylib (compatibility version 0.0.0, current version 0.0.0)
	@executable_path/../Frameworks/QtSql.framework/Versions/4/QtSql (compatibility version 4.6.0, current version 4.6.0)
	@executable_path/../Frameworks/QtCore.framework/Versions/4/QtCore (compatibility version 4.6.0, current version 4.6.0)
	/usr/lib/libstdc++.6.dylib (compatibility version 7.0.0, current version 7.4.0)
	/usr/lib/libgcc_s.1.dylib (compatibility version 1.0.0, current version 1.0.0)
	/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 88.3.11)

Which is a lot better! It looks in the Framework folder of the App bundle and if that fails, it falls back on the Standard location for QT 4.6 (Which I do have on my machine).

Hope that helps!

PS/ I now have the telrad view... happy!

--
Laurent

#69 GeneT

GeneT

    Ely Kid

  • *****
  • Posts: 16,161
  • Joined: 07 Nov 2008

Posted 21 July 2010 - 07:12 PM

This is a great program!

#70 pfile

pfile

    Fly Me to the Moon

  • -----
  • Posts: 5,747
  • Joined: 14 Jun 2009

Posted 22 July 2010 - 11:38 PM

That's because the compiled version of the SQLite driver refers to QT 4.7.
...

Hope that helps!

PS/ I now have the telrad view... happy!

--
Laurent


i had forgotten to check this thread for some time. i do have the developer tools installed, and i see the same thing. copied the old dylib and ocular is working. thanks!

doesn't this mean that stellarium 10.5 was packaged wrong? who are we supposed to contact about this?

#71 b1gred

b1gred

    Enginerd

  • *****
  • Posts: 16,902
  • Joined: 01 Apr 2004

Posted 23 July 2010 - 02:15 PM

Well it doesn't seem to work on my 64bit Win7 machine for me. I can get the popup menus to show when I move my mouse toward the lower left corner, but the cursor doesn't show up so I can't see where I'm trying to change anything.

#72 DavidD

DavidD

    Viking 1

  • *****
  • Posts: 736
  • Joined: 23 Jul 2009

Posted 23 July 2010 - 02:45 PM

Try using the alternate startup shortcut, so that a less strenuous video interface is used. See earlier in this thread. I have 64-bit Win7 and it works fine for me.

#73 b1gred

b1gred

    Enginerd

  • *****
  • Posts: 16,902
  • Joined: 01 Apr 2004

Posted 23 July 2010 - 04:09 PM

I've tried the alternate (no OpenGL) option, still no visible cursor. Makes it really hard to run...

I've also tried it in "no OpenGL" and compat mode for XP SP2 and SP3, as well as no compat. Just don't get a visible cursor.

#74 DavidD

DavidD

    Viking 1

  • *****
  • Posts: 736
  • Joined: 23 Jul 2009

Posted 23 July 2010 - 05:00 PM

Interesting. First, it should work, as I have it working, though it took some tweaking.

So, you don't see the mouse pointer? But you can see evidence that it moves, as you see the menus pop out?

Just making sure we understand the issue.

David

BTW, I'm no Stellarium expert, but an a software dev, and am running 64-bit Win7, so I'm willing to give it some guesses.

#75 b1gred

b1gred

    Enginerd

  • *****
  • Posts: 16,902
  • Joined: 01 Apr 2004

Posted 23 July 2010 - 09:52 PM

Yes, I can manipulate the cursor as evidenced by the icons highlighting in the popup menus on the lower left corner of the screen, but the cursor pointer doesn't show up.


CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.


Recent Topics






Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics