Jump to content

  •  

CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.

Photo

ZWO PROBLEM

  • Please log in to reply
20 replies to this topic

#1 JGray

JGray

    Sputnik

  • -----
  • topic starter
  • Posts: 34
  • Joined: 05 Aug 2014

Posted 19 June 2017 - 06:38 PM

I bought a ZWO ASI 120mm camera to use for guiding.  It arrived today and I set to work trying to connect it and get it working.  I am using PHD2 software.  There is a manual included in the CD that came with the camera but it is next to useless.  I found another manual on-line but it is four years old and is not relevant to the current version of the ZWO or PHD(I guess.)  Appealing to the ZWO site yielded a version of the next to useless manual included on the CD that is made totally useless because it is written mainly in Japanese and I could not begin to read it.

  

After much frustration and guessing and by-goshing due to the lack of a competent set of instructions, I managed to get the camera and mount (CGEM) to connect to the lap top.  However, after 30 seconds the camera connection fails.  

 

I had hoped to be able to make direct connection from the camera to the mount without going through the hand controller.  That's one of the reasons why I bought the camera.  Right now, I don't care if I have to route the connection through Bungfuzzle, Egypt.  I just want to get it working.  I have tried through the hand controller as well as directly into the Auto Guide port of the CGEM.  I have tried the different drivers  available from ZWO for which there is no explanation as to what the differences are.  Nothing has worked.  

 

What I am appealing to you forum members for is maybe some info. on where I can find a competent and current manual for dealing with a ZWO camera.  If not that, maybe just a set of instructions that works.

 

THX.



#2 leveye

leveye

    Gemini

  • *****
  • Posts: 3409
  • Joined: 06 Feb 2013
  • Loc: Central Oregon Coast

Posted 19 June 2017 - 06:48 PM

 First thing to do is replace the cable it came with. They are unfortunately not very good. Are you using a USB hub at all? If your trying to pulse guide which you should be the guide camera usb out goes to the computer and then a USB connection goes back out to the mount. A direct connection is preferable and not through the handset using a serial converter but you might have to with your Celestron. Then in PHD2 you choose your camera in the drop down menu. You'll want to input your guide camera's pixel size and your guide scopes focal length into PHD2 calibration step calculator and then input that number into calibration step size.


Edited by leveye, 19 June 2017 - 06:51 PM.


#3 jtrezzo

jtrezzo

    Messenger

  • *****
  • Posts: 449
  • Joined: 13 Mar 2017
  • Loc: St. Petersburg, FL

Posted 19 June 2017 - 06:57 PM

I had an issue with this when I first got mine. It was a very odd one, where I had a USB port turning itself off after a time. Check your device manager and make sure that all your USB ports do not have the "allow computer to turn this device off" check box ticked. In my case it was actually a bluetooth port, for some reason. That solved it for me.



#4 leveye

leveye

    Gemini

  • *****
  • Posts: 3409
  • Joined: 06 Feb 2013
  • Loc: Central Oregon Coast

Posted 19 June 2017 - 07:01 PM

I had an issue with this when I first got mine. It was a very odd one, where I had a USB port turning itself off after a time. Check your device manager and make sure that all your USB ports do not have the "allow computer to turn this device off" check box ticked. In my case it was actually a bluetooth port, for some reason. That solved it for me.

Sometimes it's a power saving feature that's turned on that does that to the USB ports. You want to turn that off for sure.



#5 gambera

gambera

    Sputnik

  • *****
  • Posts: 34
  • Joined: 08 Jun 2016

Posted 19 June 2017 - 10:05 PM

Like jtrezzo and leveye said, disable USB power saving mode on your laptop. Actually ZWO has an instruction on how to do it in one of their useless manuals 

https://astronomy-im.../QuickGuide.pdf  step 5 on page 6. In case you don't already know.

 

In PHD2 choose "ZWO ASI Camera" (the last one down) in the drop down menu under Connect Equipment. This way you can only change camera Gain thru the Brain settings and to be honest, that's all you need. 

 

Whether you use ST-4 or ASCOM, you still need to connect to your laptop. PHD needs to send the signals to the mount somehow. There are benefits to using ASCOM.

 

I assume you installed zwo camera driver v2.0.1.3 from their web site.

The other driver is ASCOM and is v1.0.2.25


Edited by gambera, 19 June 2017 - 10:09 PM.


#6 gambera

gambera

    Sputnik

  • *****
  • Posts: 34
  • Joined: 08 Jun 2016

Posted 19 June 2017 - 10:08 PM

Just remembered that I've read in one of ZWO manuals (dont remember which one) that you should install camera driver first and then ASCOM.



#7 Jon Rista

Jon Rista

    Hubble

  • *****
  • Posts: 18127
  • Joined: 10 Jan 2014
  • Loc: Colorado

Posted 20 June 2017 - 12:16 AM

I had hoped to be able to make direct connection from the camera to the mount without going through the hand controller.  That's one of the reasons why I bought the camera.  Right now, I don't care if I have to route the connection through Bungfuzzle, Egypt.  I just want to get it working.  I have tried through the hand controller as well as directly into the Auto Guide port of the CGEM.  I have tried the different drivers  available from ZWO for which there is no explanation as to what the differences are.  Nothing has worked.  

So just to make sure I understand. You are connecting the camera both via USB to the computer, as well as to the mount via ST-4? 

 

When you are connecting to the mount. How are you connecting? Via the mount's ASCOM driver? Or are you using the "On Camera" option in PHD2? If the former, then even if you connect the camera to the mount via ST-4, it won't matter, because you've connected PHD2 directly to the mount via ASCOM. You would have to choose "On Camera" to connect PHD2 to the mount via the ST-4 cable connecting the camera to the mount/HC. 

 

HOWEVER, that said...WHY on God's green earth would you WANT to use ST-4? ST-4 is old and limited, and will likely not give you the best guiding possible. It is better to connect PHD2 directly to the mount via ASCOM, and ignore ST-4 entirely. I am curious, if you remove the ST-4 cable, connect the mount via ASCOM and then connect to the camera, whether the camera will stay connected.

 

There is one other thought I have as well. I have the QHY5L-II, the QHY counterpart to the ASI120. Both cameras are pretty notorius for having connectivity problems. I have discovered that the 5L-II really likes to have 30-60 seconds to "settle" after it's been powered up. By that, I mean, it greatly prefers to have a powered USB hub at the mount, it prefers to be plugged into that hub first, with a "settling" time of at least 30 seconds, before the powered USB hub is connected to the computer. If I don't do this, then my 5L-II can be quite unstable. However, since I always wait at least 30 seconds now before connecting my USB cable to my powered USB hub, I never have any problems with the 5L-II.

 

I wonder if the ASI120 might have a similar problem? Have you ever tried that? Powered usb hub at the mount:

 

1) Power the hub.

2) Connect the camera to the hub.

3) Wait 45-60 seconds.

4) Connect USB to powered hub and computer.

 

Might be worth a try to see if the camera starts working.

 

Finally, as a side note...I have recent first hand knowledge ZWO is working very hard on bettering their English documentation. ;) It's a top priority for them, and it should greatly improve their support of individuals such as yourself who just needed a readable manual to help you through the setup process. 



#8 AhBok

AhBok

    Apollo

  • *****
  • Posts: 1042
  • Joined: 02 Dec 2010

Posted 20 June 2017 - 08:58 PM

Just a data point on Jon's posting. I had a bunch of intermittent connection issues when first using my ASI120 as a guide camera until I mounted a 4-port powered USB hub on my scope's dolly. I've never had a connection issue since.



#9 leveye

leveye

    Gemini

  • *****
  • Posts: 3409
  • Joined: 06 Feb 2013
  • Loc: Central Oregon Coast

Posted 20 June 2017 - 09:25 PM

My experience with an ASI120 using a 4 port Ethernet USB extension hub was not good until I first replaced the supplied cable.After that all was great. You must also always remember to never use a repeater cable direct from the camera to the hub.  If you do it will confuse USB protocol and you'll have connection issues. USB reads any repeater cable as a hub unto itself. Only a standard USB cable from camera to the hub and your good.



#10 Bigdan

Bigdan

    Viking 1

  • *****
  • Posts: 642
  • Joined: 17 Dec 2014
  • Loc: Panacea, FL

Posted 20 June 2017 - 09:40 PM

On a CGEM you can't go from camera to mount head.  If you haven't already, you should set up ASCOM platform.... download the latest ASCOM platform, and then separately download the latest ASCOM Nexstar driver.  Get all that installed, then USB from camera should go to USB hub.  You will have to plug into the bottom of the hand controller for the CGEM.  Use the serial cable that came with the CGEM to run from the hand controller to a serial/USB adapter, then to USB socket on your laptop.  Those adapters are at Office Depot, or tons of them available online.

 

ASCOM guiding would be superior to ST-4 connection.  I believe more of the guiding log is generated for evaluation of your guiding performance.

 

Some guide cameras need to be plugged into a USB hub for extra power in order to work.  From some of the posts above, sounds like that is your case, which is normal.

 

Having to connect to the hand controller is a Celestron/Nexstar issue and not a problem with your camera. 


Edited by Bigdan, 20 June 2017 - 10:09 PM.


#11 MoonPrince

MoonPrince

    Sputnik

  • -----
  • Posts: 46
  • Joined: 27 Mar 2017

Posted 21 June 2017 - 01:36 AM

I think you need to install  ASI ASCOM camera driver:http://astronomy-ima...p V1.0.2.25.exe



#12 gbeaton

gbeaton

    Ranger 4

  • -----
  • Posts: 310
  • Joined: 06 Oct 2016
  • Loc: Montreal

Posted 21 June 2017 - 07:05 AM

I have the same setup except with a HEQ5. No issues with the ASI120mm except I discovered that it wouldn't guide south when using ST-4. I'm hoping its the cable like others have mentioned.

 

The order of the driver installation didn't matter in my case. Ridiculous to expect to have to re-install ASCOM after the camera. That would be bulls***

 

Just install all relevant looking stuff

 

In my case , I just selected the ZWO camera directly in PHD2 and for mount use "on-camera" if you want to use ST-4. Otherwise you use the ASCOM driver for mount control. I've got it working on both mac and windows. Pretty happy with it except for the ST-4 issue.



#13 astronate

astronate

    Lift Off

  • -----
  • Posts: 14
  • Joined: 14 Jan 2016

Posted 21 June 2017 - 09:38 AM

One more thing to try. My older ASI120MC (not the -S) prefers USB2 to USB3.


Sent from my iPad using Tapatalk

#14 rgsalinger

rgsalinger

    Vanguard

  • *****
  • Moderators
  • Posts: 2381
  • Joined: 19 Feb 2007
  • Loc: Carlsbad Ca

Posted 21 June 2017 - 10:08 AM

The most likely problem when you have a connection that works for a while and then fails is always going to be the USB cable that you are using. The best topology you can use is a single usb cable going from your imaging computer to a powered hub. (I use three of the startech 7 port hubs and have had almost zero USB problems for years now.) Connect all the devices to the powered hub. Second, if possible, only USB cables that are labeled 28/24. These cables have heavier gauge wiring for sending power and signal over USB than cheaper cables do. Finally, keep the cable runs as short as possible. The use of a hub helps with this as the hub can even be mounted on the OTA in some circumstances.

 

Next, don't use the ST4 cable. It's unnecessary and is just another source of potential snagging and failure. The signal path for guiding has to go through your laptop and be processed. There's really no reason to send the correction back to the camera and then have the camera send it to the mount, when you can just send it directly to the mount. The only reason that the ST4 ports even exist is to support situations where there is no computer involved - stand alone guiders. This can be a great way to image when a computer isn't needed - use a DSLR with an intervalometer and you're good to go.

 

There also seems to be some confusing about ZWO drivers in this thread. From what I have been able to understand, you need to install both the native windows driver and the ascom driver for your camera to work. If you are using the ascom driver, then you need to correct version of the ascom platform. The platform acts as a kind of middle ware between imaging software and the camera's driver. I am pretty convinced, though, that the order of installation is largely irrelevant. (At least this is true on my Windows 10 systems.)



#15 Gipht

Gipht

    Viking 1

  • *****
  • Posts: 542
  • Joined: 12 Nov 2016

Posted 21 June 2017 - 08:37 PM

I just received the -s version of the same camera, and I am having the same issue.  Works for a while the stops.  I have changed the USB enable to disable on power saving.  Headed out to give it a try.    I am wondering if the USB  3 is backwards compatible to my 5 year old laptop?



#16 rgsalinger

rgsalinger

    Vanguard

  • *****
  • Moderators
  • Posts: 2381
  • Joined: 19 Feb 2007
  • Loc: Carlsbad Ca

Posted 21 June 2017 - 10:59 PM

It's not going to be USB power saving after 30 seconds of disconnection. I would start troubleshooting by using a really short USB cable directly to your PC and seeing if that has the same problem. If it does then the problem is most likely software and could be the drivers. I've got two ZWO cameras and have had no trouble with the ascom drivers for them for at least the past 6 months using several different computers. I run Win10 Pro on all three machines that have connected to them.

Rgrds-Ross



#17 Gipht

Gipht

    Viking 1

  • *****
  • Posts: 542
  • Joined: 12 Nov 2016

Posted 22 June 2017 - 12:11 AM

Well so far, so good on mine.  Plugged and unplugged the computer side  of the USB several times, and heard a ding, then it connected.  Has been going for about 30 minutes now.   Maybe, crosses fingers, Gambera's suggestion to disable the power saver on the USB was the trick.


  • Sprigan76 likes this

#18 rmollise

rmollise

    ISS

  • *****
  • Posts: 21498
  • Joined: 06 Jul 2007

Posted 22 June 2017 - 01:47 PM

On a CGEM you can't go from camera to mount head. 

 

You can't? Strange, I do it every time. ST-4 cable from camera to auto-guide port...

 

ST-4 and ASCOM guiding in my experience are about equal. The advantage of ST-4 is no messing with ASCOM required. ;)


  • rgsalinger and dfisherows like this

#19 My 2 Stars

My 2 Stars

    Vendor - "Listen To The Stars" Audio & Sketch Book

  • -----
  • Vendors
  • Posts: 902
  • Joined: 13 Dec 2015
  • Loc: SE Penna.

Posted 22 June 2017 - 02:10 PM

Many have given you good advice so I won't add to that. But I do have ONE question?

Where is Bungfuzzle Egypt? wink.gif

 

 



#20 leveye

leveye

    Gemini

  • *****
  • Posts: 3409
  • Joined: 06 Feb 2013
  • Loc: Central Oregon Coast

Posted 22 June 2017 - 02:28 PM

Well so far, so good on mine.  Plugged and unplugged the computer side  of the USB several times, and heard a ding, then it connected.  Has been going for about 30 minutes now.   Maybe, crosses fingers, Gambera's suggestion to disable the power saver on the USB was the trick.

Post # 4 where it was suggested first. Just fyi.


  • Gipht likes this

#21 Gipht

Gipht

    Viking 1

  • *****
  • Posts: 542
  • Joined: 12 Nov 2016

Posted 22 June 2017 - 03:36 PM

Sorry leveye, my skim reading skills need some work.   Thanks for your help.  The guided tracking worked great for the entire 3 hours.  This was my first attempt to guide ever and I did not need more confusion then I already had.  When I looked at the graph showing 2 colors  of tracking lines and two different pulse signals, I had to run inside and see what the heck I was looking at.  My efforts were a little weak on prep., but got a decent photo of Whirpool.  I had the tracking response to soft at 4 seconds.  This resulted in a dec error of around 3 seconds.  I might need to work on the backlash.   Here is the photo that resulted:

 

 

 

Attached Thumbnails

  • whirlpool1sttguided.jpg

  • Erik30 likes this


CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.







Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics