Jump to content

  •  

CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.

Photo

New guide camera not connecting to PHD2

  • Please log in to reply
14 replies to this topic

#1 WConde

WConde

    Vostok 1

  • *****
  • topic starter
  • Posts: 152
  • Joined: 04 Oct 2014

Posted 22 November 2018 - 11:44 AM

Hello everyone!  Happy Thanksgiving!  Since yesterday I've been trying to connect a new ZWO ASI 120 mini that I purchased for my OAG system without success.  I image using a ZWO ASI 1600 and when I ask PHD to connect the camera it automatically connects the 1600 instead of recognizing the 120.  It doesn't give me a way to connect the 120.  If  I disconnect the 1600, PHD then sends a message that it cannot find any ZWO camera.   I checked in the control Panel and both cameras show there (see attached image, sorry about the weird orientation).  Has this happened to anyone?  I am at loss here, please help!

 

 

Attached Thumbnails

  • Device manager.jpg


#2 jmiller1001

jmiller1001

    Mariner 2

  • *****
  • Posts: 296
  • Joined: 21 Mar 2016
  • Loc: Bay Area, CA

Posted 22 November 2018 - 12:15 PM

I had the same issue the other night with my ASI071 and my ASI120 in PHD2.  I have not gotten around to looking at, but this a good prompt - let me try to debug it right now.  Be back in a minute.



#3 cfosterstars

cfosterstars

    Mercury-Atlas

  • *****
  • Posts: 2,784
  • Joined: 05 Sep 2014
  • Loc: Austin, Texas

Posted 22 November 2018 - 12:24 PM

I assume that you are using the ASCOM driver to connect your cameras and not the native driver. With the ASCOM, there are two drivers: one for camera 1 and one from camera 2. You have to use the camera 1 driver for one camera say your ASI1600MM and the camera 2 driver for the guide camera say your ASI120MM. Or you can use the native for the giude camera and the ASCOM for the image camera. I use Sequence Generator Pro and use the ASCOM connections without issue. I have even used the two ASCOM drives for two imaging camera collecting at the same time and the native driver for the guide camera. What main imaging software are you using?

 

One issue with the ZWO cameras that I wish they would change is to have a third ASCOM driver for the guide scope so that I can not use the native driver. The native driver is on 8 bit and I get much better guiding with the ASCOM driver at 16 bit. QHY has such a third guide camera ascom driver. I have requested this from ZWO twice and they say its not worth it. If you can, ask for this on the ZWO forum. 

 

I should be able to get this working for you with more details. For the native in PHD2, there is a button on the connection popup that allows you to select which camera you want to use. 

 

Have you updated to the latest ZWO drivers on the web page.?


  • WConde likes this

#4 Mike7Mak

Mike7Mak

    Surveyor 1

  • *****
  • Posts: 1,807
  • Joined: 07 Dec 2011
  • Loc: New York

Posted 22 November 2018 - 12:24 PM

There's a button in the connect dialog to select between multiple cameras of the same type. Maybe you need to update PHD to the latest version?

Attached Thumbnails

  • phd-zwo.jpg

  • bmurphy495 and WConde like this

#5 jmiller1001

jmiller1001

    Mariner 2

  • *****
  • Posts: 296
  • Joined: 21 Mar 2016
  • Loc: Bay Area, CA

Posted 22 November 2018 - 12:42 PM

Ok - Problem solved.  

 

BTW, you may want to check out this thread:  https://astronomy-im...php?f=21&t=7174

 

I downloaded the latest ASCOM driver - but that or may not have helped. :-)

 

Ok - When you into PHD2 and go into the Connect Equipment Menu.  Select ZWO ASI Camera as the driver (not the ASCOM driver #1 or #2) - if your set-up is like mine both of those drivers default to the ASI1600 (or ASI071 in my case).

 

Before you hit the Connect button, there is an icon just to the right of the ZWO ASI Camera driver (it has two arrows that converge into one).  Hit that icon and you should get an option to connect to either the 1600 or the 120.  Select the 120 and hit Connect.  

 

You should be good to go.

 

Let me know if this works.


  • bmurphy495 likes this

#6 KenS

KenS

    Viking 1

  • *****
  • Posts: 922
  • Joined: 10 Jan 2015
  • Loc: Melbourne, Australia

Posted 22 November 2018 - 02:58 PM

And if you click the button to the right of that one you get the choice of 8bit or 16bit.



#7 cfosterstars

cfosterstars

    Mercury-Atlas

  • *****
  • Posts: 2,784
  • Joined: 05 Sep 2014
  • Loc: Austin, Texas

Posted 22 November 2018 - 03:27 PM

And if you click the button to the right of that one you get the choice of 8bit or 16bit.

I dont see this option at all. I would love to be able to use the native driver in 16bit mode. Can you do a screen shot?



#8 WConde

WConde

    Vostok 1

  • *****
  • topic starter
  • Posts: 152
  • Joined: 04 Oct 2014

Posted 22 November 2018 - 06:38 PM

I assume that you are using the ASCOM driver to connect your cameras and not the native driver. With the ASCOM, there are two drivers: one for camera 1 and one from camera 2. You have to use the camera 1 driver for one camera say your ASI1600MM and the camera 2 driver for the guide camera say your ASI120MM. Or you can use the native for the giude camera and the ASCOM for the image camera. I use Sequence Generator Pro and use the ASCOM connections without issue. I have even used the two ASCOM drives for two imaging camera collecting at the same time and the native driver for the guide camera. What main imaging software are you using?

 

One issue with the ZWO cameras that I wish they would change is to have a third ASCOM driver for the guide scope so that I can not use the native driver. The native driver is on 8 bit and I get much better guiding with the ASCOM driver at 16 bit. QHY has such a third guide camera ascom driver. I have requested this from ZWO twice and they say its not worth it. If you can, ask for this on the ZWO forum. 

 

I should be able to get this working for you with more details. For the native in PHD2, there is a button on the connection popup that allows you to select which camera you want to use. 

 

Have you updated to the latest ZWO drivers on the web page.?

 

 

There's a button in the connect dialog to select between multiple cameras of the same type. Maybe you need to update PHD to the latest version?

 

 

Ok - Problem solved.  

 

BTW, you may want to check out this thread:  https://astronomy-im...php?f=21&t=7174

 

I downloaded the latest ASCOM driver - but that or may not have helped. :-)

 

Ok - When you into PHD2 and go into the Connect Equipment Menu.  Select ZWO ASI Camera as the driver (not the ASCOM driver #1 or #2) - if your set-up is like mine both of those drivers default to the ASI1600 (or ASI071 in my case).

 

Before you hit the Connect button, there is an icon just to the right of the ZWO ASI Camera driver (it has two arrows that converge into one).  Hit that icon and you should get an option to connect to either the 1600 or the 120.  Select the 120 and hit Connect.  

 

You should be good to go.

 

Let me know if this works.

I combined all your recommendations and I think i was able to solve the issue.  The cameras are now  connecting correctly through the ZWO Ascom Driver (not the native ZWO driver)  The only thing is that under PHD I can only find the ASI 120 camera, which I selected as my ASI camera 2.  That allows me to asign the ASI 1600 as the ASI Camera 1 in SGPro.  I am too tired to test this tonight but will confirm over the weekend if it actually worked.  Thank you everyone!



#9 cfosterstars

cfosterstars

    Mercury-Atlas

  • *****
  • Posts: 2,784
  • Joined: 05 Sep 2014
  • Loc: Austin, Texas

Posted 22 November 2018 - 08:31 PM

I combined all your recommendations and I think i was able to solve the issue.  The cameras are now  connecting correctly through the ZWO Ascom Driver (not the native ZWO driver)  The only thing is that under PHD I can only find the ASI 120 camera, which I selected as my ASI camera 2.  That allows me to asign the ASI 1600 as the ASI Camera 1 in SGPro.  I am too tired to test this tonight but will confirm over the weekend if it actually worked.  Thank you everyone!

I am pretty sure that this will work for you. Its exactly what I use.


  • WConde likes this

#10 KenS

KenS

    Viking 1

  • *****
  • Posts: 922
  • Joined: 10 Jan 2015
  • Loc: Melbourne, Australia

Posted 22 November 2018 - 08:43 PM

I dont see this option at all. I would love to be able to use the native driver in 16bit mode. Can you do a screen shot?

Capture.png



#11 cfosterstars

cfosterstars

    Mercury-Atlas

  • *****
  • Posts: 2,784
  • Joined: 05 Sep 2014
  • Loc: Austin, Texas

Posted 23 November 2018 - 09:56 AM

I think that this is a new feature. It is not accessable with my version of PHD2. The button is grayed out.



#12 cfosterstars

cfosterstars

    Mercury-Atlas

  • *****
  • Posts: 2,784
  • Joined: 05 Sep 2014
  • Loc: Austin, Texas

Posted 23 November 2018 - 10:03 AM

This feature is only available in the DEV4 version of 2.5.4. I just downloaded it and its now available. THanks. THis will be nice.



#13 Cfreerksen

Cfreerksen

    Apollo

  • *****
  • Posts: 1,100
  • Joined: 18 Aug 2018
  • Loc: Tooele, Ut

Posted 23 November 2018 - 06:58 PM

This feature is only available in the DEV4 version of 2.5.4. I just downloaded it and its now available. THanks. THis will be nice.

So there is native ASI support for multiple cameras now? I have always had to use the ASCOM driver.

 

Chris



#14 cfosterstars

cfosterstars

    Mercury-Atlas

  • *****
  • Posts: 2,784
  • Joined: 05 Sep 2014
  • Loc: Austin, Texas

Posted 23 November 2018 - 08:47 PM

So there is native ASI support for multiple cameras now? I have always had to use the ASCOM driver.

 

Chris

I have clouds tonight but will test it ASAP. I have found that the ASCOM driver for the ASI190MM-mini works much better for PHD2 than the 8-bit native. If the 16-bit native is as good as the ASCOM, this is really nice. I like to do two camera imaging with a master narrow field and a slave for wide field on the same target. Means I could not use the two ASCOM ports for the two imaging cameras and still be able to use ASCOM for the guide camera since they are all ZWO cameras. If the 16-bit native works, I am in business for two camera acquisition with PHD2 and SGP! I downloaded the 2.6.4dev6 version to test out.


Edited by cfosterstars, 23 November 2018 - 08:48 PM.

  • Cfreerksen likes this

#15 entilza

entilza

    Soyuz

  • *****
  • Posts: 3,774
  • Joined: 06 Oct 2014
  • Loc: Oakville, ON, Canada

Posted 24 November 2018 - 10:46 AM

Download the latest PHD2 dev6 version as of this post.

Many of my friends picked up this camera and had this issue. I hope PHD2 release a new main version as it is a popular camera.

https://openphdguidi...ment-snapshots/


CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.


Recent Topics






Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics