Jump to content

  •  

CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.

Photo

QHY183C - bias/darks random minimum ADU value 0

  • Please log in to reply
15 replies to this topic

#1 niccoc1603

niccoc1603

    Ranger 4

  • -----
  • topic starter
  • Posts: 318
  • Joined: 16 Aug 2018
  • Loc: Firenze, Italy

Posted 11 January 2019 - 04:30 PM

I am testing my new QHY183C

 

I have noticed a weird behavior with bias/dark frames

 

I collect the frames in APT with ASCOM QHY driver, settings below

 

ascom.jpg

 

When I analyze my bias/dark frames, sometimes they return a 0 min ADU value, see below.

These three bias are were shot in a sequence with same settings above. Bias 3 shows min ADU=0

The difference I can spot is that Bias 3 histogram is shifted to the left and a tiny line appears in the right part of the hystogram for Bias 3 (circled in red).

I have no idea is this might be the cause and where it comes from

 

bias.jpg

 

same for the darks:

darks.jpg

 

FITS can be downloaded from here:

https://drive.google...sAF0scKhQ9x9iFE


Edited by niccoc1603, 11 January 2019 - 04:37 PM.


#2 Shiraz

Shiraz

    Viking 1

  • -----
  • Posts: 605
  • Joined: 15 Oct 2010
  • Loc: South Australia

Posted 11 January 2019 - 10:06 PM

that is odd.

 

The camera appears to be sometimes blacking out one and a bit lines at the bottom of the frames. It seems to be only a minor fault that does not appear to affect/shift the main part of the image, so it should be fairly easy to crop - but it should not happen. Maybe worth a note to QHY to see if they can advise/fix it. Might possibly be something to do with the overscan removal, so perhaps try another capture software if you have anything available.


Edited by Shiraz, 11 January 2019 - 10:24 PM.


#3 niccoc1603

niccoc1603

    Ranger 4

  • -----
  • topic starter
  • Posts: 318
  • Joined: 16 Aug 2018
  • Loc: Firenze, Italy

Posted 12 January 2019 - 01:49 AM

I have tried with Sharpcap
 
no issues with direct QHY Driver capture
 
by using ASCOM drivers, the issue is back
 
sharpcapsharpcap-ascom.jpg
 
It seems to be a problem related to QHY ASCOM drivers

Edited by niccoc1603, 12 January 2019 - 01:52 AM.


#4 entilza

entilza

    Soyuz

  • *****
  • Posts: 3745
  • Joined: 06 Oct 2014
  • Loc: Oakville, ON, Canada

Posted 12 January 2019 - 09:48 AM

Hey, What QHY ASCOM Driver version are you using?

 

I loaded the fits in Pixinsight, the little bump is there at the beginning but the minimum value is slightly different.

 

 

Attached Thumbnails

  • qhy183_minimum_Cn2.jpg


#5 niccoc1603

niccoc1603

    Ranger 4

  • -----
  • topic starter
  • Posts: 318
  • Joined: 16 Aug 2018
  • Loc: Firenze, Italy

Posted 12 January 2019 - 10:50 AM

I am using the latest drivers

drivers.jpg

Not sure what the magic is in PI , I loaded the "dark 2" (21-29-04) in Nebulosity and it is showing Min 0 as well

neb.jpg

Edited by niccoc1603, 12 January 2019 - 10:53 AM.


#6 entilza

entilza

    Soyuz

  • *****
  • Posts: 3745
  • Joined: 06 Oct 2014
  • Loc: Oakville, ON, Canada

Posted 12 January 2019 - 11:02 AM

I saved Their 0.19 version - ASCOM 0.19  Can you try that and try your test again please?  

 

https://drive.google...BRQ9tNBdkuoShk-



#7 niccoc1603

niccoc1603

    Ranger 4

  • -----
  • topic starter
  • Posts: 318
  • Joined: 16 Aug 2018
  • Loc: Firenze, Italy

Posted 12 January 2019 - 11:05 AM

ok, how do I remove the previous ones?

#8 entilza

entilza

    Soyuz

  • *****
  • Posts: 3745
  • Joined: 06 Oct 2014
  • Loc: Oakville, ON, Canada

Posted 12 January 2019 - 11:08 AM

Just install this it will remove the old version automatically...

 

To be sure 0.19 installed check the directory:  C:\Program files(x86)\Common Files\ASCOM\Camera     The QHY DLL files should have a time stamp of 2018-11-30.


Edited by entilza, 12 January 2019 - 11:11 AM.


#9 niccoc1603

niccoc1603

    Ranger 4

  • -----
  • topic starter
  • Posts: 318
  • Joined: 16 Aug 2018
  • Loc: Firenze, Italy

Posted 12 January 2019 - 11:29 AM

5119.jpg

ascom1.jpg

Capture.jpg

something's weird

When I connect the camera the first time, the ASCOM driver window shows FW version
connect.jpg

When I open the ASCOM driver settings later FW version is "uknown"

connected.jpg

Edited by niccoc1603, 12 January 2019 - 11:34 AM.


#10 entilza

entilza

    Soyuz

  • *****
  • Posts: 3745
  • Joined: 06 Oct 2014
  • Loc: Oakville, ON, Canada

Posted 12 January 2019 - 11:34 AM

Ack well this didn't help your issue, sorry :(

 

I'm not sure why pixinsight showed a different minimum?



#11 entilza

entilza

    Soyuz

  • *****
  • Posts: 3745
  • Joined: 06 Oct 2014
  • Loc: Oakville, ON, Canada

Posted 12 January 2019 - 11:36 AM

At first I was going to say don't use such fast exposures, but I see you have higher exposure tests... Normally you use Dark flats (not bias) for these CMOS cameras...

 

I'm not sure if what you are seeing is typical for this camera,  maybe everything will be ok.  It could be that overscan area checkbox, that seems to be default for you?  on my QHY163 it is off but it's a different camera.



#12 entilza

entilza

    Soyuz

  • *****
  • Posts: 3745
  • Joined: 06 Oct 2014
  • Loc: Oakville, ON, Canada

Posted 12 January 2019 - 12:54 PM

Mine does the same "unknown" thing after connecting then clicking properties... Probably not anything major.

 

Does the minimum 0 still happen after turning off overscan checkbox?


Edited by entilza, 12 January 2019 - 01:02 PM.


#13 niccoc1603

niccoc1603

    Ranger 4

  • -----
  • topic starter
  • Posts: 318
  • Joined: 16 Aug 2018
  • Loc: Firenze, Italy

Posted 12 January 2019 - 01:29 PM

Yes, both checked and unchecked

#14 bulrichl

bulrichl

    Vostok 1

  • -----
  • Posts: 144
  • Joined: 27 May 2018
  • Loc: La Palma (Canary Islands)

Posted 13 January 2019 - 05:36 AM

Hi,

 


I'm not sure why pixinsight showed a different minimum?

 

Mouse-over option 'Unclipped' in PixInsight's Statistics tool and the following help text will appear:

 

By default, the Statistics tool computes statistics for the subset of pixel sample values within the [0,1] normalized range, that is, excluding pure black and white pixels. Enable this option to compute statistics for the unclipped [0,1] range.

 

So this is expected behavior and you can toggle it by checking/unchecking the option 'Unclipped' in the Statistics tool.

 

Bernd

 



#15 entilza

entilza

    Soyuz

  • *****
  • Posts: 3745
  • Joined: 06 Oct 2014
  • Loc: Oakville, ON, Canada

Posted 13 January 2019 - 12:03 PM

Yes it's that black line at the bottom... and selecting unclipped shows min zero..

 

This probably won't affect anything, I don't think anyway.

Attached Thumbnails

  • qhy183_unclipped.jpg


#16 niccoc1603

niccoc1603

    Ranger 4

  • -----
  • topic starter
  • Posts: 318
  • Joined: 16 Aug 2018
  • Loc: Firenze, Italy

Posted 09 March 2019 - 01:18 PM

for the record, after several iterations with the QHY guys they provided me with a new version of qhyccd.dll that has solved the MIN=0 "black line" issue

 

I guess they will update the .dll in the new drivers, but for now I have uploaded it here

 

it must be copied and replaced in C:\Program Files (x86)\Common Files\ASCOM\Camera

 

dll.jpg


Edited by niccoc1603, 09 March 2019 - 01:20 PM.



CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.


Recent Topics






Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics