Jump to content

  •  

CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.

Photo

Trouble Connecting Nikon to Astroberry Server

  • Please log in to reply
7 replies to this topic

#1 AstronoDon

AstronoDon

    Vostok 1

  • *****
  • topic starter
  • Posts: 103
  • Joined: 07 Jan 2019
  • Loc: Connecticut, US

Posted 19 June 2019 - 06:21 PM

Tried asking about this on the Indi forums but got no response so I'll try here...

I recently downloaded the astroberry server onto my Raspberry pi to try remote imaging. Everything seemed to work fine running kstars directly in the pi OS. Cameras and mount were working fine but kstars seemed to run very slow.

I set up the indi web manager on the pi so I could run kstars on my remote laptop and just use the Pi as a controller. My mount and guide cam still connect fine but now my Nikon d5300 will not work. I am told there is no camera to be found. Has anyone had this issue? I know the drivers and camera work as I could control it from the pi OS but not remote kstars.

#2 sbradley07

sbradley07

    Mariner 2

  • *****
  • Posts: 220
  • Joined: 06 Mar 2017
  • Loc: Connecticut

Posted 19 June 2019 - 11:46 PM

Running kstars/ekos on your Pi is gonna be slow.  Things like Astroberry and Stellarmate are really meant to use the Pi as the controller (server), with kstars/ekos running on a remote client. 

 

I am using Stellarmate OS, so all the same stuff as on Astroberry and connecting my D5300 just fine.  Assuming your camera is connected to the Pi, the Ekos equipment profile on your laptop should indicate "remote" and include the ip address or hostname of the Pi.  But I'm gonna guess you have it configured right, because you say your other equipment connects.

 

Do you have all equipment plugged directly into the Pi?  If so, it may be a power issue.  I think most people using this type of set up use an external, powered usb hub for the imaging gear.  



#3 AstronoDon

AstronoDon

    Vostok 1

  • *****
  • topic starter
  • Posts: 103
  • Joined: 07 Jan 2019
  • Loc: Connecticut, US

Posted 20 June 2019 - 05:59 AM

Running kstars/ekos on your Pi is gonna be slow. Things like Astroberry and Stellarmate are really meant to use the Pi as the controller (server), with kstars/ekos running on a remote client.

I am using Stellarmate OS, so all the same stuff as on Astroberry and connecting my D5300 just fine. Assuming your camera is connected to the Pi, the Ekos equipment profile on your laptop should indicate "remote" and include the ip address or hostname of the Pi. But I'm gonna guess you have it configured right, because you say your other equipment connects.

Do you have all equipment plugged directly into the Pi? If so, it may be a power issue. I think most people using this type of set up use an external, powered usb hub for the imaging gear.



Everything is plugged into the pi. I've tried using the camera alone and still have the problem. The camera is running off its own battery also so I can't imagine it's a power issue. Also, when running kstars native on the pi, everything worked fine so I think that shows the power is fine.

#4 sbradley07

sbradley07

    Mariner 2

  • *****
  • Posts: 220
  • Joined: 06 Mar 2017
  • Loc: Connecticut

Posted 20 June 2019 - 10:45 AM

Are you getting the "No camera detected" pop up window, or do you see the camera tab in the INDI Control Panel after starting up?  I've had issues with usb port assignments in ekos, but that was on earlier versions.  Anything in the logs with verbose enabled?  Also double check the camera is detected (type lsusb in Terminal) on the Pi when testing from your laptop.  



#5 AstronoDon

AstronoDon

    Vostok 1

  • *****
  • topic starter
  • Posts: 103
  • Joined: 07 Jan 2019
  • Loc: Connecticut, US

Posted 20 June 2019 - 09:00 PM

Are you getting the "No camera detected" pop up window, or do you see the camera tab in the INDI Control Panel after starting up? I've had issues with usb port assignments in ekos, but that was on earlier versions. Anything in the logs with verbose enabled? Also double check the camera is detected (type lsusb in Terminal) on the Pi when testing from your laptop.


I am getting the pop up about no camera and I see nothing mentioning nikon or a camera in the USB list.

#6 sbradley07

sbradley07

    Mariner 2

  • *****
  • Posts: 220
  • Joined: 06 Mar 2017
  • Loc: Connecticut

Posted 20 June 2019 - 09:18 PM

Then the pi isn't recognizing the camera.  This is what I see:

 

Screen Shot 2019-06-20 at 10.08.54 PM.png

 

You said it worked when running ekos on the pi, but didn't work when connecting from a remote client.  For it to have worked the first way, the pi must have detected the camera.  The only other thing I can think of is a faulty camera usb cable creating intermittent connection issues.



#7 AstronoDon

AstronoDon

    Vostok 1

  • *****
  • topic starter
  • Posts: 103
  • Joined: 07 Jan 2019
  • Loc: Connecticut, US

Posted 22 June 2019 - 11:02 PM

Then the pi isn't recognizing the camera. This is what I see:

Screen Shot 2019-06-20 at 10.08.54 PM.png

You said it worked when running ekos on the pi, but didn't work when connecting from a remote client. For it to have worked the first way, the pi must have detected the camera. The only other thing I can think of is a faulty camera usb cable creating intermittent connection issues.


Thanks for the suggestions. I had also suspected the cable was faulty so I ordered another a couple days ago. I realized when I went to go back to using APT with windows and that no longer worked either so I assumed it must be the cable.

Just got the new one in the mail and everything is back to working. Very strange it happened to become faulty as I made the switch to remote control of the camera but just a coincidence I suppose.

#8 sbradley07

sbradley07

    Mariner 2

  • *****
  • Posts: 220
  • Joined: 06 Mar 2017
  • Loc: Connecticut

Posted 23 June 2019 - 12:19 AM

Glad you got it worked out.  USB cable gremlins have bitten me before.  Now I carry a spare one for my camera.  




CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.


Recent Topics






Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics