Jump to content

  •  

CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.

Photo

Problems with a Meade LXD75 Mount

  • Please log in to reply
8 replies to this topic

#1 Skywise1965

Skywise1965

    Lift Off

  • -----
  • topic starter
  • Posts: 3
  • Joined: 12 Feb 2019

Posted 21 August 2019 - 10:04 PM

I have a Meade LXD75 Mount that I purchased from one of our fellow members of Cloudy Nights.

It seemed to work OK the first time I used it, but the second time it would dissolve to gibberish on the hand controlled soon after starting up.

I would then only show the red background light on the hand controlled the next several times I tried to restart the mount.

Then it would work for a short time before exhibiting the same problem.

 

From what I read, it seemed the hand controller or the cord were the likely culprits, so I replaced both.

This seemed to work the next two or three times I took it out.

 

Then it went back to being gibberish a minute or so after starting up the mount.

The last time I took it out, I never got the hand controller to show more than jut a red light - no lettering at all.

 

I'm guessing the issue is in the mount itself, but can't seem to find anything that talks about whether there is any firmware in there to update.

Any thoughts?



#2 sg6

sg6

    Fly Me to the Moon

  • *****
  • Posts: 5689
  • Joined: 14 Feb 2010
  • Loc: Norfolk, UK.

Posted 22 August 2019 - 12:56 AM

Could be newer firmware, you need to identify the version you have and then head off to Meade.com and see what they give as the lastest available.

 

The next question is does it address the problem, which I half suspect it may not. Your problem sounds more like connections and/or power.

 

Concerning connections can you see the socket pins? Just wondering if one is pushed back and so missing contact. A new cable may not rectify that.

 

Next is power, what are you using.

 

I suppose the worst case is you have a dry joint on one of the boards, and occasionally the joint fails. "Worst case" as they are generally difficult to identify. Would, I expect, need the boards out and examined.


  • Skywise1965 likes this

#3 ThatsMyCoffee

ThatsMyCoffee

    Ranger 4

  • -----
  • Posts: 375
  • Joined: 15 Dec 2017
  • Loc: Czech Republic

Posted 22 August 2019 - 11:05 AM

If the hand controller isn't functioning properly, DON'T try to change the firmware.  You'll just end up doing more damage.  

 

I'd focus my search on power issues.  


  • Skywise1965 likes this

#4 lphilpot

lphilpot

    Apollo

  • *****
  • Posts: 1259
  • Joined: 15 Oct 2005
  • Loc: Central Lousiana, USA

Posted 22 August 2019 - 09:04 PM

Agreed on power issues being a question mark. When I bought my LXD75 a few years ago, I ran into problems using the battery pack that came with it. With brand new batteries it was OK for a while, but any slewing (which really is the point of a goto mount) ran the batteries down to a point where strange things started happening, even despite the measured voltage being normal.

 

I found a power supply on Amazon which worked out a lot better. The link is dead now, but the description is "T-Power ™ Ac Dc adapter for Meade Universal Telescope LXD75 Reflector N-6 AT LXD75 SN-6 AT SN-8 AT SN-10 AT SC-8 AT AR-5 AT AR-6 AT LX50 LXD55 LX10" (if that helps you search).


  • Skywise1965 likes this

#5 Skywise1965

Skywise1965

    Lift Off

  • -----
  • topic starter
  • Posts: 3
  • Joined: 12 Feb 2019

Posted 24 August 2019 - 08:25 PM

sg6 - when you say firmware, are you speaking about the hand controller, or is there something that can be updated on the mount itself?

 

ThatsMyCoffee - this issue has happened with two separate sets of hand controllers and cables.  I'm pretty sure it's not a hand controller issue.

 

lphilpot - thanks for the link to an AC power source.  I had changed out batteries to see if that might be an issue, but it does seem possible that the battery pack itself may be the culprit.  It is another common denominator during all of these issues.  I'll see if I can find the AC unit so I can eliminate that as a possibility.

 

Thanks to all three of you for your input.  I'll let you know how I make out.  I started this thread feeling that the mount itself had some internal issue.  At least now I have a couple of other directions to go.



#6 lphilpot

lphilpot

    Apollo

  • *****
  • Posts: 1259
  • Joined: 15 Oct 2005
  • Loc: Central Lousiana, USA

Posted 24 August 2019 - 08:40 PM

Aside from the motors and whatever control circuits they contain, there is (AFAIK) no firmware in the mount - It's all in the handbox. If you need to patch the handbox I recommend using StarPatch instead of the Meade software: https://www.stargps.ca/starpatch.htm

 

Other tips:

  • Read everything you can find here: http://www.weasner.com/lxd/index.html
  • Join the LXD55 Yahoo group - Lots of good info there, as well as stuff from Andrew Johansen and Dick Seymour (two experts on this mount family). Andrew wrote a nifty Windows program (which I can't recall the name of right now) that will talk to the mount and let you see / tweak / erase stuff. Handy.
  • Make sure your mount is clean, lubed and doesn't bind. The motors don't have a ton of torque and will stall under strain.

I "Ultratuned" mine... I intended it to be a hypertune, but I discovered the polar scope was glued into the RA axis with (apparently) cyanoacrylate and would've required heat to remove, so I just cleaned up the Dec axis (which was far worse, anyway). I bought a DVD (maybe from EFT / Ed here on CN?) that had details on how to do it.



#7 OzAndrewJ

OzAndrewJ

    Mercury-Atlas

  • *****
  • Posts: 2807
  • Joined: 30 Nov 2010

Posted 24 August 2019 - 09:20 PM

Gday Skywise

If the problem is "screen related", then it can only be in the handbox itself as the main CPU is directly connected to the LCD inside the box.

The fact 2 different handboxes show the effect means it is more likely power related, but i havent heard of screen "gibberish" occurring.

There is actually firmware inside the mount, but it is dedicated to running the motors only, it has no effect on the handbox.

Basically, power comes into the mount, and the 12V goes up the coiled cable to the handbox.

All other cabling from the handbox is for TTL level data transfers, and is simply directed to the rlevant cards/connectors.

 

You mention batteries, and if they are low, it may be causing the Hbx to brown out if the motors are drawing too much

so you need to try a different power supply, and also ( if possible ) get something that allows you to measure the current draw ( or measure the battery voltage when under load to see what it drops to.

If batt voltage drops when loaded and current is high, it might be a dying battery

but if it also gets high current with a wall power supply, it might be due to a failing motor or binding

 

Andrew Johansen Melbourne Australia



#8 jgraham

jgraham

    ISS

  • *****
  • Posts: 20179
  • Joined: 02 Dec 2004
  • Loc: Miami Valley Astronomical Society

Posted 24 August 2019 - 09:45 PM

Make sure that the connectors are clean and straight. I had some problems with the first of two LXD75s ans the problem was a munged handbox connector. I straightened the guides and carefully plugged it back in and it cleared up. The mount also likes a beefy power supply. I use a jumpstart battery with mine.



#9 Skywise1965

Skywise1965

    Lift Off

  • -----
  • topic starter
  • Posts: 3
  • Joined: 12 Feb 2019

Posted 25 August 2019 - 08:48 AM

Again - many thanks for all the replies.

lphilpot - thank you for the information on the mount.  That crosses that off the list and puts me squarely back at power issues.

 

I have ordered the AC power adapter recommended earlier.

Will let you all know how I make out.

 

Thank you all!




CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.


Recent Topics






Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics