Jump to content

  •  

CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.

Photo

Trouble connecting EQ6-R Pro to EQMOD/ASCOM

  • Please log in to reply
10 replies to this topic

#1 raguramm

raguramm

    Sputnik

  • *****
  • topic starter
  • Posts: 42
  • Joined: 15 Jan 2019

Posted 19 September 2019 - 01:22 AM

I have the new version of the EQ6-R pro with the USB type B port. I'm using a basic printer cable USB A to B to connect to my computer. Unfortunately, EQMOD isn't able to find the mount through the USB connection - see attached pictures. I think it's an issue with the COM port, but I'm not sure how to correct that. If anyone has input, I'd appreciate it!

 

Capture.JPG

 

Capture2.JPG



#2 PDB

PDB

    Explorer 1

  • -----
  • Posts: 76
  • Joined: 18 Nov 2016

Posted 19 September 2019 - 03:43 AM

Hi,

 

Seems there is no driver installed for the USB-Serial convertor (the USB socket from the mount). Is your computer connected to the internet when you connect the mount? Could be that W10 can't download and install the driver due to no connection to internet. Would expect to show that port as a Prolific driver and attach a com port to it. (Which will run at 115000 baud)

 

Paul



#3 *Axel*

*Axel*

    Mariner 2

  • -----
  • Posts: 213
  • Joined: 01 Mar 2016

Posted 19 September 2019 - 05:03 AM

You need an eqmod compatible USB plug+driverd. A standard USB cable will not work and can damage your mount.

#4 PDB

PDB

    Explorer 1

  • -----
  • Posts: 76
  • Joined: 18 Nov 2016

Posted 19 September 2019 - 05:22 AM

You need an eqmod compatible USB plug+driverd. A standard USB cable will not work and can damage your mount.

 

These are only needed for the model WITHOUT the USB connection. The USB connector should work as an USB/Serial adapter to go directly to the mount. Using it in that wat already for years with the AZ/EQ5 (for which the dealer sold me an EQDIR cable I did not needed ....)

 

P



#5 *Axel*

*Axel*

    Mariner 2

  • -----
  • Posts: 213
  • Joined: 01 Mar 2016

Posted 19 September 2019 - 05:27 AM

My bad I totally overlooked the mention to the USB type B port! Got an old mount

#6 jdupton

jdupton

    Surveyor 1

  • *****
  • Posts: 1950
  • Joined: 21 Nov 2010
  • Loc: Central Texas, USA

Posted 19 September 2019 - 07:33 AM

raguramm,

 

   I think you're looking in the wrong place in the Device Manager for the mount to show up.

 

   When you connect the USB cable and power up the mount, look under COM & LPT Ports in the device Manager. A new COM port should appear when you power on the mount. Note the Port number. Open the COM Port Properties dialog and select the Port Settings tab. Change the Speed from 9600 (which is probably the default that Windows selected) to 115,200 as Paul mentioned in Post #2 in this thread. Apply those changes.

 

   Now go into the EQMOD Set-Up Dialog and change the Port Number selection there to match the Port number you noted in the Windows Device Manager. Also change the speed to 115,200 to match the Windows properties. Close the EQMOD Set-up window and now try to start EQMOD. It should connect and work fine after those changes.

 

   If the Device Manger does not show a new COM Port when you connect the USB cable and power on the mount, you probably didn't get the low level device driver properly installed. Look for an "Unknown" device in the Device Manager (a device with a yellow triangle next to it) and open its properties. Click on Update Drivers to let Windows search again for the proper device driver to load. Then try the steps above again.

 

 

John


Edited by jdupton, 19 September 2019 - 09:31 AM.


#7 H-Alfa

H-Alfa

    Ranger 4

  • -----
  • Posts: 386
  • Joined: 21 Sep 2006
  • Loc: Spain

Posted 19 September 2019 - 09:22 AM

A little bit out of topic (or maybe not) but...

It is feasible to increase the baud rate (matching windows&eqmod)? I thought that has to be always 9600.
And would this increase allow better communication with the mount?

Enviado desde mi ANE-LX1 mediante Tapatalk

#8 PDB

PDB

    Explorer 1

  • -----
  • Posts: 76
  • Joined: 18 Nov 2016

Posted 19 September 2019 - 09:31 AM

Depends on the setting/connection of the usb/serial or serial port. For the port with EQDIR it is 9600 baud. For Skywatcher Mounts with a true USB connector baud rate needs to be set at 115000.

 

P/



#9 jdupton

jdupton

    Surveyor 1

  • *****
  • Posts: 1950
  • Joined: 21 Nov 2010
  • Loc: Central Texas, USA

Posted 19 September 2019 - 09:31 AM

Alberto,

 

   In a general case, yes but not for the SkyWatcher mounts.

 

   The problem is that we do not have access to configure the communications speed inside the mount / Handset. The electronics inside the SynScan system set the port communications speed with the internal firmware. If we change the speed of the Port in Windows, the mount could no longer follow along as it always expects the speed it was configured for in firmware.

 

   We are forced to use the speed that the mount expects. SkyWatcher appears to be going to faster serial speeds as they change over to having the USB-to-RS232 converter inside the mounts / Handsets. All older mounts are using 9600 while the newer mounts that incorporate the USB to Serial conversion into the mount expect 115,200. All we can do at this point is match what they expect to see coming from the PC side.

 

 

John


Edited by jdupton, 19 September 2019 - 09:32 AM.


#10 H-Alfa

H-Alfa

    Ranger 4

  • -----
  • Posts: 386
  • Joined: 21 Sep 2006
  • Loc: Spain

Posted 19 September 2019 - 09:56 AM

Ok, understood. It was a question "just in case..."
Thank you for the quick replies! ;)

Enviado desde mi ANE-LX1 mediante Tapatalk

#11 raguramm

raguramm

    Sputnik

  • *****
  • topic starter
  • Posts: 42
  • Joined: 15 Jan 2019

Posted 19 September 2019 - 11:15 AM

Thanks everyone for your help! My windows update itself is broken, it isn't letting me check for updates. I'm trying to solve that problem now. 




CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.


Recent Topics






Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics