Jump to content

  •  

CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.

Photo

Starizona microtouch wired focuser issue

astrophotography imaging planetarium software
  • Please log in to reply
3 replies to this topic

#1 imtl

imtl

    Lift Off

  • *****
  • topic starter
  • Posts: 7
  • Joined: 07 Jun 2016

Posted 19 September 2019 - 11:17 PM

Hi all,

 

I posted this in "Equipment"  but I figured I should post it here as well in hope for some help. Anyways, I have a Starizona microtouch wired focuser. I installed everything and things work very nice

with the controller software. However, when I try to control it with either APT or BYE it does something weird.

With APT or BYE and even SGP, it does not matter if I push the IN or OUT travel button it always goes IN. And I don't understand why.

 

Just to be more clear. The position counter says 30000 on all software, I push the IN or OUT buttons on APT/BYE/SGP and it always goes in one direction, which is DOWN, i.e. lower count. But when I do it with the microtouch controller software it works fine.

 

I tried hard to find posts with similar problems but no luck. Anyone has an idea? I'm quite sure it is some definition that I am missing here.

 

Thanks!



#2 dmdouglass

dmdouglass

    Surveyor 1

  • *****
  • Posts: 1724
  • Joined: 23 Dec 2007
  • Loc: Tempe, AZ

Posted 19 September 2019 - 11:50 PM

You might give Starizona a call and ask them.

I do believe they are familiar with the software referenced.

AND... they are always VERY helpful.

 

I use that setup with TheSkyX, with TheSkyX controlling and it works just fine.


  • Jim Waters likes this

#3 imtl

imtl

    Lift Off

  • *****
  • topic starter
  • Posts: 7
  • Joined: 07 Jun 2016

Posted 19 September 2019 - 11:58 PM

Thank you. Okay I started finding out some stuff.

 

I have the microtouch controller box and there is an option of Motor Reverse.

When I go ON/OFF with that then all the softwares I mentioned and also including focus max move in the opposite direction along with ON/OFF.

 

BUT! If for example, I'm on ON, it does not matter if I go inward or outward in the softwares. It will go the same direction on the motor itself. The only way for me to revert the direction is to manually press the MOTOR REV on the hand controller. 

I am confused here.

 

Another annoying thing is that when I do go to position in all the softwares it just keeps going no matter if it reached the position already.



#4 imtl

imtl

    Lift Off

  • *****
  • topic starter
  • Posts: 7
  • Joined: 07 Jun 2016

Posted 20 September 2019 - 12:27 AM

Okay. I seems that my problem is fixed. The issue was that in the microtouch controller software itself (which I guess the defines the parameters for the ASCOM driver as well) I needed to change the min value and max value to fit the range of my motor. The default after installation is 0-10 but the real thing is 0-60000. So, when I was trying to move the motor with any of my softwares it kept on reading that it is above the maximum value allowed and moved in one direction all the time to try and compensate for it.

 

Everything seems to be working now. At least in matters of moving the motor. 

Thanks!




CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.


Recent Topics





Also tagged with one or more of these keywords: astrophotography, imaging, planetarium software



Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics