Jump to content

  •  

CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.

Photo

SOLVED- SGP Crashing. (Make sure you update .net if trying latest betas)

  • Please log in to reply
15 replies to this topic

#1 ChrisWhite

ChrisWhite

    Fly Me to the Moon

  • *****
  • topic starter
  • Posts: 5,027
  • Joined: 28 Feb 2015
  • Loc: Colchester, VT

Posted 16 November 2019 - 06:30 PM

Trying to run SGP, and the program crashes after slewing to the target but before completing any other sequence step. 

 

This is the screen of SGP death that I get:

 

SGP Crash.JPG

 

This is what I found in the Log:

 

"GlobalExceptionHandler caught: Could not load file or assembly 'netstandard, Version=2.0.0.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51' or one of its dependencies. The system cannot find the file specified."

 

Not sure what it means or how to fix it....

 

Entire log-file attached. 

 

Attached File  sg_logfile_20191116181349.txt   70.2KB   2 downloads


Edited by ChrisWhite, 16 November 2019 - 06:53 PM.


#2 ChrisWhite

ChrisWhite

    Fly Me to the Moon

  • *****
  • topic starter
  • Posts: 5,027
  • Joined: 28 Feb 2015
  • Loc: Colchester, VT

Posted 16 November 2019 - 06:37 PM

Going to try to update .net to 4.8... will report back.



#3 ChrisWhite

ChrisWhite

    Fly Me to the Moon

  • *****
  • topic starter
  • Posts: 5,027
  • Joined: 28 Feb 2015
  • Loc: Colchester, VT

Posted 16 November 2019 - 06:53 PM

Well, updating to .net 4.8 solved the problem. 

 

Mods can either delete or lock thread... might be useful though for people trying out the new SGP Betas....


  • Jim Waters, PeteM, Jon Rista and 1 other like this

#4 Peter in Reno

Peter in Reno

    Voyager 1

  • *****
  • Posts: 10,631
  • Joined: 15 Jul 2008
  • Loc: Reno, NV

Posted 16 November 2019 - 07:43 PM

This is not just for you but for others to see:

 

https://forum.mainse...t-problem/10931

 

Peter


  • ChrisWhite likes this

#5 PeteM

PeteM

    Vanguard

  • -----
  • Posts: 2,338
  • Joined: 12 Jul 2009
  • Loc: West Michigan

Posted 16 November 2019 - 10:08 PM

Yeah I was crashing on the .NET issue last night with the .366 beta, but with autofocusing. Been running like a champ for the last 2 hours tonight after updating .NET to 4.8 this morning.



#6 Salacious B Crumb

Salacious B Crumb

    Viking 1

  • *****
  • Posts: 762
  • Joined: 13 Apr 2017
  • Loc: Greater Atlanta Area, GA

Posted 16 November 2019 - 10:25 PM

And currently the framing mosaic wizard is not working, something about the server where the databases are being down. Ken is trying to fix this.

 

In case someone else is wondering...

 

 

- Mikko



#7 ChrisWhite

ChrisWhite

    Fly Me to the Moon

  • *****
  • topic starter
  • Posts: 5,027
  • Joined: 28 Feb 2015
  • Loc: Colchester, VT

Posted 17 November 2019 - 08:08 AM

I think I have identified a couple of other bugs.  I posted on SGP forum with logs. 

 

1) When inputting an end time for my sequence of 6am the next day, the current frame finished and the program immediately ran through shutdown and parked the mount, warmed up camera, etc...

 

2) After my target was obscured by trees SGP attempted to recover.  Once the recover time ran out, the program just stopped doing anything and allowed the mount to continue to track.  It should have parked everything, so glad I woke up early and checked before a pier crash.



#8 Salacious B Crumb

Salacious B Crumb

    Viking 1

  • *****
  • Posts: 762
  • Joined: 13 Apr 2017
  • Loc: Greater Atlanta Area, GA

Posted 17 November 2019 - 09:08 AM

I think I have identified a couple of other bugs.  I posted on SGP forum with logs. 

 

1) When inputting an end time for my sequence of 6am the next day, the current frame finished and the program immediately ran through shutdown and parked the mount, warmed up camera, etc...

 

2) After my target was obscured by trees SGP attempted to recover.  Once the recover time ran out, the program just stopped doing anything and allowed the mount to continue to track.  It should have parked everything, so glad I woke up early and checked before a pier crash.

 

#1 first happens to me too so I want back to the earlier version. After Ken stated yesterday that he'll only do the FMW update to the 3.1 version, I went back to it. Now that won't work either. 

 

 

- Mikko


Edited by Salacious B Crumb, 17 November 2019 - 09:09 AM.

  • ChrisWhite likes this

#9 ChrisWhite

ChrisWhite

    Fly Me to the Moon

  • *****
  • topic starter
  • Posts: 5,027
  • Joined: 28 Feb 2015
  • Loc: Colchester, VT

Posted 17 November 2019 - 11:31 AM

#1 first happens to me too so I want back to the earlier version. After Ken stated yesterday that he'll only do the FMW update to the 3.1 version, I went back to it. Now that won't work either. 

 

 

- Mikko

 

Hmm, I wonder if when rolling back versions there is some residual code from the latest beta that is left behind. I found this when I initially identified the .net being an issue for the .366 beta.  I rolled back to a previous version and that too crashed when before it did not.


  • gunny01 likes this

#10 gunny01

gunny01

    Surveyor 1

  • *****
  • Posts: 1,969
  • Joined: 02 Jun 2014

Posted 17 November 2019 - 11:54 AM

Hmm, I wonder if when rolling back versions there is some residual code from the latest beta that is left behind. I found this when I initially identified the .net being an issue for the .366 beta.  I rolled back to a previous version and that too crashed when before it did not.

 Had the same problem when I tried one of the betas a month or so back.  Wish I had never done that.  Now I have to connect only to the mount first, slew to the object, then connect the rest of the equipment.  I don't get the error message that you are showing though.  Uninstalling the beta and reloading an older version did not stop the problem.  Camera, focuser, dew heaters, atmospherics would all disconnect upon a slew at the beginning of the evening for imaging.  Funny that it will slew on meridian flip with no problems so far. 

 

  The betas seem to really mess things up starting with trying to improve the focusing.  Waiting to see the beta version...............3.......00...100.  They got a real mess on their hands now.


  • ChrisWhite likes this

#11 ChrisWhite

ChrisWhite

    Fly Me to the Moon

  • *****
  • topic starter
  • Posts: 5,027
  • Joined: 28 Feb 2015
  • Loc: Colchester, VT

Posted 17 November 2019 - 11:59 AM

 Had the same problem when I tried one of the betas a month or so back.  Wish I had never done that.  Now I have to connect only to the mount first, slew to the object, then connect the rest of the equipment.  I don't get the error message that you are showing though.  Uninstalling the beta and reloading an older version did not stop the problem.  Camera, focuser, dew heaters, atmospherics would all disconnect upon a slew at the beginning of the evening for imaging.  Funny that it will slew on meridian flip with no problems so far. 

 

  The betas seem to really mess things up starting with trying to improve the focusing.  Waiting to see the beta version...............3.......00...100.  They got a real mess on their hands now.

 

The AF is fantastic though, so hopefully these other bugs get fixed quickly.  I wonder if all the GUI changes are the culprit.  Seems that Ken and Jared are motivated to develop the program currently, which is nice after a year or more of not much happening. 


  • Salacious B Crumb likes this

#12 gunny01

gunny01

    Surveyor 1

  • *****
  • Posts: 1,969
  • Joined: 02 Jun 2014

Posted 17 November 2019 - 12:21 PM

  I think that Voyager is kinda playing a role in the motivation.  Competition is usually a good thing for the consumer.


  • rockstarbill and ChrisWhite like this

#13 AgilityGuy

AgilityGuy

    Viking 1

  • -----
  • Posts: 551
  • Joined: 20 Jun 2015
  • Loc: Northern CA

Posted 17 November 2019 - 12:34 PM

Chris - I can't post on experience about SGP but since you have a Mach1, if you aren't using A-Ps APCC you may look into getting a copy of the software.  If all the wheels come off the wagon in the middle of the night due to any of the pieces of software you're using, setting the horizon limits in APCC will make sure you don't wake up to an expensive accident in the morning.   


  • ChrisWhite likes this

#14 Dan Crowson

Dan Crowson

    Vanguard

  • *****
  • Moderators
  • Posts: 2,342
  • Joined: 08 Oct 2010
  • Loc: Dardenne Prairie, MO

Posted 17 November 2019 - 12:53 PM

And currently the framing mosaic wizard is not working, something about the server where the databases are being down. Ken is trying to fix this.

 

I'd just mention that this one is impacting other programs. The server appears to be throwing an out of space error.

Dan


  • ChrisWhite likes this

#15 ChrisWhite

ChrisWhite

    Fly Me to the Moon

  • *****
  • topic starter
  • Posts: 5,027
  • Joined: 28 Feb 2015
  • Loc: Colchester, VT

Posted 17 November 2019 - 12:59 PM

Chris - I can't post on experience about SGP but since you have a Mach1, if you aren't using A-Ps APCC you may look into getting a copy of the software.  If all the wheels come off the wagon in the middle of the night due to any of the pieces of software you're using, setting the horizon limits in APCC will make sure you don't wake up to an expensive accident in the morning.   

 

Hi Joe.  I'm running SGP on my CEM60.  I believe that with that I can set limits in the driver... I just haven't done so yet due to (insert lame excuse here). 

 

I run Voyager on my Mach 1 rig, and I WILL be testing out APCC on that in the near future.  I just have not yet due to... clouds.  I want to have a forecasted clear streak before I start the trial. 



#16 ChrisWhite

ChrisWhite

    Fly Me to the Moon

  • *****
  • topic starter
  • Posts: 5,027
  • Joined: 28 Feb 2015
  • Loc: Colchester, VT

Posted 17 November 2019 - 09:19 PM

Beta .371 is now available.  Fixed a couple of the issues discussed in this thread and sounds like progress on a couple of others. 

 

http://mainsequences...re.com/Releases

 

Kudos to Ken for being responsive. 


Edited by ChrisWhite, 17 November 2019 - 09:19 PM.



CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.


Recent Topics






Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics