Jump to content

  •  

CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.

Photo

CPWI and Auto Guiding W/ASCOM on Celestron AVX

astrophotography Celestron imaging
  • Please log in to reply
9 replies to this topic

#1 Dustyhills

Dustyhills

    Explorer 1

  • *****
  • topic starter
  • Posts: 71
  • Joined: 12 Jun 2014
  • Loc: Apple Valley, Utah

Posted 26 January 2020 - 11:33 PM

I got CPWI working with it connected through the HC and a serial cable on my Celestron AVX mount. I would like to use PHD or DUSK to auto guide using ASCOM but would also need to connect it through the HC. Am I stuck with using ST4 or can I still make it work with ASCOM somehow?

 

Thank you for your help

Tim

 



#2 freestar8n

freestar8n

    Vendor - MetaGuide

  • *****
  • Vendors
  • Posts: 9,335
  • Joined: 12 Oct 2007

Posted 26 January 2020 - 11:41 PM

I use CPWI with CGX-L and guiding is easy because CPWI comes with its own ASCOM driver - and it can connect to multiple devices.

 

When you connect to the mount via ASCOM, look for an ascom interface called CPWI.  It is different from the normal celestron ascom driver.

 

It should all work - and no need for st4.

 

And note that there was a recent beta release of CPWI on TeamCelestron with many improvements.  I recommend using it.

 

Frank



#3 Cfreerksen

Cfreerksen

    Apollo

  • *****
  • Posts: 1,003
  • Joined: 18 Aug 2018
  • Loc: Tooele, Ut

Posted 26 January 2020 - 11:56 PM

CPWI will communicate with several programs at the same time. Just select CPWI when you need any program to connect to the mount. Like PHD2. Make sure you start CPWI first to enable the driver.

 

Chris



#4 MikiSJ

MikiSJ

    Messenger

  • -----
  • Posts: 416
  • Joined: 20 Nov 2018
  • Loc: San Jose

Posted 27 January 2020 - 12:06 AM

And note that there was a recent beta release of CPWI on TeamCelestron with many improvements.  I recommend using it.

 

Frank

As with many beta release there are many issues being reported. I would wait for the 2.3.3 final release.



#5 Cfreerksen

Cfreerksen

    Apollo

  • *****
  • Posts: 1,003
  • Joined: 18 Aug 2018
  • Loc: Tooele, Ut

Posted 27 January 2020 - 12:11 AM

As with many beta release there are many issues being reported. I would wait for the 2.3.3 final release.

Been using 2.3.3 beta1 for some time. I have run into no issues. Some have had some glitches but it has been solid for me.

 

Edit: I have been using 2.2.4 beta1. 2.3.3 Beta1 just came out 4 days ago. My bad. Looks like many UI changes.

 

Chris


Edited by Cfreerksen, 27 January 2020 - 12:18 AM.


#6 Dustyhills

Dustyhills

    Explorer 1

  • *****
  • topic starter
  • Posts: 71
  • Joined: 12 Jun 2014
  • Loc: Apple Valley, Utah

Posted 27 January 2020 - 12:42 AM

I guess I need to clarify that I don't understand connecting the cables. One for the CPWI to hand controller and then the same one works for PhD also or do I need a second cable

#7 freestar8n

freestar8n

    Vendor - MetaGuide

  • *****
  • Vendors
  • Posts: 9,335
  • Joined: 12 Oct 2007

Posted 27 January 2020 - 01:09 AM

I guess I need to clarify that I don't understand connecting the cables. One for the CPWI to hand controller and then the same one works for PhD also or do I need a second cable

You only need one cable to allow cpwi to control the mount and to autoguide.  The autoguide software will connect to the cpwi ascom driver and the guide commands will be sent down that cable.

 

Frank


  • Cfreerksen likes this

#8 Dustyhills

Dustyhills

    Explorer 1

  • *****
  • topic starter
  • Posts: 71
  • Joined: 12 Jun 2014
  • Loc: Apple Valley, Utah

Posted 29 January 2020 - 12:16 AM

Thank you for your help, I have it all working now.

 

Tim


  • Cfreerksen likes this

#9 Vaujean

Vaujean

    Lift Off

  • -----
  • Posts: 2
  • Joined: 16 Feb 2020

Posted 27 February 2020 - 11:37 AM

I read your exchanges carefully. But on my side I have a problem when I want to auto-guide with Maxim DL through CPWI via the ascom driver Celstron CPWI. Obviously moving the telescope in autoguiding does not happen, while in tracking or pointing it works very well. In the Maxim DL settings I therefore use the CPWI driver for the telescope settings (C14 on CGEPro) and for the "telescope" settings guide. When I want to calibrate the autoguiding the displacement of the telescope is not done or is erratic.
I am very interested in any help. I want to use CPWI for the performance of its scoring model.

Attached Thumbnails

  • settings calibrate autoguiding.png


#10 daglw

daglw

    Lift Off

  • -----
  • Posts: 2
  • Joined: 08 Jul 2017

Posted 27 March 2020 - 09:10 AM

Hi Vaujean,

 

Did you get this problem with Maxim DL and CPWI sorted as I have a similar problem?

 

David




CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.


Recent Topics





Also tagged with one or more of these keywords: astrophotography, Celestron, imaging



Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics