Jump to content

  •  

CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.

Photo

Vixen StarBook 10 and SkySafari 5 Pro - connection problems

  • Please log in to reply
5 replies to this topic

#1 Blueox4

Blueox4

    Viking 1

  • *****
  • topic starter
  • Posts: 631
  • Joined: 26 Nov 2015
  • Loc: Upstate New York

Posted 03 July 2020 - 02:50 PM

So I’ve got a small nano router connected to my Vixen StarBook 10, which I love by the way! This interfaces with a SXD2 mount. SB10 is updated to the latest firmware. My router assigns itself a 10.10.10.254 address and SB10 seems to assign itself a 169.254.0.1 address. I’ve read all the topics I can find on this and still can’t connect SkySafari 5 Pro to the Vixen SB10. Any ideas? Is there a way to assign SB10 a 10.10.10.XXX address? I believe that to be my issue and the 169 IP address that SB10 gives itself is not routable probably. Just not sure how to resolve. Thanks for any Insight! 



#2 StarGoBoom

StarGoBoom

    Lift Off

  • -----
  • Posts: 20
  • Joined: 31 May 2020

Posted 03 July 2020 - 04:04 PM

Are you loading the Vixen ASCOM driver for Starbook Ten on your PC?  User cuivienor on this BBS has a later beta version than the one provided on the Vixen download pages.  Don't know if SkySafari can access the StarBook Ten directly without the ASCOM driver. 


  • Blueox4 likes this

#3 Blueox4

Blueox4

    Viking 1

  • *****
  • topic starter
  • Posts: 631
  • Joined: 26 Nov 2015
  • Loc: Upstate New York

Posted 03 July 2020 - 04:29 PM

I’m connecting to my Nano router with my ipad by typing the IP address if 10.10.10.254 from Safari browser. I reach the router configuration pages. The Starbook 10 is connected to the Nano router with a strait thru CAT5 cable. The IP address of Starbook 10 shows as 169.254.0.1 on Starbook itself. The router does not see SB.

Attached Thumbnails

  • 3D4BD0CF-157B-49FB-A01C-34A888D757B5.jpeg
  • B0DB6831-B3B2-4F29-940E-95AE42A5D30D.jpeg

Edited by Blueox4, 03 July 2020 - 04:32 PM.


#4 StarGoBoom

StarGoBoom

    Lift Off

  • -----
  • Posts: 20
  • Joined: 31 May 2020

Posted 03 July 2020 - 05:00 PM

Most small Nano routers are expecting a WAN ethernet cable not a Lan cable (if it's one of those that just has one ethernet socket).  I believe most of these routers can be easily configured to use that one WAN socket as a Lan socket...  These small Nano travel routers are setup to be used in Hotels and such...  The one I use has 3 ethernet sockets, 2 Lan and 1 WAN -- the WAN ethernet socket can be reconfigured as a Lan socket through the configuration menus.  You might check the Web page docs on your router to see how to configure the WAN to Lan on your router.


  • Blueox4 likes this

#5 brisdob

brisdob

    Ranger 4

  • -----
  • Posts: 375
  • Joined: 04 Aug 2014
  • Loc: Brisbane, Australia

Posted 03 July 2020 - 05:18 PM

Here is how I did it years ago - copied from a post I made on another forum.

 

I bought a little travel router with a built in battery. The one I got is the TPLink MR3040, but I am sure there are others that would work equally well. Go through the instructions to install and configure the router. I left the DCHP range as the defaults, type set as wisp (whatever that means!). Charge battery in router. Connect LAN port on router to LAN port of Starbook Ten. You need to use a straight through cable for this - not a crossover cable. Turn on router. Turn on Starbook Ten and do alignment as normal. Go to System menu on Starbook Ten and note the IP address, mine is something in the range 192.168.0.100 to 192.168.0.199, which is the default address range for the router. Next, open up the WiFi settings on your laptop, iPad etc, The TPLink network should be clearly visible, join the network (note password is on the back of the router if you need it.) Open SkySafari, go to Telescope>Setup. Scope Type - seems to work as either Vixen Starbook or Vixen Sphinx. Connection Type is WiFi / Ethernet. Set auto detect SkyFi to off i.e. uncheck box. Set IP address to the same as the Starbook Ten is showing. Port 80. Readout rate does not seem critical, I left mine at 10 per second. Press Connect and with any luck......Just note that you need to exit the system menu on Starbook Ten before SkySafari will control the telescope. Well, it worked for me, but obviously it's your equipment and you connect things to it at your own risk!

 

Edit to add a link to the thread.

 

http://www.iceinspac...ht=Starbook Ten

 

This one may also be useful - although when I did it it worked first time with no issues.

 

http://www.iceinspac...ht=Starbook Ten


Edited by brisdob, 03 July 2020 - 05:27 PM.


#6 StarGoBoom

StarGoBoom

    Lift Off

  • -----
  • Posts: 20
  • Joined: 31 May 2020

Posted 03 July 2020 - 05:33 PM

??? "!"  So, if everything is the same as it was before, perhaps the issue is on the iPad side?  I just use PCs, but one connection problem I recently had was that my Antivirus firewall started "automatically" blocking ports and addresses after it updated itself (of course, without any prior notifications to the user)...  I had to either "turn off" that section of the firewall or manually add-in addresses and applications in a permissions list.  That was such a pain that I just disable the entire firewall when I'm connecting to my A2D and DAC devices. 

 

A good test would be to see if you can connect to the StarBook using a crossover cable.  If that works, then you can rule-out any problems with the StarBook Ten ethernet port and focus on why 169.254.0.1 isn't being passed through the router/iPad network layers. 




CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.


Recent Topics






Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics