Jump to content

  •  

CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.

Photo

Issues with Televue Telepod

  • Please log in to reply
1 reply to this topic

#1 bartine

bartine

    Vanguard

  • *****
  • topic starter
  • Posts: 2,021
  • Joined: 03 Oct 2007
  • Loc: Silver Spring, MD

Posted 09 July 2020 - 08:35 AM

I recently picked up a used Televue Telepod mount.

 

I Believe the mount head is supposed to rotate in azimuth.  It appears to be totally locked up.  I removed the azimuth tensioning screw and the mount head will not rotate.

 

The only way to get the mount to rotate is to loosen the mount head on the tripod shaft, or to have it slightly loosened (unscrewed).

 

First - Am I correct - that the lower hand screw in this picture is supposed to control tension for rotation in azimuth?

 

Or - does this just rotate around the tripod shaft - and you loosen that to allow it to rotate?

Attached Thumbnails

  • 0709200926a.jpg


#2 bartine

bartine

    Vanguard

  • *****
  • topic starter
  • Posts: 2,021
  • Joined: 03 Oct 2007
  • Loc: Silver Spring, MD

Posted 09 July 2020 - 08:38 AM

I took the mount apart - it was really locked up.

 

Here are two pictures of the parts dissasembled.

 

Is anything missing? is there supposed to be some type of anti friction pad, felt, or teflon between the scope bracket and the rest of the mount so that even when tight, it can rotate?

 

Note:  The white ring on the scope holder seems to almost be painted on - there really isn't anything there other than a different color.

Attached Thumbnails

  • 0709200925.jpg
  • 0709200926.jpg



CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.


Recent Topics






Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics