Jump to content

  •  

CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.

Photo

Pixinsight wont recognize my flats!

  • Please log in to reply
7 replies to this topic

#1 skycamper

skycamper

    Surveyor 1

  • *****
  • topic starter
  • Posts: 1,987
  • Joined: 20 Oct 2007
  • Loc: Beaverton OR

Posted 12 July 2020 - 08:27 PM

I think my flats were derived from APT maybe and lights from SGP, does this matter?  Im not even sure. But this is the message I get.   Does the nomenclature matter to Pixinsight as far as the name format of the files?  I also tried clicking the "use master flat"  check box and putting in a master flat stcked by DSS and it gives me the same error message.  If I click run it will calibrate with darks but not flats.  I also use flat darks and that box is checked.

Thanks! 

Attached Thumbnails

  • Screenshot (378).png
  • Screenshot (379).jpg


#2 pfile

pfile

    Fly Me to the Moon

  • -----
  • Posts: 5,607
  • Joined: 14 Jun 2009

Posted 12 July 2020 - 08:33 PM

its the filter=none thing. what you can do is use "add custom" to load the lights, making sure to enter all the right data, including the filter name (which needs to match the flats filter name exactly obviously).

 

having said this it is a bad idea to mix calibration frames from different capture programs or camera drivers, so you might have problems down the line after you get this sorted.

 

rob


  • skycamper and jdupton like this

#3 Michael Covington

Michael Covington

    Author

  • *****
  • Vendors
  • Posts: 6,680
  • Joined: 13 May 2014
  • Loc: Athens, Georgia, USA

Posted 12 July 2020 - 08:38 PM

Was "use master flat" checked?   Do you in fact have a master flat?


  • skycamper likes this

#4 skycamper

skycamper

    Surveyor 1

  • *****
  • topic starter
  • Posts: 1,987
  • Joined: 20 Oct 2007
  • Loc: Beaverton OR

Posted 12 July 2020 - 08:59 PM

Was "use master flat" checked?   Do you in fact have a master flat?

Hi Michael, Yes I tried it both ways checked, not checked, uploaded a master flat and checked the box. No go.     

 

Rob, I was afraid of that!  Ok I wont mix the capture programs, this data is older as I was making a transition to APT from SGP due to being able to dual dither with APT.  

 

Ok I can try and make sure I avoid this problem in the future.  Not sure why PI wont just trust me that these are actual flat files!



#5 FlankerOneTwo

FlankerOneTwo

    Viking 1

  • *****
  • Posts: 904
  • Joined: 30 Aug 2017
  • Loc: Vegas, baby!

Posted 12 July 2020 - 10:24 PM

 

Ok I can try and make sure I avoid this problem in the future.  Not sure why PI wont just trust me that these are actual flat files!

It's because your flat files state that they were taken with a different filter ("Lum") than your light frames ("None"). Flats have to match for filter as well as binning.


  • skycamper likes this

#6 skycamper

skycamper

    Surveyor 1

  • *****
  • topic starter
  • Posts: 1,987
  • Joined: 20 Oct 2007
  • Loc: Beaverton OR

Posted 12 July 2020 - 10:32 PM

It's because your flat files state that they were taken with a different filter ("Lum") than your light frames ("None"). Flats have to match for filter as well as binning.

Can I simply change the name of all the files to match more closely the 2nd night?   I stack multiple nights of data in this case 6 nights on M33.    I can just copy the format from night 2 and rename all the night 1 files to match and just change the frame numbers in the title?



#7 FlankerOneTwo

FlankerOneTwo

    Viking 1

  • *****
  • Posts: 904
  • Joined: 30 Aug 2017
  • Loc: Vegas, baby!

Posted 13 July 2020 - 01:33 AM

Can I simply change the name of all the files to match more closely the 2nd night?   I stack multiple nights of data in this case 6 nights on M33.    I can just copy the format from night 2 and rename all the night 1 files to match and just change the frame numbers in the title?

The filter name is typically written into the FITS header. As Rob mentioned above, the simplest thing to do is to load the flats into the script using the "Add Custom" button - this allows to override the filter name as well as other parameters, so just put "None" for the filter name and it should work fine. Or you could alternatively load your lights specifying "Lum" for the filter.


  • skycamper likes this

#8 pfile

pfile

    Fly Me to the Moon

  • -----
  • Posts: 5,607
  • Joined: 14 Jun 2009

Posted 13 July 2020 - 10:42 AM

Hi Michael, Yes I tried it both ways checked, not checked, uploaded a master flat and checked the box. No go.     

 

Rob, I was afraid of that!  Ok I wont mix the capture programs, this data is older as I was making a transition to APT from SGP due to being able to dual dither with APT.  

 

Ok I can try and make sure I avoid this problem in the future.  Not sure why PI wont just trust me that these are actual flat files!

sounds like you're on the right track now... as for PI trusting that these are flats, well, it does know that they are flats but since it can't match the filter name it thinks they are extraneous files. anyway the "add custom" function is there precisely to overcome these sorts of problems. but it's best to go back and fix your capture program settings so that everything just matches up properly.


  • skycamper likes this


CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.


Recent Topics






Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics