Jump to content

  •  

CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.

Photo

9.25 evolution azimuth motor stopped working

  • Please log in to reply
7 replies to this topic

#1 Cfeastside

Cfeastside

    Explorer 1

  • -----
  • topic starter
  • Posts: 66
  • Joined: 28 Apr 2020
  • Loc: Eastern sierra California

Posted 01 August 2020 - 02:03 PM

A couple nights ago during an alignment the mount completely stopped and shut down.  After turning it back on there was no reponse to azimuth input either from the ipad or the hand controller.  I had the mount on the wedge.   Im assuming the motor or the controller board is toast.  The battery had been fully charged before using it that night.  
 

tried getting a hold of celestron tech support via phone was unsuccessful and put in a ticket yesterday afternoon.  Not too encouraged at seeing people’s experiences with long turn around times for warranty work.  
 

just got the scope in early may and got the wedge in june.  Didnt have a lot of time on the wedge.  I was having difficulties getting accurate and consistent gotos on the wedge. Im wondering if the mount was a bit off from the factory and the wedge just was too much.  i only had starsense telrad and 2” diag with 22 panoptic so i dont think was too heavy.  But perhaps this mount is not quite up to the task with 9.25 ota and on wedge.  Not sure i want to do this on the replacement mount.  

 

anyone else have similar experiences with this mount?
 

 



#2 coopman

coopman

    Fly Me to the Moon

  • *****
  • Posts: 6,430
  • Joined: 23 Apr 2006
  • Loc: South Louisiana

Posted 01 August 2020 - 02:20 PM

I have seen past threads here about the azimuth motion locking up and the fix for it. Try searching for this issue and see if you can find some guidance. Good luck.

#3 coopman

coopman

    Fly Me to the Moon

  • *****
  • Posts: 6,430
  • Joined: 23 Apr 2006
  • Loc: South Louisiana

Posted 01 August 2020 - 02:26 PM

Try here:

https://www.cloudyni...h#entry10022422



#4 whizbang

whizbang

    Viking 1

  • *****
  • Posts: 775
  • Joined: 18 Mar 2018
  • Loc: NE of Seattle, WA

Posted 01 August 2020 - 02:34 PM

My new EVO925 arrived June 13th.

 

The wifi died completely 2 weeks ago.  The mount/hand control started getting ERROR 17 and ERROR 16 lock ups 10 days ago.

 

It took a week to get a Return Authorization.  I shipped it back just this morning.

 

When the EVO mount works, it's amazing.  My old EVO8 is a tank.



#5 Cfeastside

Cfeastside

    Explorer 1

  • -----
  • topic starter
  • Posts: 66
  • Joined: 28 Apr 2020
  • Loc: Eastern sierra California

Posted 01 August 2020 - 04:00 PM

I have seen past threads here about the azimuth motion locking up and the fix for it. Try searching for this issue and see if you can find some guidance. Good luck.

Thanks for link.  Looks like that was for clutch tightening up.  I can loosen clutch no problem



#6 Cfeastside

Cfeastside

    Explorer 1

  • -----
  • topic starter
  • Posts: 66
  • Joined: 28 Apr 2020
  • Loc: Eastern sierra California

Posted 01 August 2020 - 04:03 PM

My new EVO925 arrived June 13th.

 

The wifi died completely 2 weeks ago.  The mount/hand control started getting ERROR 17 and ERROR 16 lock ups 10 days ago.

 

It took a week to get a Return Authorization.  I shipped it back just this morning.

 

When the EVO mount works, it's amazing.  My old EVO8 is a tank.

Im afraid its gonna take awhile to get fixed.  A week to get a return authorization not very inspiring.  Im not seeing any kind of error code.  Ive looked.   Is your error scrolling on screen when first power up?  Is that nexstar or starsense hc?   Good luck with your repair



#7 skaiser

skaiser

    Viking 1

  • -----
  • Posts: 730
  • Joined: 16 Oct 2010
  • Loc: dallas Texas

Posted 01 August 2020 - 04:20 PM

Celestron can be slow to respond but once you get RMA, they are very good about processing the repair.

you should be able to only ship the arm back with the hand control. Hopefully you kept the original box to make it easier to pack and ship.

i always keep my original boxes for 3-4 years, maybe longer ( much to frustration of my wife) but if you need to return it is very handy.

good luck



#8 coopman

coopman

    Fly Me to the Moon

  • *****
  • Posts: 6,430
  • Joined: 23 Apr 2006
  • Loc: South Louisiana

Posted 01 August 2020 - 07:09 PM

OK, sorry.


CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.


Recent Topics






Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics