Jump to content

  •  

CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.

Photo

Astroberry Wifi Problem

  • Please log in to reply
8 replies to this topic

#1 acommonsoul

acommonsoul

    Vostok 1

  • -----
  • topic starter
  • Posts: 133
  • Joined: 08 Jan 2014

Posted 29 October 2020 - 12:47 AM

So I just got a Raspberry pi 4 and loaded Astroberry on it. I can boot it up fine and access all the menus and such on the astroberry hotspot. The problem  is when I add my home network in the advanced network configuration and then connect to it the system will switch me back to my home network, which it is supposed to, and bring me back to the astroberry home screen, but then it fails to log in every time. It just states failed to connect to server. Also, because I set the home wifi network to a higher priority than the hotspot, the pi logs onto my home network supposedly, but I can't access it to change any settings. Please help. I have no idea how to access the log files or anything.



#2 endlessky

endlessky

    Viking 1

  • -----
  • Posts: 700
  • Joined: 24 May 2020
  • Loc: Padova, Italy

Posted 29 October 2020 - 01:05 AM

If you changed the priority, I think the only way you can get back into it is by plugging in the ethernet cable and connect it directly to the modem/router. This way, it should bypass all the priorities you set and just connect directly to the network. This is what I used to do if I changed the priority from wi-fi to hotspot (or viceversa) and then forgot to reset the priority before switching the Pi off.

 

You can then log in into your modem/router (usually, by typing 192.168.1.1 on a browser), see what IP address was assigned to the Pi and use something like VNC Viewer on your computer to remote desktop into the Pi. After that, you can change the settings. There are also some free programs that allow you to see all the IP addresses of devices currently attached to the network. One of these is Angry IP Scanner.

 

Another alternative is to hook the Pi up to a keyboard, mouse and monitor and go into it directly, without network connection needed.



#3 acommonsoul

acommonsoul

    Vostok 1

  • -----
  • topic starter
  • Posts: 133
  • Joined: 08 Jan 2014

Posted 29 October 2020 - 01:13 AM

I ended up just reflashing the img file and starting over. I get the same result each time though. After confining the internet and switching over I can’t connect to the server.

#4 acommonsoul

acommonsoul

    Vostok 1

  • -----
  • topic starter
  • Posts: 133
  • Joined: 08 Jan 2014

Posted 29 October 2020 - 12:17 PM

Anybody have a suggestion? I’ve tried it 5 times now and every time I connect to my WiFi with Astroberry it acts like it’s connected but then the server fails to join every single time.

#5 sbradley07

sbradley07

    Messenger

  • *****
  • Posts: 419
  • Joined: 06 Mar 2017
  • Loc: Connecticut

Posted 29 October 2020 - 01:41 PM

You don't provide details on this, but if you are trying to connect to it using the same IP as the Astroberry hotspot, it won't work.  endlesssky gave you two good suggestions, but it's not clear you tried either.  You need to determine the IP address of the Pi if it is indeed connected to your network.  You can either look at it directly with a keyboard/monitor or connect it via ethernet to your network and check for it's IP address in your router admin panel. 



#6 acommonsoul

acommonsoul

    Vostok 1

  • -----
  • topic starter
  • Posts: 133
  • Joined: 08 Jan 2014

Posted 29 October 2020 - 01:46 PM

You don't provide details on this, but if you are trying to connect to it using the same IP as the Astroberry hotspot, it won't work. endlesssky gave you two good suggestions, but it's not clear you tried either. You need to determine the IP address of the Pi if it is indeed connected to your network. You can either look at it directly with a keyboard/monitor or connect it via ethernet to your network and check for it's IP address in your router admin panel.


Currently I don’t have a micro hdmi cable so I’m working on ordering one. I’ll have to wait until it arrives until I can connect directly to the modem and use a monitor to adjust settings.

#7 TelescopeGreg

TelescopeGreg

    Vanguard

  • -----
  • Posts: 2,334
  • Joined: 16 Jul 2018
  • Loc: Auburn, California, USA

Posted 30 October 2020 - 10:54 PM

When you connect the Astroberry to your home network, how are you trying to connect to it?  What IP address?  You should be able to log into your home router and ask it what the Astroberry IP address is.  It will NOT be the same 10.42.0.1 as the hotspot.

 

I presume your Astroberry system is in close-enough proximity to your home network to get a good signal.

 

Oh, just to check...  Is the home network you connected to a "guest" network?  If so, you can't get to it from a laptop on the regular home network.



#8 acommonsoul

acommonsoul

    Vostok 1

  • -----
  • topic starter
  • Posts: 133
  • Joined: 08 Jan 2014

Posted 02 November 2020 - 09:18 AM

When you connect the Astroberry to your home network, how are you trying to connect to it? What IP address? You should be able to log into your home router and ask it what the Astroberry IP address is. It will NOT be the same 10.42.0.1 as the hotspot.

I presume your Astroberry system is in close-enough proximity to your home network to get a good signal.

Oh, just to check... Is the home network you connected to a "guest" network? If so, you can't get to it from a laptop on the regular home network.


So I’m not quite sure how to figure out what IP address it’s connected to. I’m terrible with internet router stuff. When I connect my monitor and keyboard to the raspberry pi it shows I’m connected to the WiFi and I have been able to do all of my updates and such. When I try to connect to the unit via a laptop of my desktop over my home WiFi the server just says failed to connect.

#9 TelescopeGreg

TelescopeGreg

    Vanguard

  • -----
  • Posts: 2,334
  • Joined: 16 Jul 2018
  • Loc: Auburn, California, USA

Posted 02 November 2020 - 04:26 PM

So I’m not quite sure how to figure out what IP address it’s connected to. I’m terrible with internet router stuff. When I connect my monitor and keyboard to the raspberry pi it shows I’m connected to the WiFi and I have been able to do all of my updates and such. When I try to connect to the unit via a laptop of my desktop over my home WiFi the server just says failed to connect.

Most home routers have a screen where they list the clients that are connected to them.  Astroberry should show up there, along with it's address.

 

Another way is to use a "Service Browser" on your smartphone.  Devices on a network often "advertise" their services using a protocol called "Bonjour".  Astroberry shows up under "_device-info._tcp" and "_smb._tcp" on my network.

 

The easiest way is probably to aim your browser at "astroberry.local", where your browser essentially does the Bonjour thing in the background to find it.  That will take you to the browser-based remote desktop; click on Start, then Connect.

 

Finally, when you have the monitor and keyboard connected to the Pi, you should be able to right-click on the WiFi icon at the top right, and choose "connection information".  That will tell you the IP address under IPv4.

 

All of the above should give you the same answer.  Your choice, at that point, on connecting via the browser or a VNC client.  Ah...  for VNC, vague recollection that I had to enable that under the Preferences -> Raspberry Pi Configuration / Interfaces tab.  At least, check that it's enabled when you have the monitor / keyboard attached.


  • acommonsoul likes this


CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.


Recent Topics






Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics