Jump to content

  •  

CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.

Photo

Kstars Ekos a Mac and a G9

  • Please log in to reply
No replies to this topic

#1 jonnybravo0311

jonnybravo0311

    Viking 1

  • -----
  • topic starter
  • Posts: 631
  • Joined: 05 Nov 2020
  • Loc: NJ, US

Posted 03 December 2020 - 10:20 AM

In an attempt to see if I would ever be able to automate my workflow - especially as I'm considering a new mount - last night I gave Kstars and Ekos a try. First, I installed the gphoto2 libraries and command line tools on my Mac. Then I plugged my G9 into it via the USB cable.

 

To be honest, I wasn't expecting it to even be recognized. Imagine my surprise when I entered the command gphoto2 --auto-detect and got back a message. Of course, the message was incorrectly identifying my camera as a GH5, but I pressed on anyway. I next ran the command gphoto2 --capture-image. My camera's shutter activated and I had an image stored on my SD card. Things were looking pretty good!

 

So, feeling bolstered by my success to this point, I downloaded and installed Kstars. I had never used this application before, so I was flying by the seat of my pants here.

 

I managed to stumble my way through things and launched Ekos. I got to the camera part and clicked the preview button. Well, of course, I got some horrible mocking sound and an immediate failure. Rude. :p

 

Spent some more time and realized I had to actually configure my camera's information... sensor size, pixel pitch, etc. I put all of that in and tried again. I clicked the preview button and my shutter activated and there was the image.

 

Well... I might actually be able to use this! Let's see if I can simulate an imaging session. I set the camera to bulb mode. I set Ekos to take 2 * 90s exposures. I clicked play. My shutter activated... and immediately closed. Wait... what? I set it for 90s... that was maybe 1s.

 

Thinking maybe I did something wrong, I checked everything again. Looks good... oh, there's some "force bulb" config. Let's set that. OK, that's done. Try again. Nope, same thing. There's some message in the log about making sure my camera is in bulb mode and the AF switch is set to manual. Um... OK... both are already set that way. Let's set the switch on the lens itself to be manual focus just in case. Oh, and let's shut everything down and restart.

 

Once everything was back up, and the camera was connected, I tried again. Same thing. Shutter is open for only 1s. Hmmm...

 

Alright, maybe I can't use bulb mode. Well, internally, my G9 can take up to 60s. Let's try that. So, I set Ekos to take a 60s exposure. I change my camera from bulb to 60s. I try again. I click play and the shutter opens... and stays open. 60s later, it closes, waits the 2s delay, and opens again. 60s later, my run is completed.

 

Woohoo! I'm good to go! Or so I thought...

 

The images were saved both to my Mac's drive as well as to my camera's SD card. When I opened the fits files I got... well... complete black with some strange Matrix-like green around the bottom of the frame. That's not useful at all! So, I opened up the images on my SD card. I expected to see completely blown out whites (I was, after all, taking these test shots in my home office at my desk with plenty of light). To my surprise, I got images that weren't blown out at all. Inspecting them, the EXIF data shows them as 1s exposures.

 

And, that's where I gave up for the night.

 

Has anyone out there been successful using this combination? Are there obvious settings I might not have done properly? To be honest, I'm actually surprised I got as far as I did.

 

If you've got any suggestions, I'm willing to try them :)

 

Thanks!




CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.


Recent Topics






Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics