Jump to content

  •  

CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.

Photo

Han anyone had connection issues with the latest ASCOM 6.5?

  • Please log in to reply
7 replies to this topic

#1 Ballyhoo

Ballyhoo

    Fly Me to the Moon

  • *****
  • topic starter
  • Posts: 6,224
  • Joined: 22 Jul 2011
  • Loc: San Diego

Posted 05 March 2021 - 06:44 PM

I have. After I upgraded to 6.5 it has been impossible for me to use my favorite  laptop, a Microsoft Surface, for imaging as I cannot get a connection between both the Ioptron Commander and my Moonlight focuser. For example, the USB ports on the USB hub do not show the green power light as connected. When I went to try and the second laptop, still my Ioptron Commander and my Moonlight focuser would not power up and thus no connection -- until I uninstalled and reinstalled the ASCOM completely.  I did the same for the third laptop as a test and it worked too. But for my chosen imaging laptop no matter how many times I reinstall ascom 6.5 and other drivers, my Ioptron Commander will not connect nor will the Moonlight focuser. So now I have to use my heavier, energy draining laptop to image.

 

This all just happened because when I bought my AS!294mm Pro, it required the latest ASCOM 6.5 to run. I am not sure though, why the issues. And also sometimes even on the the heavier laptop I have to pull out the USB cable a couple of times before there is a connection. And yes,   I have the most expensive USB hub that has its own power, and three other hubs that I have tried. Makes no difference.  At this point I sadly may have to ditch my beloved Surface laptop for imaging. 


Edited by Ballyhoo, 05 March 2021 - 06:46 PM.


#2 Rion

Rion

    Lift Off

  • -----
  • Posts: 2
  • Joined: 29 Jan 2021

Posted 05 March 2021 - 07:40 PM

It actually sounds more like a compatibility problem with your Microsoft "Surface". I really can't see how the ASCOM 6.5 can be faulted for a problem that lies with the "Surface's" compatibility. I've heard too many people say that Microsoft is it's "own breed". Personally, that's why I've never considered owning one. Good luck on this though...



#3 StephenW

StephenW

    Apollo

  • -----
  • Posts: 1,379
  • Joined: 04 Feb 2005
  • Loc: San Jose, CA

Posted 05 March 2021 - 07:54 PM

It looks like the latest supported version of ASCOM for iOptron commander is 6.4:  https://www.ioptron....cles.asp?ID=337

 

And Moonlite just mentions ASCOM Platform "6" - so hard to tell if it's compatible with 6.5...

 

But you're saying that both devices work with 6.5 (SP1, I assume?) on your other laptops, just not on your surface?

 

You sure you have the necessary .NET versions installed on your surface?  

 

per ASCOM release notes you need both .BET 3.5 & 4.8

 

https://github.com/A...tform/releases/

 

- Requires .NET 3.5 to be installed (Windows 7, 8) or enabled (Windows 10)
- Requires .NET 4.8 to be installed



#4 philinbris

philinbris

    Messenger

  • *****
  • Posts: 492
  • Joined: 10 Jan 2020
  • Loc: Brisbane, Australia

Posted 05 March 2021 - 08:00 PM

It actually sounds more like a compatibility problem with your Microsoft "Surface". I really can't see how the ASCOM 6.5 can be faulted for a problem that lies with the "Surface's" compatibility. I've heard too many people say that Microsoft is it's "own breed". Personally, that's why I've never considered owning one. Good luck on this though...

How can you come to that conclusion when something works before an upgrade of software and then does not work after the upgrade?

Surely that indicates its more of a software issue than the hardware that has not changed?


Edited by philinbris, 05 March 2021 - 08:01 PM.


#5 Ballyhoo

Ballyhoo

    Fly Me to the Moon

  • *****
  • topic starter
  • Posts: 6,224
  • Joined: 22 Jul 2011
  • Loc: San Diego

Posted 05 March 2021 - 08:16 PM

 

 

https://github.com/A...tform/releases/

 

- Requires .NET 3.5 to be installed (Windows 7, 8) or enabled (Windows 10)
- Requires .NET 4.8 to be installed

regarding the above, wouldn't I get that with the upgrade to ASCOM 6.5?



#6 Ballyhoo

Ballyhoo

    Fly Me to the Moon

  • *****
  • topic starter
  • Posts: 6,224
  • Joined: 22 Jul 2011
  • Loc: San Diego

Posted 05 March 2021 - 08:17 PM

I wonder why ZWO requires the latest ascom 6.5 for its newest cameras?  Does not allow for backwards compatability.



#7 Rion

Rion

    Lift Off

  • -----
  • Posts: 2
  • Joined: 29 Jan 2021

Posted 05 March 2021 - 09:52 PM

I'm sorry, maybe I misread your question. I thought that you were saying that it did work on your other two laptops but not on your "surface".



#8 philinbris

philinbris

    Messenger

  • *****
  • Posts: 492
  • Joined: 10 Jan 2020
  • Loc: Brisbane, Australia

Posted 06 March 2021 - 04:12 PM

regarding the above, wouldn't I get that with the upgrade to ASCOM 6.5?

Only if the software dev packages the .net installers with their setup program.

Cheers




CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.


Recent Topics






Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics