Jump to content

  •  

CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.

Photo

Myscope4960 pec editor for LX85

Equipment Software
  • Please log in to reply
67 replies to this topic

#26 OzAndrewJ

OzAndrewJ

    Fly Me to the Moon

  • *****
  • Posts: 5,352
  • Joined: 30 Nov 2010

Posted 05 April 2021 - 06:50 AM

Gday Damo

the model name entered in Audiostar is "LX85 8 ACF" which is slightly different to what was reported in the log.

Thats probably me :-)

I have hardcoded names against the model nos selected in my app,

so can guarantee they are the same as in the Meade code, as it changes over time.

As long as it works, i wouldnt worry :-)

 

I think it would have been a really long wait for Meade to resolve this themselves

I cant believe they stuffed it up so badly, ( and that no one else has detected it yet )

Based on this and another recent thread re cordwrap on LX65s

i have to assume they have no idea what they are doing at present.

 

Andrew Johansen Melbourne Australia



#27 Damo19

Damo19

    Lift Off

  • -----
  • topic starter
  • Posts: 19
  • Joined: 28 Mar 2021

Posted 06 April 2021 - 04:54 AM

Hi Andrew,

 

It does seem like this firmware has been rushed a bit given the number of bugs, there's also some weird shenanigans with DEC axis after unparking which i think flips the sign of the DEC axis (although I'm not completely sure what its doing smile.gif. Its easily resolved by running a single star alignment. But again another example of something being missed before they put it out. 

 

Anyway I had some decent weather last night so I managed to get in some real time PE training runs (see attached .rom).  A comparison of PE error in the PHD log data with and without PEC active definitely showed a marked improvement smile.gif Its still a bit choppy as this was with unsmoothed correction data. Nevertheless an excellent result given the starting point smile.gif

 

I did have a quick blast with the smoothing options in Myscope this morning and I can get a nice interpolated curve however the loadRA Avge button remains greyed out. Do I need to enable something else in the software to back load the smoothed curve into the PEC table? 

 

Cheers

 

Damo

 

 

Attached Files



#28 OzAndrewJ

OzAndrewJ

    Fly Me to the Moon

  • *****
  • Posts: 5,352
  • Joined: 30 Nov 2010

Posted 06 April 2021 - 05:57 AM

Gday Damo

It does seem like this firmware has been rushed a bit given the number of bugs,

Yes and no. We identified a lot of the ( still existing ) bugs as soon as the new CPU came out

( incl how the ASU doesnt work properly. )

We advised them in detail of the bugs but it appears its not worth their while to fix them

and each new release brings new ones.

Just the way it is, as most bugs dont affect normal manual operation.

 

however the loadRA Avge button remains greyed out. Do I need to enable something

No idea????

The button status "should" only be controlled by whether or not you have the peek/poke patch.

Will need to check tomorrow if i stuffed something up when i rewrote it all for the new PEC formats.

 

That said, your PEC is about 45 arcsec pk-pk based on the model, but very smooth.

Be interesting at some time to get a PHD, unguided, PEC off log for say 3-5 revs of the worm

to get a baseline of the raw PE to compare against.

 

Andrew Johansen Melbourne Australia


Edited by OzAndrewJ, 06 April 2021 - 06:04 AM.


#29 OzAndrewJ

OzAndrewJ

    Fly Me to the Moon

  • *****
  • Posts: 5,352
  • Joined: 30 Nov 2010

Posted 06 April 2021 - 11:57 PM

Gday Damo

OK, found the bug.

I didnt finish incorporating the LX85 in full as i didnt know its worm wheel toothcount

and as no one ever commented on it, i simply forgot to finish it lol.gif

( My app handles the PEC "by bin" properly , but i needed the toothcount to do

true arcsec error conversions. As such, the "true arcsec" plot is correct in shape

but has a scaling error in the Y axis. )

Just retesting my fixes and wil lpost tomorrow, but if you do a few more trains

and save them out after each one, you wil still be able to post process them

( and it will also give a good idea of the repeatability )

 

Andrew Johansen Melbourne Australia



#30 OzAndrewJ

OzAndrewJ

    Fly Me to the Moon

  • *****
  • Posts: 5,352
  • Joined: 30 Nov 2010

Posted 07 April 2021 - 09:46 PM

Gday Damo

New version up on my site.

Seems to work now lol.gif

 

Andrew Johansen Melbourne Australia



#31 Damo19

Damo19

    Lift Off

  • -----
  • topic starter
  • Posts: 19
  • Joined: 28 Mar 2021

Posted 08 April 2021 - 05:03 AM

Thanks again Andrew,

 

Loaded up a previous rom file and applied some smoothing / interpolation etc and back loaded to the audiostar with no problemslaugh.gif. Just need the sky's to clear now to do some proper testing, in fact cant you add a clear sky button to the app as its seems your able to fix anything, so the weather should be easy lol.gif.

 

Below is a screen shot of a few worm cycles with the pec off, Although pk-pk is quite big somewhere around 30 it does look reasonable smooth so I think pec should help quite a lot with this. I suspect other LX85's maybe better pk-pk but not as smooth as what's measured here as I'm running belts instead of the standard brass gears. This is just speculation as I didn't do measurement before the belt mod. 

 

Anyway at the next available opportunity I'll update with a further plot showing the end result with the new smoothed PEC curve active. 

 

no_pec.jpg

 

 

 

 

Cheers

 

Damo

 

 

 

 

 

 

 

 

 



#32 OzAndrewJ

OzAndrewJ

    Fly Me to the Moon

  • *****
  • Posts: 5,352
  • Joined: 30 Nov 2010

Posted 08 April 2021 - 05:11 AM

Gday Damo

as I'm running belts instead of the standard brass gears.

Oohhh sneaky waytogo.gif , so i assume you just changed the sign of the ratios to make it work. ????

Your PEMPro log shows a distinct high freq ripple ( belt related ??? )

Would luv to get the pempro log file so i can guess what tooth count you used for the belts :-)

 

Andrew Johansen Melbourne Australia



#33 Menocchio

Menocchio

    Lift Off

  • -----
  • Posts: 12
  • Joined: 08 Jan 2020
  • Loc: Philadelphia, PA

Posted 08 April 2021 - 09:34 AM

Hi all.

Andrew, you may remember me from a year or so ago when you helped me figure out how to solder a connection back into my LX85 from the Aux port after I accidentally reversed the polarity in the HBX port.

Happy to say that the fix is still working marvelously, but I recently ended up spending a couple of frustrating nights battling the bug mentioned earlier in the thread, in which the sign of the Dec value gets inverted when unparking. Thankfully, Starpatch resolved that for me, but the whole tribulation led me to this thread which I read with keen interest. Imagine my shock to learn that all this time, when I was doing "PPEC", that first 'P' stood for Placebo! Scandalous waste for such a touted feature of the mount to not even work without third party software. Once again, astounded by your competence. You're clearly running circles around any of the clowns currently making telescope mounts over in Irvine, California.

Since my own savvy about all of this is marginal by comparison: I just want to make sure I am doing what I need to in order to get the feature working. This morning I managed to find MyScope ver. 4.9.9.5 along with its proviso that for LX85s using A4S4, the firmware needs to be patched in order for the mount's native PEC to work. What is the right patch to install, and from where?

 

Most recently (yesterday), I patched my mount with PatchAUA4S4v01.spf from Starpatch, and clearly that wasn't the ticket because after training and updating twice on the handbox last night, I'm looking at 71 zeroes on the MyScope application today.



#34 Menocchio

Menocchio

    Lift Off

  • -----
  • Posts: 12
  • Joined: 08 Jan 2020
  • Loc: Philadelphia, PA

Posted 08 April 2021 - 10:03 AM

Oh, just remembered a bit earlier in the thread. No sweat if the patch I installed was correct, because the PEC wouldn't have registered in any event, as I'm pretty certain the handbox was not set to speed 1.



#35 OzAndrewJ

OzAndrewJ

    Fly Me to the Moon

  • *****
  • Posts: 5,352
  • Joined: 30 Nov 2010

Posted 08 April 2021 - 05:10 PM

Gday Menocchio

 

What is the right patch to install, and from where?

Most recently (yesterday), I patched my mount with PatchAUA4S4v01.spf from Starpatch, and clearly that wasn't the ticket

A4S4v01.spf is the correct patch.

You will note in post #24, i gave a snippet to manually insert into the patch, and that will enable the PPEC.

It is ony a test at present hence why its not a "released" patch, but if you add that to your copy

then reload the patch, you should be able to get the PPEC working.

Also, the patch is specific for the 8" SCT model, so you wil need to select that model via the Hbx

or if you have another model, i can tell you how to tweak the patch for that.

 

as I'm pretty certain the handbox was not set to speed 1

That is no longer a requirement. As part of the rewrite of the code, Meade appear to have changed

from counting the interrupts a slew key was down, ( which meant it needed to know speed )

to now comparing perfect times per bin vs reality.

It was part of this change where they forgot to include the LX85s :-)

and as no one complained til just recently,

i never bothered to really dig into it.

 

Andrew Johansen Melbourne Australia


  • Menocchio likes this

#36 Menocchio

Menocchio

    Lift Off

  • -----
  • Posts: 12
  • Joined: 08 Jan 2020
  • Loc: Philadelphia, PA

Posted 08 April 2021 - 05:58 PM

Also, the patch is specific for the 8" SCT model, so you wil need to select that model via the Hbx

or if you have another model, i can tell you how to tweak the patch for that.

Aye, that's why I asked: I bought the LX-85 as a standalone mount, and the scope type is listed simply as "Audiostar LX85 Mount" in the MyScope app.

Lol, and part of me wonders if this is really all forgetfulness, or if there was some cynical 70's Ford Pinto style cost-benefits analysis meeting where they rejected the item: "replacing Dave in Accounting's nephew with a professional coder".



#37 OzAndrewJ

OzAndrewJ

    Fly Me to the Moon

  • *****
  • Posts: 5,352
  • Joined: 30 Nov 2010

Posted 08 April 2021 - 06:18 PM

Gday Menocchio

 

the scope type is listed simply as "Audiostar LX85 Mount"

Yep. There are 11 variants of LX85 listed in the code.

The only real difference between them ( internally ) is

a) The setting of the focal length

( only used for EP calcs and spiral search box sizing )

b) The upper and lower slew limits for mount collision testing

 

As such you can

1) use the patchette i loaded earlier, and then just select your mount as an 8"SCT

or

2) modify one line in the patchette

R 0D6C30  41 56     // change VM1 to LX85-8 SCT

becomes

R 0D6C30  41 50     // change VM1 to LX85-Mount

 

And then select "LX85 Mount" as per normal

 

I will see if i can pinch a way to do it in a cleaner manner

but they have mixed the LX65 and 85 mounts together,

so i cant do a simple range test.

 

Andrew Johansen Melbourne Australia


  • Menocchio likes this

#38 Menocchio

Menocchio

    Lift Off

  • -----
  • Posts: 12
  • Joined: 08 Jan 2020
  • Loc: Philadelphia, PA

Posted 08 April 2021 - 08:48 PM

Gday Menocchio

 

Yep. There are 11 variants of LX85 listed in the code.

The only real difference between them ( internally ) is

a) The setting of the focal length

( only used for EP calcs and spiral search box sizing )

b) The upper and lower slew limits for mount collision testing

 

As such you can

1) use the patchette i loaded earlier, and then just select your mount as an 8"SCT

or

2) modify one line in the patchette

R 0D6C30  41 56     // change VM1 to LX85-8 SCT

becomes

R 0D6C30  41 50     // change VM1 to LX85-Mount

 

And then select "LX85 Mount" as per normal

 

I will see if i can pinch a way to do it in a cleaner manner

but they have mixed the LX65 and 85 mounts together,

so i cant do a simple range test.

 

Andrew Johansen Melbourne Australia

No need to rush that on my account, I edited and loaded up the patch: lo and behold, it works.bow.gif  You're unstoppable. If Meade payed you the worth of your work on their products, they'd have to file for bankruptcy all over again.

So, while I can't pay you the barest fraction of the princely sum you've earned, I can give you this bit of levity:

I now feel very vindicated in my project of a few weeks back; designing and printing all new labels for my mount to make it look like a Seegson Corporation product: a company that makes bargain bin androids and 'great value' technology in the Alien universe. 

 

51104002995_d04b333484_b.jpg



#39 OzAndrewJ

OzAndrewJ

    Fly Me to the Moon

  • *****
  • Posts: 5,352
  • Joined: 30 Nov 2010

Posted 08 April 2021 - 09:00 PM

Gday Menocchio

No need to rush that on my account, I edited and loaded up the patch: lo and behold, it works

Excellent work.

 

designing and printing all new labels for my mount

As you have that ability ( and obviously too much time on your hands lol.gif lol.gif    )

Maybe print up a label marked "XAU" and stick it over yr Aux port,

just so you remember it is wired back to front

 

Andrew Johansen Melbourne Australia



#40 Menocchio

Menocchio

    Lift Off

  • -----
  • Posts: 12
  • Joined: 08 Jan 2020
  • Loc: Philadelphia, PA

Posted 08 April 2021 - 09:23 PM

Gday Menocchio

Excellent work.

 

As you have that ability ( and obviously too much time on your hands lol.gif lol.gif    )

Maybe print up a label marked "XAU" and stick it over yr Aux port,

just so you remember it is wired back to front

 

Andrew Johansen Melbourne Australia

lol.gif I like it, though when thinking of an in-theme label for THAT port, one really recommends itself....

alien_310.JPG
 



#41 Damo19

Damo19

    Lift Off

  • -----
  • topic starter
  • Posts: 19
  • Joined: 28 Mar 2021

Posted 12 April 2021 - 01:14 PM

Finally managed to test out the PEC before the clouds came in. The PEC was created using 4 consecutive training runs with the last three updates to provide a reasonable average data set before smoothing in the myscope app and back loading into the audiostar. I think in the end I went for a smoothing value of 3 with the interpolate switch unchecked. 

 

Grabbing some more data in PemPro shows a marked improvement with the PEC on (pec off was about 30 pk-pk), unfortunately the clouds came in before I could capture anymore worm cycles but even with the 1 and bit captured its clear the PEC is now working.

 

 

pec_on.PNG

 

Once again thanks for all your help Andrew, LX85's can now use the PEC like they were born too cool.gif



#42 Damo19

Damo19

    Lift Off

  • -----
  • topic starter
  • Posts: 19
  • Joined: 28 Mar 2021

Posted 12 April 2021 - 01:26 PM

updated plot from tonight with the scale dialled in, definitively a much better position to auto guide fromsmile.gif

 

 

pec_zoomed_in2.jpg


Edited by Damo19, 12 April 2021 - 03:47 PM.


#43 OzAndrewJ

OzAndrewJ

    Fly Me to the Moon

  • *****
  • Posts: 5,352
  • Joined: 30 Nov 2010

Posted 12 April 2021 - 04:20 PM

Gday Damo

Looking nice.

Can you post ( or PM ) the before and after logs from PEMPro

I can then overlay them to see the real effects.

 

Andrew Johansen Melbourne Australia



#44 Damo19

Damo19

    Lift Off

  • -----
  • topic starter
  • Posts: 19
  • Joined: 28 Mar 2021

Posted 13 April 2021 - 02:09 AM

Here you go Andrew PEMpro logs attached

 

Cheers

 

Damo

Attached Files



#45 OzAndrewJ

OzAndrewJ

    Fly Me to the Moon

  • *****
  • Posts: 5,352
  • Joined: 30 Nov 2010

Posted 13 April 2021 - 02:36 AM

Gday Damo

Hmm, the plot you posted in post #42 looks better than the log you posted,

but that said, the before and after from the posted logs shows a dramatic improvement.

It also shows a small high freq ripple is still there ( and looks like belt ripple )

However, it indicates the gears you used have 90 teeth ( which seems high to me )

Soooooooooooo, are they 90 toothers with an ultrafine belt ?????

Andrew Johansen Melbourne Australia

PEC before vs after.jpg



#46 Damo19

Damo19

    Lift Off

  • -----
  • topic starter
  • Posts: 19
  • Joined: 28 Mar 2021

Posted 13 April 2021 - 06:51 AM

That's strange if the data looks different, I'm pretty sure it's the same maybe I plotted it with drift offset thing enabled.

The belt mod is identical to the one shown here https://youtu.be/Qkr8W-_4Wzw. Its basically two cheap aluminium pulleys with 16 and 32 teeth driven by a 96mm belt. In terms of ratio it works out quite close to the standard brass gears.

#47 OzAndrewJ

OzAndrewJ

    Fly Me to the Moon

  • *****
  • Posts: 5,352
  • Joined: 30 Nov 2010

Posted 13 April 2021 - 05:21 PM

Gday Damo

That's strange if the data looks different,

Yep, i just tried PEMPro 2 and 3 and cannot replicate it, but the timestamp looks OK.

If i load it into PEMPro and select RA = Y, i get a close match but inverted.

Soooo, im not sure what the analyse screen is doing.

I normally use the PEMPro Log viewer as it forcibly plots RA and DEC by name

and your plot looked closer to DEC.

That said, there is still a strong fundamental at 90 so i assume this now comes from the gearbox.

I dont suppose you saw a part no for the encoder ?????

If i knew its linecount, i can reverse engineer the gearbox ratio to see where the ripple is coming from.

On a gut feel most "off the shelf" Meade Gbxs are between 40 and 50,

so if it was 45:1 and then a 2:1 belt we get 90:1

and that would indicate your motor has an eccentric gear on it

( and a 108 vane encoder, which is whats on LX90s/LT, LXD75 )

 

Just for my records, do you have the old gears and the toothcount???

 

Andrew Johansen Melbourne Australia

 

Ed, OK, found how to replicate it, and it appears to be a setting re "DeRotate"

My guess is yr plot is of the DEC.

I suggest in future if you want to look at the logs, use the freeware log viewer

as it is a bit more intuitive, and gives you the FFT results as well


Edited by OzAndrewJ, 13 April 2021 - 05:37 PM.


#48 Damo19

Damo19

    Lift Off

  • -----
  • topic starter
  • Posts: 19
  • Joined: 28 Mar 2021

Posted 14 April 2021 - 09:11 AM

Ok cool i'll check out the PEMPro log viewer looks very useful

 

For the original LX85 brass gears I get a tooth count of 52 and 26 I could of swore there were 53 on the big one last time I looked, but I must have miscounted. Anyway pic below for reference.

 

LX85_gears.jpg

 



#49 OzAndrewJ

OzAndrewJ

    Fly Me to the Moon

  • *****
  • Posts: 5,352
  • Joined: 30 Nov 2010

Posted 14 April 2021 - 04:21 PM

Gday Damo

 

Ok cool i'll check out the PEMPro log viewer looks very useful

It is a very useful tool, and will also open PHD logfiles ( but not calibrates, just tracking logs )

I use it al the time in conjunction with PHDs viewer and my own viewer

as each one gives different views of the same thing.

Andrew Johansen Melbourne Australia



#50 Damo19

Damo19

    Lift Off

  • -----
  • topic starter
  • Posts: 19
  • Joined: 28 Mar 2021

Posted 14 April 2021 - 06:11 PM

I think I'm turning into a PEC addict lol.gif. I've run a few more PEC updates and smoothed / avg the data in your app to try and get the best average I can. Also the seeing is a bit better tonight so that should have help as well.

 

I've run the new curve through PEMpro and If I understand this correctly I think I'm now getting 4.3 arcsecs pk-pk with the PEC on. Which is probably about as good as it gets for my set-up.

 

Not too bad for an LX85 swinging an 8"sct with a guide scope and DSLR hanging off itwaytogo.gif thanks again for all of your help getting to this point.

 

 

 

 

CheersCapture.jpg

 

 

I suppose i should start taking some images now smile.gif

 

Cheers

 

Damo

 

 

Attached Files




CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.


Recent Topics





Also tagged with one or more of these keywords: Equipment, Software



Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics