Jump to content

  •  

CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.

Photo

Can't have 2 lead violinist in a pub, alias, 2 ZWO cameras wont' work together

  • Please log in to reply
15 replies to this topic

#1 unimatrix0

unimatrix0

    Viking 1

  • -----
  • topic starter
  • Posts: 806
  • Joined: 03 Jan 2021

Posted 04 April 2021 - 11:58 AM

Wasted my 3-4 hours of clear sky on an ongoing issue with my  ASImini120  and my ASI533. 
This of course started after I switched from QHY cmos to my new AS533. 

I thought it was just a USB issue.  Nope! 

Things I tried- 
My original setup: 
1 main USB from my garage PC to a 3.0 Hub : 
Things connected: 
1. ASI533
2. ASI Mini guide cam
3. Mount EQ6R
4. Focuser
-  This setup has been working for me for months with QHY cam as main and my the ZWO mini as guiding, regardless which software running. 
 

Last night I stopped imaging because as soon as the ASI533 started taking images and the ASImini guiding, the guide cam would freeze up. Or both freeze up along with NINA. 

 

Changed it to this: 
2 USB Main cables  ASI 533 on a separate USB 3.0 cable. Disconnected the mount and focuser USB to avoid conflict issues and only deal with the cameras. 

  • Nope! won't work, one or both cameras would freeze up. 

 

Next try, connect the ASI mini 120 to the hub of the ASI 533

  • Nope! Won't work, one or both freeze up. 

Next try.  Disconnected the USB 3.0 hub, connected each and all equipment to the PC with their own USB cables. 

  • Nope! Won't work, one or both of the cameras would freeze up! 

Next Try (I'm patient, but it's 1am now and I'm cold) 
Wiped all the ASI ZWO software and drivers, including the ASCOM drivers for them, cleaned the registry, restarted the PC , installed all ZWO drivers + software +ASCOM drivers. 

  • Results:  NOPE,  still the same, cameras freeze up in  NINA and tried APT as well as Sharpcap  + PHD2. 

As last resort, I removed the ASI120 guide cam and put in my old $40 SVBONY 103 eyepiece camera for guiding. Not a super fantastic camera but I guided with it previously back in January. 

  • BOOM, everything is working!   I tried several connections scenarios, all working!  I just connected to the ASI533's extra USB ports with a 10 inch USB cable,  working just fine. 
  • I set everything back to my HUB version with one lead USB cable to my PC  - Yep, it's all fine;  guiding, imaging, whatever I want! 

Someone, whoever is out there with 2 ZWO cameras,  not sure how you do it.  You must probably use some other software than Windows 10, or other configuration I haven't tried yet. 
I just can't get 2 ZWO cameras working together, regardless of what USB or whatever else is connected or not. 

‚Äč 


Edited by unimatrix0, 04 April 2021 - 12:00 PM.


#2 SnowWolf

SnowWolf

    Mariner 2

  • *****
  • Posts: 281
  • Joined: 21 Jan 2019
  • Loc: Colorado Front Range

Posted 04 April 2021 - 12:04 PM

I have been imaging and guiding with 2 ZWO cameras for a year now.  Both connected to the same powered USB3 hub.

 

Last night I had the ASI290mm-mini guiding with PHD2 and the ASI183mm-Pro imaging with NINA.

 

One thing that may make a difference is I'm using the ASCOM driver with PHD2 and the native driver with NINA. 

 

Edit:

 

You can test things during the day - PHD2 doesn't need to guide, just loop the camera and NINA doesn't care what the images are pictures of.  It sounds like you are trying to connect the same camera to both programs. That's what happens when I accidently do that.


Edited by SnowWolf, 04 April 2021 - 12:15 PM.


#3 scopewizard

scopewizard

    Viking 1

  • *****
  • Posts: 570
  • Joined: 04 Oct 2010
  • Loc: Alberta, Canada

Posted 04 April 2021 - 12:06 PM

I use 2 x  ZWO cameras and it works well. Make sure when you connect in PHD2 that the proper camera is selected. I had this issue when I select in PHD2 "connect all", my main camera would also get selected in PHD2 instead of the guide camera. Both would fail in this instance.


  • PirateMike and 42itous1 like this

#4 pyrasanth

pyrasanth

    Aurora

  • *****
  • Posts: 4,606
  • Joined: 08 Jan 2016

Posted 04 April 2021 - 12:25 PM

Just curious- did you ensure that each camera had its own instance for the connection- so imaging camera as camera 1 and guide camera as camera 2?- this issue is quite unusual from my experience with ZWO cameras. It looks like the software had grabbed each camera and connected both to the same instance which would cause a crash of the software or hardware. I suggest, as said earlier, connect manually and ensure each camera has a unique instance for the connection.


  • 42itous1 likes this

#5 AhBok

AhBok

    Gemini

  • *****
  • Posts: 3,329
  • Joined: 02 Dec 2010
  • Loc: Lakeland, TN

Posted 04 April 2021 - 12:30 PM

Yep. I use a ZWO ASI 533 and ASI120 with Windows 10 and APT for a long time with no issues.
  • 42itous1 likes this

#6 Larry Mc

Larry Mc

    Mariner 2

  • -----
  • Posts: 295
  • Joined: 29 Sep 2008
  • Loc: Pittsburgh, PA.

Posted 04 April 2021 - 12:40 PM

Yep, sounds like PHD is connecting to the wrong camera.verify your camera setup, you should see multiple Zwo cameras listed, make sure phd select's the correct one for guiding.

Fyi, I've had up to four ZWO cameras running at the same time connected to a powered hub at the telescope and a single usb running to the laptop. (A juiced-up gaming machine). Asi120mc for phd guiding, asi290mc with a canon zoom lens as a widefield finder, asi294mc on the main scope, and a diy allsky cam using an asi224mc & fisheye lens, using multiple iterations of sharpcap.
  • cybermayberry likes this

#7 descott12

descott12

    Gemini

  • *****
  • Posts: 3,429
  • Joined: 28 Sep 2018
  • Loc: Charlotte, NC

Posted 04 April 2021 - 12:48 PM

I run my ASI 294MC Pro and 120MM mini together all the time. No problem at all.



#8 rimcrazy

rimcrazy

    Viking 1

  • *****
  • Posts: 569
  • Joined: 03 Mar 2012
  • Loc: Overgaard, AZ

Posted 04 April 2021 - 01:06 PM

I had a similar issue with using my ASI533MC and ASI290MM camera.  I could not use them together to save my life.  No matter what I did and no matter who's imaging software I used, when they were both plugged in I would always see two instances of my ASI290MM and no ASI533MC.  I just threw in the towel and figured nothing but a clean install of windows would fix it.

 

So I just did do a clean install of Windows and this time when I installed the ZWO drivers I made sure to NOT install any of the DirectShow or TWAIN drivers.   I only installed the the ASI Camera Driver,  ASIStudio and in my case the ASCOM ASI drivers.  This fixed my issue.  If you had installed the DirectShow and/or TWAIN drivers, try removing them and see if your system now works.


  • unimatrix0 likes this

#9 barbarosa

barbarosa

    Gemini

  • *****
  • Posts: 3,179
  • Joined: 11 Apr 2010
  • Loc: 139 miles W of the Awahnee Hotel

Posted 04 April 2021 - 01:47 PM

Almost everyone who responds will say that they can run two or more ZWO cameras at the same time. I will say three and a focuser or two. The guide cam and focuser can both run off the USB2 hub on a 294, a 533 or 2600 and probably many other combinations. 

 

I would still suspect a suspect a USB problem.

 

USB3 cable is quite often reported as problematic. Cable too long. Failure from bending or from extreme temperature, or undersized conductors for full power in longer runs.

 

When the cams freeze do they still appear in the win 10 device manager as working?

 

When you run SharpCap does the 533 show as connected at USB3?

 

You might want to run USB Tree Viewer to see the connection path for each device and whether the speed of the link is correct. If you select a camera in the tree the app brings up a window showing the device max connection speed, the actual connection speed  (super speed or high speed) and the power demand from the device. Multiple devices connected to the same hub can require more power than the hub can supply, causing one or more of the devices to perform erratically or fail.

 

If you are using SharpCap you should be able to start separate instances of SC for each camera or have PHD2 run one and two SC instances running two more cams. I know that you can get as many as three USB 3 ZWO cams working at the same time.


  • jdupton likes this

#10 unimatrix0

unimatrix0

    Viking 1

  • -----
  • topic starter
  • Posts: 806
  • Joined: 03 Jan 2021

Posted 04 April 2021 - 08:28 PM

Hi! Thanks for the responses, I did make sure I am selecting the right camera. I even saw their specs, saying their resolution and their usual settings and name, and yes I tried using the ASI mini with ASCOM drivers and even vice versa, The 533 -ASCOM and  Mini in native. Not working, the towel is thrown in the ring for now. 
I'm imaging tonight with the SVBONY as a guide, although it can be only used as a "webcam" in PHD2 but it's working. I need further testing , probably put both cameras right front of the computer without the scope and go from there. I am also thinking about cleaning up the computer, I got all kinds of drivers. I am also preparing a mini-PC with Astroberry OS loaded on it, just to try different things. 



#11 Jinux

Jinux

    Messenger

  • *****
  • Posts: 480
  • Joined: 25 Jun 2007
  • Loc: Bay Area, CA

Posted 04 April 2021 - 11:19 PM

One thing to double check is USB limit in NINA setting. If that is not the default 40, try to roll it back. I had similar problem when I set it to higher value. Once I put it back, everything went to normal.


  • Lucas.Maguire likes this

#12 BrettD

BrettD

    Vostok 1

  • -----
  • Posts: 158
  • Joined: 14 Aug 2020
  • Loc: Melbourne, Australia

Posted 05 April 2021 - 04:14 AM

I feel you pain!

 

I still haven't found a root cause and I suspect my issue (described in THIS THREAD) is the same thing.

 

Since then the issue seems to have gotten worse, and has spread to the ASCOM drivers as well, and rebooting no longer is a sure fix.

Last session the only thing that worked was running a septate cable back to a second root hub on my laptop.

Not happy about this, as I soon want a scope mounted usb hub for better cable management.

 

I think the crashing / freezing thing is a symptom of an underlying usb problem (like rimcrazy was suggesting) thats triggered when 2 connections to the same camera are made.  But the CAUSE is that both "cameras" point to the same "instance"

 

Last night ASCOM cameras 1 and 2 both connected separately in multiple programs (sharpcap / phd2 / nina) all actually connected to my 2600 (neither to the 174mm)

Verified by the reported resolution, and a flashlight down each main / guide scope.

 

Tonight I will try a remove all zwo / ascom camera drivers/ reboot / re-install ... and see if it makes any difference.  Hope a full reinstall of windows can be avoided ... its a new laptop, and would be a PITA!

 

Brett



#13 Lucas.Maguire

Lucas.Maguire

    Mariner 2

  • *****
  • Posts: 216
  • Joined: 03 Aug 2020
  • Loc: Rhode Island

Posted 05 April 2021 - 11:53 AM

One thing to double check is USB limit in NINA setting. If that is not the default 40, try to roll it back. I had similar problem when I set it to higher value. Once I put it back, everything went to normal.

this may be your issue. My USB limit in NINA would not allow the 2 cameras to be connected onto the same USB hub. I had to plug my guide cam into the hub and main cam into the Mini PC. 



#14 unimatrix0

unimatrix0

    Viking 1

  • -----
  • topic starter
  • Posts: 806
  • Joined: 03 Jan 2021

Posted 05 April 2021 - 11:26 PM

I traced the problem down to 1 USB cable.  The 2 cameras actually failed to operate just having them off the mount, on the table by themselves with their own USB cables connected to my Core i7 mid tower, which used to be like a mini server and can take plenty of load. One or both would hang, or one would just quit or never start. 
I used NINA , as well as SharpCap and PHD2. 

The problematic one is the main USB 3.0 cable that came with the ZWO ASI533pro . 

It's that flat sided USB cable , and I replaced it with a sturdier, thicker USB cable.  Also, the guide camera's cable is questionable, it's also that flat USB, and while it doesn't require such a large bandwidth, it starts to add up as all the stuff along with other USB devices, like my autofocuser and the mount. 
 

I went as far for a stress test, that I connected both of my cooled cameras (QHY and ZWO) and plus the guide cam and mount and focuser and the cables to my USB hub and then connected the hub with a single /sturdy USB cable to the computer. I had them all running at the same time ,  Both imaging cameras imaging with both NINA and APT , while the guide cam is looping in PHD2 and I'm moving the mount with EQMOD. Just to be sure. grin.gif

 

Truth to be told, I really don't like USB cables in general, as a connectivity for video signals,  and my gripe is how all the manufacturers are aiming for aesthetics over functionality since the smartphone mania. 

 


Edited by unimatrix0, 05 April 2021 - 11:29 PM.

  • SnowWolf likes this

#15 cybermayberry

cybermayberry

    Vostok 1

  • -----
  • Posts: 199
  • Joined: 26 Aug 2010

Posted 05 April 2021 - 11:58 PM

Post your phd2 log file

#16 unimatrix0

unimatrix0

    Viking 1

  • -----
  • topic starter
  • Posts: 806
  • Joined: 03 Jan 2021

Posted 07 April 2021 - 10:36 AM

Post your phd2 log file

Sorry, don't have it, couldn't use the software or guiding at the time. It's working fine now, since I changed the USB cables. 




CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.


Recent Topics






Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics