Jump to content

  •  

CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.

Photo

CFM cannot get it to open

  • Please log in to reply
5 replies to this topic

#1 ColdNights

ColdNights

    Sputnik

  • -----
  • topic starter
  • Posts: 26
  • Joined: 10 Mar 2021

Posted 14 April 2021 - 11:53 PM

I have a 64-bit Windows 10 operating system.  I have been trying for many attempts now to install Java so I can install Celestron’s CFM.  I do not know what I am doing wrong.  I have watched YouTube videos on downloading and installing both programs and making the short cut to open CFM, but CFM does not open.  I have even downloaded the Java offline zip and that did not help either. 

My browser is Google Chrome, could that be the problem?  On the Java web site, they talk about browsers and downloading both a 64-bit and 32-bit program if you use those types of browsers interchangeably.  I like using Chrome but if I have to change to some other browser, I can.  I do not know what bit rate browsers are or how to find out.

 

Please advise me.

Thank you,

Jerry



#2 kg74

kg74

    Sputnik

  • -----
  • Posts: 49
  • Joined: 28 Feb 2021

Posted 15 April 2021 - 09:32 PM

Your browser should not matter as the program is JAVA - independent of your browser.  I have it running fine on a Windows 10 64 bit machine.  I did go in and told it to run as XP though. 

 

I also have it running without any issues on my old XP laptop with serial port - thing is older than some of my kids, but it works just fine when I use it for various things once or twice a year.



#3 rocice

rocice

    Lift Off

  • -----
  • Posts: 16
  • Joined: 25 Dec 2020
  • Loc: Colorado

Posted 16 April 2021 - 07:46 AM

Windows 10 is 64bit and does not have java installed.  Your browser has nothing to do with running java on Windows.

 

Do you have java installed?  Is CFM in a folder and do you see CFM.jar?

 

If you can see CFM.jar in a folder, with your mouse, right click on CFM.jar, click on Properties at the bottom of the window that opens. 

 

A new window will open, CFM.jar Properties.  In the General tab, look for Type of file: should read Executable Jar File (jar)   and Opens with: Java™ Platform SE bit

 

If you do not see Executable Jar File (jar) and Opens with: Java™ Platform SE bit click on the gray Change button. 

 

New window opens How do you want to open .jar files from now on?  Under Other Options Java should be listed.  If listed click on Java, will turn blue, then click OK.  If Java is not listed click on More apps  and/or Look for another app on this pc you should be able to scroll and find Java.  Select Java, click OK, click Apply, click OK.  wonderful windows...

 

You should be able to open CFM.jar by double clicking on it.  You will want to have your mount and hardware you want firmware updated on connected to your mount and your mount connected to your PC.  The CFM window should open.

 

If that fails, look through https://www.cloudyni...ch&fromsearch=1



#4 ColdNights

ColdNights

    Sputnik

  • -----
  • topic starter
  • Posts: 26
  • Joined: 10 Mar 2021

Posted 16 April 2021 - 03:50 PM

Well after about 4-hours of trying different “Open with” links and reading what many have stated what worked for them, I went to YouTube again to see what I could find.  One of the forum members did mentioned “jarfix download” fixed his issue.  YouTube had that fix as did some other methods; making a text file and turning the text file to a .bat.  I elected to try the “jarfix download”.  That worked but you must be careful when downloading it because, the free downloads want you to download the first button which is usually full of advertisements or wanting to let you install a virus protection software.  Scroll on down to just get the “jarfix download” software.  Even when I am careful on downloads, if during the install there is a check box marked with some other software to install, I always uncheck the box.  I only want the software not the extra stuff.  Anyway, “jarfix download” did correct the problem. 

I seem to remember that the hand controller NexStar*™ is not designed to work with updates, such as CFM, other than the MCupdate for motor encoder boards.  I was able to clear out the error #16 & #17 from that hand controller using the MCupdate software.  Am I correct about the NexStar*™?

The club has two NexStar+ controllers but only one seems to have a working COM port connection.  The non-working one still works on the telescope but updates and using it with a planetarium software are not obtainable.  Is there a way to fix that connection?  I used the same mini-USB cable, so it must be a connection problem in the hand controller. 

 

Thank you all for the assistance.



#5 Michael_Swanson

Michael_Swanson

    Author of The NexStar Users Guide

  • *****
  • Vendors
  • Posts: 3,456
  • Joined: 23 Apr 2003

Posted 17 April 2021 - 01:44 AM

Version 4 hand controls (sometimes referred to as "NexStar*" hand controls) require HCupdate, not CFM to update firmware:

https://www.nexstars...wToVersion4.htm

 

NexStar+ hand controls (version 5) require CFM to update firmware:

https://www.nexstars...NexStarPlus.htm

 

The newest mounts (Evolution, AVX, CGX, CGXL) require CFM to update firmware:

https://www.nexstars...pgradeHowTo.htm

 

The older mounts (NexStar GPS, CPC HD Deluxe, CPC, LCM, SE, SLT, CGE, CGE Pro, CGEM and AS-GT) require MCupdate to update firmware:

https://www.nexstars...pgradeHowTo.htm

 

These links are from this section of my website:

https://www.nexstars...om/Firmware.htm

 

Best regards,
Mike Swanson
https://www.NexStarSite.com



#6 ColdNights

ColdNights

    Sputnik

  • -----
  • topic starter
  • Posts: 26
  • Joined: 10 Mar 2021

Posted 17 April 2021 - 09:13 AM

Thanks for the clarification info Mike




CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.


Recent Topics






Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics