Jump to content

  •  

CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.

Photo

Astroberry su password

  • Please log in to reply
8 replies to this topic

#1 Wm Rison

Wm Rison

    Mariner 2

  • *****
  • topic starter
  • Posts: 240
  • Joined: 24 Oct 2005
  • Loc: Newburg, Maryland

Posted 22 June 2021 - 11:15 AM

I want to change the network mask for eth0.

When I do the ifconfig eth0 192.250.0.2 netmask 255.255.255.0 (what I need it to be) I get Operation not permitted.

So I try and change to super user with the su command.

su fails with authentication failure

Tried astroberry and raspberry as passwords, no luck.

 

Looked at the document on astroberry.io it was not any help.

Does anyone know the su passwrod for astroberry?

 

William



#2 astrokeith

astrokeith

    Apollo

  • -----
  • Posts: 1,091
  • Joined: 14 Mar 2010
  • Loc: Surrey, UK

Posted 22 June 2021 - 11:40 AM

Weird. My default passwords work.

 

Have you tried a straight

 

sudo ifconfig <network name> <IP> net mask <mask>



#3 eits

eits

    Sputnik

  • *****
  • Posts: 43
  • Joined: 05 Nov 2015
  • Loc: 31N 110W (SE Arizona, USA)

Posted 22 June 2021 - 12:38 PM

I am by no means an IP expert. Your request puzzles me a bit. First of all, your su (super user) password should have been set when you installed the computer. Secondly, the sudo command, if available, usually requires your user id to be set in the sudo users config file (found in the /etc directory on fedora). Thirdly, if your eth0 is connected to the internet your attempted ifconfig change is going to cause problems since the IP range 192.250.0.0 - 192.250.15.255 is registered to the OTIS Elevator Company. WHOIS 192.250.0.2 will show this. If your eth0 is only connected to a local network I would expect you would be using one of the private IP ranges 10.0.0.0 - 10.255.255.255 or 172.16.0.0 - 172.31.255.255 or 192.168.0.0 - 192.168.255.255

 

-gary-



#4 Lasko

Lasko

    Vostok 1

  • -----
  • Posts: 121
  • Joined: 15 Jan 2021
  • Loc: Sacramento, CA

Posted 22 June 2021 - 01:47 PM

ifconfig eth0 192.250.0.2 netmask 255.255.255.0 (what I need it to be)

Can you confirm you are trying to use the wired connection, and what is the network you are connecting to?  Usually DHCP will handle assigning the address.

 

If you need to set the address manually you can do that with the "Edit Connections" menu.

Attached Thumbnails

  • Edit_Connections.png


#5 Dan Crowson

Dan Crowson

    Gemini

  • *****
  • Moderators
  • Posts: 3,080
  • Joined: 08 Oct 2010
  • Loc: Dardenne Prairie, MO

Posted 22 June 2021 - 01:52 PM

You could just change it:
 
sudo passwd root
 
Dan


  • Kevin Ross likes this

#6 Wm Rison

Wm Rison

    Mariner 2

  • *****
  • topic starter
  • Posts: 240
  • Joined: 24 Oct 2005
  • Loc: Newburg, Maryland

Posted 22 June 2021 - 05:32 PM

Thanks everyone for the information.

I made a mistake with the IP address I was wanting to use.

Should have been 169.254.0.2 mask 255.255.0.0

It turns out I just did now wait long enough for the address to be set correctly.

Eth0 is connected directly to my Starbook Ten.

 

Also when I do a sudo ifconfig and am asked for a password astroberry works as the password.

Just issuing an su command and typing in the same password fails.

The sudo works for me.

 

Just to clear things I did not configure any parameters on my Raspberry Pi 4 because this is the astroberry image.

This is the first time I have worked with the Raspberry Pi and any unix type os for a very long time.

I do a lot of windows visual basic programming.

 

Thanks again,

William



#7 astrokeith

astrokeith

    Apollo

  • -----
  • Posts: 1,091
  • Joined: 14 Mar 2010
  • Loc: Surrey, UK

Posted 22 June 2021 - 05:43 PM

Thanks everyone for the information.

I made a mistake with the IP address I was wanting to use.

Should have been 169.254.0.2 mask 255.255.0.0

It turns out I just did now wait long enough for the address to be set correctly.

Eth0 is connected directly to my Starbook Ten.

 

Also when I do a sudo ifconfig and am asked for a password astroberry works as the password.

Just issuing an su command and typing in the same password fails.

The sudo works for me.

 

Just to clear things I did not configure any parameters on my Raspberry Pi 4 because this is the astroberry image.

This is the first time I have worked with the Raspberry Pi and any unix type os for a very long time.

I do a lot of windows visual basic programming.

 

Thanks again,

William

Glad you got it fixed.

I got hooked on Pi's - enjoy the learning.

Keith



#8 TelescopeGreg

TelescopeGreg

    Gemini

  • -----
  • Posts: 3,453
  • Joined: 16 Jul 2018
  • Loc: Auburn, California, USA

Posted 22 June 2021 - 10:44 PM

You can also right-click on the network icon on the toolbar at the top, and select "Edit connections".  Select the Eth0 row, hit the "settings" icon at the bottom (the star-shaped thingy), and fill in whatever you need to set under the IPv4 settings tab.

 

You can also have the Pi become the DHCP server for the external devices (and not rely on the kludgy self-assigned addressing) by changing the IPv4 "Method" from DHCP to "Shared to other computers".

 

But, if you have it working to your satisfaction, what you've done can work too.  Note that making a change with ifconfig is temporary (reverts on reboot) unless you're setting it in a system configuration script somewhere.  If that's the case, using the established GUI interface (above) is much better.



#9 gmiller123456

gmiller123456

    Vostok 1

  • -----
  • Posts: 167
  • Joined: 25 Dec 2020

Posted 22 June 2021 - 11:00 PM

Also when I do a sudo ifconfig and am asked for a password astroberry works as the password.

Just issuing an su command and typing in the same password fails.

 

 

For future reference, "sudo" asks for your own password, "su" asks for the "root" password.  It is pretty rare nowdays that you really want to use "su".




CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.


Recent Topics






Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics