Jump to content

  •  

CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.

Photo

SGP Autofocus not working with new setup

  • Please log in to reply
16 replies to this topic

#1 Tuant

Tuant

    Sputnik

  • -----
  • topic starter
  • Posts: 28
  • Joined: 26 Apr 2018
  • Loc: Zamora, Spain

Posted 06 July 2021 - 12:49 AM

Hello folks. 

I'm having some trouble trying to get SGP autofocus to run properly.

I've configured it many times before, following the steps described on its manual, and never had any issue -until now. What's more, I have it working flawlessly on a C8 HD Edge and a TS61 EDPH.

But on my 107 apo, with the new CMOS (ASI 294MM), autofocus behaves in a way I've never seen. With 9 datapoints, it makes many more frames, trying to find the optimal focus (wich never happens). Also, even when it shows a reasonable U-V shape, it keeps on moving the focuser to new points.

The only new ítem on the equipment is the CMOS.

- I tried several backlash compensation values: no result.

- Since this cam is intended to work in bin 2x2 with my setup, I've tried running autofocus with bin 2x2 and 4x4:no result.

- Did the initial configuration (described in the manual) several times, with slight variations in the step size: no result.

- Tried setting the variable "quadratic_fi_min_quality" to 80%, but SGG ignores it. What I'm doing wrong?

 

I'm attaching some images of the graphics, in case it might help.

 

Thanks.

 

https://ibb.co/W2dVL5M
https://ibb.co/hydngWL
https://ibb.co/HntdqFT
https://ibb.co/B65pm30
https://ibb.co/hVxrhwC

 

 



#2 bulrichl

bulrichl

    Ranger 4

  • *****
  • Posts: 385
  • Joined: 27 May 2018
  • Loc: La Palma (Canary Islands)

Posted 06 July 2021 - 05:53 AM

Judging from the linked limages, your step size in SGP's Auto Focus is too large. Instead of using a step size of 25, please try a step size in the range of 12 to 20 (maintaining the number of Auto Focus Data Points = 9).

 

If you still get the "dog ear" appearance at the right side of the AF plot, please increase the focuser backlash compensation progressively until it disappears.

 

Bernd



#3 Midnight Dan

Midnight Dan

    Voyager 1

  • *****
  • Posts: 14,688
  • Joined: 23 Jan 2008
  • Loc: Hilton, NY, Yellow Zone (Bortle 4.5)

Posted 06 July 2021 - 08:31 AM

That wing on the right seems to indicate your backlash is not set up right.  Either the amount of backlash compensation is too low, or the direction is wrong.  

 

-Dan



#4 StephenW

StephenW

    Surveyor 1

  • -----
  • Posts: 1,530
  • Joined: 04 Feb 2005
  • Loc: San Jose, CA

Posted 06 July 2021 - 09:03 AM

>trying to find the optimal focus (wich never happens). Also, even when it shows a reasonable U-V shape, it keeps on moving the focuser to new points.

 

In two of the images you attached, autofocus reaches a quality metric of 98% and 99%.   Are you saying that even when it gets these results, autofocus still "fails" and keeps looking for additional focus points?  Can you upload your SGP log so we can see what's happening? 

 

And as others have mentioned, your backlash settings need to be tweaked to remove the flat part on the right hand side of your curve,



#5 Tuant

Tuant

    Sputnik

  • -----
  • topic starter
  • Posts: 28
  • Joined: 26 Apr 2018
  • Loc: Zamora, Spain

Posted 06 July 2021 - 09:38 AM

@ Bulrichl, Dan

Yes, I' aware I have some backlash I should fix. Pegasus Astro focusers are nice and work, but they're not free of backlash. The point is I never applied backlash compensation before - and it worked, finding focus even when having backlash.

@ Stephen

That's the point. SGP, even when it reachess that 9X% accuracy with 7 measurements (configured with 7 data points) keeps on taking new frames. On each of those graphics, 7 data points were set. And autofocus routine takes more points, and eventually restarts and fails after 3 attempts.

@ Bulrichl, Dan & Stephen

Could it be that autofocus fails due to an incorrect backlash compensation? It puzzles me as I've never applied it before, and could focus (until I've begun using the ASI 294MM).

Tonight I'll try again, and save the logs so it could be more clarifying.



#6 Midnight Dan

Midnight Dan

    Voyager 1

  • *****
  • Posts: 14,688
  • Joined: 23 Jan 2008
  • Loc: Hilton, NY, Yellow Zone (Bortle 4.5)

Posted 06 July 2021 - 09:44 AM

Could it be that autofocus fails due to an incorrect backlash compensation? It puzzles me as I've never applied it before, and could focus (until I've begun using the ASI 294MM).

Yes.  That wing to the right doesn't follow the expected curve so it fails.  The "accuracy" may be high, but if the graph line is red, then it's not happy with how the curve fits the data.  

 

-Dan



#7 Peregrinatum

Peregrinatum

    Surveyor 1

  • *****
  • Posts: 1,820
  • Joined: 27 Dec 2018
  • Loc: South Central Valley, Ca

Posted 06 July 2021 - 01:15 PM

with a new scope its always the step size that is the critical value, along with the backlash comp...  with that size scope 7 points should be more than enough...  the new camera should not be an issue at all so long as you are starting the autofocus run at decent focus



#8 bulrichl

bulrichl

    Ranger 4

  • *****
  • Posts: 385
  • Joined: 27 May 2018
  • Loc: La Palma (Canary Islands)

Posted 06 July 2021 - 05:30 PM

@ Bulrichl, Dan

Yes, I' aware I have some backlash I should fix. Pegasus Astro focusers are nice and work, but they're not free of backlash. The point is I never applied backlash compensation before - and it worked, finding focus even when having backlash.

@ Stephen

That's the point. SGP, even when it reachess that 9X% accuracy with 7 measurements (configured with 7 data points) keeps on taking new frames. On each of those graphics, 7 data points were set. And autofocus routine takes more points, and eventually restarts and fails after 3 attempts.

@ Bulrichl, Dan & Stephen

Could it be that autofocus fails due to an incorrect backlash compensation? It puzzles me as I've never applied it before, and could focus (until I've begun using the ASI 294MM).

Tonight I'll try again, and save the logs so it could be more clarifying.

SGP doesn't fail, it reports a poor quality of the fit. You can lower the quality threshold, but the much better alternative is to adjust the backlash compensation appropriately.

 

If you really prefer lowering the threshold for the quality of the fit (I would advise against it), set the following variable in the 'Variables' field in sequences and profiles, decreasing the default value of 0.90, e.g.:

     quadratic_fit_min_quality=0.80

as suggested by Ken in https://forum.sequen...-0-313/10701/12 .

 

Bernd

 



#9 Tuant

Tuant

    Sputnik

  • -----
  • topic starter
  • Posts: 28
  • Joined: 26 Apr 2018
  • Loc: Zamora, Spain

Posted 08 July 2021 - 06:16 PM

Well, I'm right now at the observatory, and followed what everyone has said: trying to reduce backlash. Also, made a reconfiguration of all autofocus settings.

 

Starting from "perfect" focus via bathinov mask:

Focuser position 25300 with HFR 2.4

Moved the focuser so new HFR is 5x HFR1:

Focuser position 25900 with HFR oscillating between 11.70 - 11.96

Did the maths: 25900-25300=600 ; 600*2=1200 ; 1200/8=150

So, step size = 150

 

I've tried backlash compensation values between 250-350, in OUT (trying on IN makes autofocus to fail after 2 captures, reporting bad HFR 2 times in a row so I'm pretty sure the right direction is OUT). I'm getting what I think is a nice U-V graphic... yet SGP never shows the green line but the red one, and after the data points, restarts autofocus again, and again...

 

https://ibb.co/F69ffw19
https://ibb.co/hLJCRXv

 

At this point, after following your advices (I think) I don't get what I'm doing wrong...


Edited by Tuant, 08 July 2021 - 06:16 PM.


#10 StephenW

StephenW

    Surveyor 1

  • -----
  • Posts: 1,530
  • Joined: 04 Feb 2005
  • Loc: San Jose, CA

Posted 08 July 2021 - 06:57 PM

Can you upload your SGP log so we can see why SGP thinks it needs to keep going?



#11 Tuant

Tuant

    Sputnik

  • -----
  • topic starter
  • Posts: 28
  • Joined: 26 Apr 2018
  • Loc: Zamora, Spain

Posted 08 July 2021 - 07:08 PM

Here it is, this is what I've been doing tonight with this workstation. I'm still at the observatory, working with another workstation, since I'm stuck with this one due to this issue.

Sorry for uploading the raw log, I can't tell the useful parts from the bundled log.

 

https://easyupload.io/j0injt

 

I've had to upload through an external web because when I try to upload it here, I get an error saying I'm not allowed to upload this kind of file.

 

 



#12 StephenW

StephenW

    Surveyor 1

  • -----
  • Posts: 1,530
  • Joined: 04 Feb 2005
  • Loc: San Jose, CA

Posted 08 July 2021 - 09:37 PM

Definitely something weird going on.   It looks like temperature compensation is triggering autofocus to restart immediately after each autofocus run completes.

 

Can you try disabling temp comp and seeing if it can complete 1 auto focus run?



#13 bulrichl

bulrichl

    Ranger 4

  • *****
  • Posts: 385
  • Joined: 27 May 2018
  • Loc: La Palma (Canary Islands)

Posted 09 July 2021 - 03:50 AM

Unfortunately I misread the scale of the focus position in your screenshots (your step size was 125, not 25 as I understood before). So my calculation was based on wrong data.

Please try a step size in the range of 60 to 90.

 

I am sorry for the confusion.

 

Bernd



#14 Tuant

Tuant

    Sputnik

  • -----
  • topic starter
  • Posts: 28
  • Joined: 26 Apr 2018
  • Loc: Zamora, Spain

Posted 09 July 2021 - 06:51 PM

I've been tonight to the observatory, trying to apply your suggestions. Here's what I did:

 

1- Tried an Autofocus run, starting from "perfect" focus, via Bathinov mask.

Step size: 130.

Backlash compensation: 260 Out.

Temperature compensation: No.

Autofocus runs 3 times, with decent graphic and % quality. Reports failure.

 

https://ibb.co/5v17KDw
https://ibb.co/JvrGRfY

 

2- As Bernd suggested, tried a Step size in the range of 60-90. Had to increase backlash compensation, so the graphic looked like U-V.

Step size: 75

Backlash compensation: 350 Out.

Temperature compensation: No.

Autofocus runs 3 times, with decent graphic and % quality. Reports failure.

 

https://ibb.co/XDtqcSx
https://ibb.co/9YyX2nj

 

3- Tried disabling smart focus with Step size 75, 130, 150. Tried several values for data points: 7,8,9.

Autofocus runs 3 times, with decent graphic and % quality. Reports failure.

 

https://ibb.co/jJ52Np6
https://ibb.co/xHc4Xmh

 

So... this is the error SGP displays after each Autofocus run (with 3 failed attempts each):

 

https://ibb.co/TkkVn3W

 

Honestly, I don't know what to think. I have 2 other workstations, each of them running Autofocus with no issues, TS61 EDPH with a ASI1600, and the other is a C8 HD with a ASI294 MC. So I'm not an expert, but it's not like I've configured Autofocus for the first time. Also, neved had this issue until I got an ASI294 MM for the 107 apo, wich didn't have problems running the Autofocus with the ASI1600.

 

I'm prone to think it's either software problem (maybe my SGP has gone mad), or there's an unsolved issue with this cam, related to the binning modes, since the ASI294 MM is intended to have "2 working modes" (pixel size is switchable – the default setting is Bin2, but you can switch to Bin1 anytime in your astrophotography software. This changes the pixel size into 2.3um)

This is how I've configured the cam in SGP, so Plate Solve doesn't go mad. Could it be that for Autofocus needs to be configured telling the software Bin1 is 4.63 um?

 

https://ibb.co/RYpJyyV

 

Edit: Here's the log from tonight:

 

https://easyupload.io/ods4wf


Edited by Tuant, 09 July 2021 - 06:56 PM.


#15 Midnight Dan

Midnight Dan

    Voyager 1

  • *****
  • Posts: 14,688
  • Joined: 23 Jan 2008
  • Loc: Hilton, NY, Yellow Zone (Bortle 4.5)

Posted 09 July 2021 - 06:59 PM

I've been tonight to the observatory, trying to apply your suggestions. Here's what I did:

 

1- Tried an Autofocus run, starting from "perfect" focus, via Bathinov mask.

Step size: 130.

Backlash compensation: 260 Out.

Temperature compensation: No.

Autofocus runs 3 times, with decent graphic and % quality. Reports failure.

 

https://ibb.co/5v17KDw
https://ibb.co/JvrGRfY

 

 

That graph looks perfectly fine.  No idea why it should try 3 times with that kind of data, and then fail.  I would post this on the SGP forum and include the SGP log. 

 

-Dan



#16 bulrichl

bulrichl

    Ranger 4

  • *****
  • Posts: 385
  • Joined: 27 May 2018
  • Loc: La Palma (Canary Islands)

Posted 11 July 2021 - 03:27 AM

I downloaded your SGP logfile of July 10, 2021 and used Mikael's SGP AF LogViewer. This is the result when the option 'Show all AF runs' is enabled:

 

AF_LogViewer_210710.PNG

 

The reason for failing is visible in column 9 (min Q): the minimum Quality must be in the range of [0,1], not [0,100]. So please try either a value of 0.95, or delete this variable (AFAIK the default value is 0.90 which is appropriate in most cases).

 

Bernd

 



#17 Tuant

Tuant

    Sputnik

  • -----
  • topic starter
  • Posts: 28
  • Joined: 26 Apr 2018
  • Loc: Zamora, Spain

Posted 15 July 2021 - 12:25 PM

Last night I was able to go to the observatory. I deleted the variable, and voilà, Autofocus ran smooth. I find ironic that, trying to made the AF process a bit more flexible, ended messing it up, due to a bad sintaxis with the variable. Mental note: If something isn't broke, don't fix it.

Many thanks everyone who helped, and specially Bernd. You folks in this forum are awesome.




CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.


Recent Topics






Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics