Jump to content

  •  

CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.

Photo

EQMOD does not see the COM port

  • Please log in to reply
5 replies to this topic

#1 alexander.horn

alexander.horn

    Lift Off

  • -----
  • topic starter
  • Posts: 2
  • Joined: 21 Jul 2021

Posted 21 July 2021 - 10:36 AM

Hello, 

 

I am using a Skywatcher AZEQ6 mount and trying to connect it to EQMOD(the connection is via the syncscan and an USB cable).

I installed the skywatcher ASCOM driver given by Skywatcher. It works, because using Carte du Ciel I can connect to the mount, and control it. 

Looking in my WIN10 system on the connections I can see the COM8 activated by the mount. 

But then, starting the EQMOD setup it does not recognize the port, and even setting it to COM8 and to 1150000 the EQMOD run does not find the pirt sending a connection error.

 

Have you an idea what I can do?

 

Sincerely yours,

 

Alexander



#2 jdupton

jdupton

    Soyuz

  • *****
  • Posts: 3,743
  • Joined: 21 Nov 2010
  • Loc: Central Texas, USA

Posted 21 July 2021 - 11:01 AM

Alexander,

 

   If you are running a USB cable between the PC and the SynScan Hand Control, then you need to set the communications speed to 9600 bps. The 115200 bps speed applies when you have a mount that has a USB connector on the mount itself and you use that path to connect to the PC bypassing the HC completely.

 

   In addition, any time you are running with the SkyWatcher ASCOM driver, then you leave the Hand Control in normal operating mode. If you want to use the EQMOD ASCOM driver, then you need to set the Hand Control into PC-Direct mode.

 

   Details on why things need to be configured this way are explained in more detail in a tutorial on my Website. See https://www.atm-workshop.com/synscan-pc-connect.html for the low level details and a description of the different ways to connect.

 

 

John

 

PS:

   Welcome to Cloudy Nights!


Edited by jdupton, 21 July 2021 - 11:02 AM.


#3 rgsalinger

rgsalinger

    Cosmos

  • *****
  • Moderators
  • Posts: 9,497
  • Joined: 19 Feb 2007
  • Loc: Carlsbad Ca

Posted 21 July 2021 - 11:06 AM

The only way EQMOD worked reliably on my Synta mounts was by getting rid of the HC entirely and using a Shoestring cable. Note that if you have the driver occupying com 8 then EQMOD cannot connect to that port. 

 

NB. I also found that I needed to install EQMOD and register it with explicit Admin priveleges. (That may have had something to do with my computer but others have seen the same thing.)

 

Finally, assuming that you are using a USB/RS232 adapter, make sure that you have the drivers installed. (You probably do since you can connect to the ASCOM driver but..............)

 

Rgrds-Ross



#4 alexander.horn

alexander.horn

    Lift Off

  • -----
  • topic starter
  • Posts: 2
  • Joined: 21 Jul 2021

Posted 21 July 2021 - 02:36 PM

Hello John, hello Ross,

 

thank you very mch for your suggestions. Firstly, the change in SyncScan hand controler to "PC direct mode" worked! I am very happy.

Secondly, I have a connection directly from the SyncScan hand controller to the PC, but it looks not like a RS232, more like a USB Type B.

 

Thank you John for your very deep explanation page, but I am wondering, why in the EQMOD I can not set the GPS signal. I set the same port, again COM 7, but it does not take any infomation from my GPS. The GPS is connected at the handSyncSan  controller....

 

Maybe you have an idea? 

 

Sincerely yours,

 

Alexander



#5 jdupton

jdupton

    Soyuz

  • *****
  • Posts: 3,743
  • Joined: 21 Nov 2010
  • Loc: Central Texas, USA

Posted 21 July 2021 - 02:52 PM

Alexander,

 

   I am not familiar with whatever GPS you are using. I have one that connects directly to my PC via USB rather than connecting to the Hand Controller. If the GPS is USB, try moving its connection from HC to the PC and see if that works in EQMOD. That is how it worked for me. If the GPS is Serial link based, try connecting to PC via a USB-to-RS232 cable to see if that works.

 

 

John



#6 MikeECha

MikeECha

    Messenger

  • *****
  • Posts: 409
  • Joined: 15 Sep 2018
  • Loc: Charlotte, NC

Posted 21 July 2021 - 05:05 PM

Hello, 

 

I am using a Skywatcher AZEQ6 mount and trying to connect it to EQMOD(the connection is via the syncscan and an USB cable).

I installed the skywatcher ASCOM driver given by Skywatcher. It works, because using Carte du Ciel I can connect to the mount, and control it. 

Looking in my WIN10 system on the connections I can see the COM8 activated by the mount. 

But then, starting the EQMOD setup it does not recognize the port, and even setting it to COM8 and to 1150000 the EQMOD run does not find the pirt sending a connection error.

 

Have you an idea what I can do?

 

Sincerely yours,

 

Alexander

When that happens to me (EQ6R pro) it is because I connected the USB cable to the laptop after I turned on the mount. To fix it I then just turn the mount off and on again and EQMOD scans finds the port.

 

I hope this helps you.




CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.


Recent Topics






Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics