Jump to content

  •  

CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.

Photo

Polar Scope doesn't fit tight on Explore Scientific / BRESSER EXOS-2 / Meade LXD-75

  • Please log in to reply
No replies to this topic

#1 biptunia

biptunia

    Vostok 1

  • *****
  • topic starter
  • Posts: 188
  • Joined: 21 May 2020

Posted 02 July 2022 - 11:22 PM

EDIT: solved. There are little tiny hex keys that hold it in.

 

-==--==-=-=

 

I got a used Explore Scientific mount on eBay. I'm slowly getting everything to make it work.

 

Got the Polar Finder Scope from Explore Scientific store on Amazon. Looks to be the correct one. But when I put it in the hole where it goes, it isn't tight. It flops around, and falls out with gravity if I let go of it. Doesn't seem like it would do an accurate align.

 

I'm wondering if it's missing some kind of plastic or metal sleeve or collar.

 

The female part on the mount has no threads inside our out. The scope has no threads where it connects.

 

Does anyone know what the issue is, and if I need a sleeve, what the part number is and where to get it?

 

Here is a photo of me holding it in place, and a shot from the manual.

 

Thank you.

Attached Thumbnails

  • loose-fit.jpg
  • manual.jpg

Edited by biptunia, 03 July 2022 - 06:55 PM.

  • Skywatchr likes this


CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.


Recent Topics






Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics