Jump to content

  •  

CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.

Photo

Beautiful Celestron 8SE but not powering on!

Celestron SCT
  • Please log in to reply
2 replies to this topic

#1 deep_b

deep_b

    Lift Off

  • -----
  • topic starter
  • Posts: 1
  • Joined: 16 Aug 2022

Posted 16 August 2022 - 08:39 PM

Deep: 319355116

Hi everyone -

I bought this beauty secondhand - Celestron 8SE (with mini-USB NextStar+ handset).

 

I got the kids and myself so excited about this, only to find out that it won't power on! Specifically, when I flip the power switch on the mount, the orange lights on the handset come on for 0.5 secs and then go out. No further activity on the screen or the button backlights. No response from pushing any of the buttons.

 

Here are all the things I have tried (based on reading these forums, esp. helpful hints from Mike Swanson and others):

  • I tried brand-new, 8xAA batteries. I also tried 3 different 12V supplies (because I had them at home) - 2A & 5A ratings. I also tried a 12V power tank (actually a portable car jumpstart with a 12V cigarette lighter) All of them have the same result. Also, I used a volt meter to confirm that these power supplies had a "positive-inside" adapter (also confirmed there's a solid 12V DC). So that's not the issue.  
  • I tried plugging in the handset into the Aux port (like Mike Swanson suggested in one of the posts). No dice.
  • I tried holding down the "Celestron key + 7" and flipping the power switch. I also tried holding down "0" while flipping the switch. No dice again.
  • I wondered if the handset firmware is out of date, so plugged the handset into the laptop with a mini-USB-to-USB cable. The handset gets further in its boot up sequence but it's stuck on "Initialize." The CFM doesn't seem to find any devices connected to the laptop. I tried this with the handset connected to the telescope, and not. I also tried holding down "Celestron key + 7", "0" while flipping the power switch - no difference.
  • I also looked into replacing just the mount + handset. $500 and it's no longer in production by Celestron!
  • I have read posts about people saying that the connectors in the mount are pretty flaky so I was about to take the screws off, get in there and check it out. But given that handset won't even boot up when I connect it to the laptop, I am suspecting that the handset might be the issue (not the motor control board in the mount).
  • Finally, I saw that Mike Swanson recommended swapping out the handset as a way of eliminating the root cause. So I posted on our local Facebook group, hoping someone has a handset I can borrow. I just posted today so waiting on that.

 

In the meanwhile, I wanted to try this helpful community. From my searching, I haven't seen anyone else fail at such an early stage of the power-up process. But perhaps there are other ideas I should try?

 

Can't wait to get this thing running. We are going to Acadia Park in ME in a couple of weeks with my 4-yr and 6-yr old. The reason for getting this now is to get them excited about the stars on that trip (apparently one of the darker places on the east coast?). Right now, it's a beautiful but heavy paper weight - but I am confident I'll get it going and get these kiddos looking up soon!

Thanks!

Attached Thumbnails

  • IMG_1622.jpg


#2 Herb_H

Herb_H

    Explorer 1

  • -----
  • Posts: 61
  • Joined: 05 Jun 2022

Posted 16 August 2022 - 10:16 PM

Looks like either the electronics was dead on arrival (possible but unlikely ... edit: it seems you bought it used !) or one of the many fiddles you did with it ... for ex the power supply with wrong polarity ...  fried the electronics. Btw some car jump starters will output 16+ volts which will fry the controller.

 

Only sensible resort seems to be send back to Celestron for proper diagnostic and repair.


Edited by Herb_H, 17 August 2022 - 11:51 AM.


#3 whizbang

whizbang

    Surveyor 1

  • *****
  • Posts: 1,505
  • Joined: 18 Mar 2018
  • Loc: NE of Seattle, WA

Posted 16 August 2022 - 11:20 PM

It sounds like you didn't have a chance to test it before you bought it.

And I don't think you fried it with the jump start battery.

You need to borrow or buy another hand control and test it. The older style Nexstar+ HC withe the RS232 jack will also work with your mount. Buy one used in the CN classifieds or eBay.


CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.


Recent Topics





Also tagged with one or more of these keywords: Celestron, SCT



Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics