Jump to content

  •  

CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.

Photo

Astap issue in Nina only

  • Please log in to reply
12 replies to this topic

#1 charles.tremblay.darveau

charles.tremblay.darveau

    Messenger

  • *****
  • topic starter
  • Posts: 436
  • Joined: 16 Oct 2020

Posted 07 October 2022 - 12:28 AM

Hi there,

 

I'm trying to setup a PC with Nina 2.0HF1 and getting non-sense errors with ASTAP. I'm getting the 'not enough stars' error even though using a 2min subs (with plenty stars). Here are the steps I've done:

-Install Nina

-Install ASTAP

-Install H18 database

-Setup scope focal length and camera properties

-Load a  2min frame from my SCT @1400mm focal length in the framing assistant

-Select Platesolve ... get error
 

Image solves fine in Astrometry.net via Nina, and also by loading the SAME image in ASTAP.exe directly. All solving variables (focal length, pixel, binning) are good in Nina.

 

Any idea? Thanks for the help!



#2 charles.tremblay.darveau

charles.tremblay.darveau

    Messenger

  • *****
  • topic starter
  • Posts: 436
  • Joined: 16 Oct 2020

Posted 07 October 2022 - 12:43 AM

Another datapoint: I'm getting a similar problem with Platesolve 2. Image solves fine in standalone platesolve2, but trying to run in Nina returns the error:
'Unable to read FITS file. Non-numeric BSCALE parameter String: BSCALE = '''1''' '

 

Seems to be an issue on Nina side ... Am I the first lucky person to get this problem?



#3 Jim Waters

Jim Waters

    Fly Me to the Moon

  • *****
  • Posts: 7,247
  • Joined: 21 Oct 2007
  • Loc: Phoenix, AZ USA

Posted 07 October 2022 - 01:25 AM

I have been using NINA with ASTAP for a number of years without any issues.  There is some NINA setting that you are overlooking.

 

Upgrade to NINA 2.0 HF02.



#4 Jim Waters

Jim Waters

    Fly Me to the Moon

  • *****
  • Posts: 7,247
  • Joined: 21 Oct 2007
  • Loc: Phoenix, AZ USA

Posted 07 October 2022 - 01:26 AM

Post your problem with the logs on NINA Discord Forum.



#5 charles.tremblay.darveau

charles.tremblay.darveau

    Messenger

  • *****
  • topic starter
  • Posts: 436
  • Joined: 16 Oct 2020

Posted 07 October 2022 - 01:37 AM

I'm on the latest and greatest Nina version (just installed). (Win11)

 

Post your problem with the logs on NINA Discord Forum.

 

Yes, I was thinking of doing that. But before that I will test my luck with a Fits acquired directly from Nina (instead of one loaded from my previous AAP folder). Unfortunately I need some clear sky for that...

 

As a side note, if I convert my FITS to a different format (png, tiff), both ASCOM/platesolve2 work fine.  It seems to be a translation issue between the loaded FIT file in Nina to ASCOM/Platesolve2



#6 Linwood

Linwood

    Gemini

  • *****
  • Posts: 3,242
  • Joined: 09 Jul 2020
  • Loc: Ft Myers, Florida, USA

Posted 07 October 2022 - 09:11 PM

I had a similar issue when I downloaded someone's fits image the other day and tried to load it in the framing wizard, got a fits error (I do not recall the specific).  I opened it in Pixinsight, and resaved it from pixinsight as xisf, then opened it in NINA and it worked (I do not know if the change in container did it, or just that I opened and resaved).  I assumed I had a corrupt fits, but maybe there is some issue with the library NINA is using.  I think that got changed recently (I am not a NINA developer I just remember bits and pieces of what I hear).  You might be better off reproducing this and posting the offending fits on discord. 



#7 unimatrix0

unimatrix0

    Gemini

  • *****
  • Posts: 3,246
  • Joined: 03 Jan 2021

Posted 07 October 2022 - 11:23 PM

Another datapoint: I'm getting a similar problem with Platesolve 2. Image solves fine in standalone platesolve2, but trying to run in Nina returns the error:
'Unable to read FITS file. Non-numeric BSCALE parameter String: BSCALE = '''1''' '

 

Seems to be an issue on Nina side ... Am I the first lucky person to get this problem?

BSCALE is a value within the fits header, If I'm not mistaken.  Something is saved the wrong way, wrong values in the fits header.  

 

 

I'm getting the 'not enough stars' error even though using a 2min subs

I had similar issue in Sharpcap and only with high focal length telescope (1370mm).   Since there is a chance you are oversampling and your stars take up a lot of pixels, NINA's scaling and sending the images over the ASTAP, something is lost in translation and the stars aren't seen as stars, because they are big. Also, 2 minutes is pointlessly too long of a sub for plate solving. If it cannot plate solve a 10 second sub, then exposure length is not the issue. 

 

Have you tried changing the image scaling in the plate solving menu in NINA?  Also have you tried binning during plate solving?  Try Bin2 see what happens.  

 

Also if the gain is too high , hot pixels can be mistaken for stars also, also had that issue so with the high focal length telescope, I used low gain afterwards (unity gain). 


Edited by unimatrix0, 07 October 2022 - 11:25 PM.


#8 KungFood

KungFood

    Surveyor 1

  • -----
  • Posts: 1,544
  • Joined: 18 Jul 2014
  • Loc: Dallas, Tx

Posted 08 October 2022 - 02:50 AM

Do you get errorsn regular platesolve exposures, eg. 5 seconds as opposed to 2 minutes?

#9 jdupton

jdupton

    Aurora

  • *****
  • Posts: 4,723
  • Joined: 21 Nov 2010
  • Loc: Central Texas, USA

Posted 08 October 2022 - 09:55 AM

Charles,

 

Another datapoint: I'm getting a similar problem with Platesolve 2. Image solves fine in standalone platesolve2, but trying to run in Nina returns the error:
'Unable to read FITS file. Non-numeric BSCALE parameter String: BSCALE = '''1''' '

 

Seems to be an issue on Nina side ... Am I the first lucky person to get this problem?

   This almost sounds a little like an international format problem. If ASTAP or PlateSolve2 is seeing a non-numeric value for the BSCALE problem, it could be something to do with numeric formats between different countries. If I may ask, are you in the US or in Europe?

 

   As a test, can you go into your Windows settings and search for Region settings. Change the Format: setting to English (United States) temporarily. Close and restart NINA and then do a sample capture for plate solving. If ASTAP or PlateSolve2 doesn't complain now, then you know you are on the right track. Check with the NINA developers on Discord to see if this might be a bug. When you finish this test, change the Formats setting back to your native country as it was before.

 

   By the way, my NINA installation does not appear to write a BSCALE parameter into the FITs Header at all. If you open one of the images in PixInsight, what does the FITsHeader process show? (I think I have seen you mention that you use PixInsight.)

 

 

John


Edited by jdupton, 08 October 2022 - 09:57 AM.


#10 Linwood

Linwood

    Gemini

  • *****
  • Posts: 3,242
  • Joined: 09 Jul 2020
  • Loc: Ft Myers, Florida, USA

Posted 08 October 2022 - 11:06 AM

Note that the OP said the images solve in ASTAP if loaded directly.  When NINA passes an image to ASTAP, at least as far as I am aware, it reads the image and rewrites it, it is not just passing it on as a file pointer. The error as described sounds like it is failing when it tries to read the image, so changes in bin and scale will not help.

 

I think as the OP suggested capturing the image to solve in NINA will resolve the issue.

 

As to bin: 

 

Note also there are two rescalings that can occur, one is by setting downsample on the platesolve -- this affects only new images NINA takes for plate solving.  My recommendation is to leave that the same as you use for most of your light images, so if your normal images taken are bin 1, keep your plate solve at bin 1.  The reason for this is that one of the most useful features of NINA's advanced sequencer is the center-after-drift, which helps recover from cloud (or other) induced offsets. It by definition is going to solve the image at your normal bin, so might as well have everything in the plate solve pipeline already binned that way.  It is not necessary to leave it the same, if you follow the next recommendation, but it does mean your plate solves are from consistent sizes and so any issues will show up (or be avoided) in both lights and plate solve specific captures. 

 

The other setting is the downsample. You can force ASTAP to downsample the resulting image before it solves by setting this (platesolve options under ASTAP specifically, the one above is generally platesolve not astap specific).  This occurs AFTER any downsampling you put in the plate solve bin.  The current recommendation for that is zero, which means "let ASTAP decide". 

 

But generally speaking if NINA is not able to read the image, all this is moot -- if the original problem stems from NINA finding the image unreadable, address that first either by capturing the image yourself, or find out why and fix the source



#11 charles.tremblay.darveau

charles.tremblay.darveau

    Messenger

  • *****
  • topic starter
  • Posts: 436
  • Joined: 16 Oct 2020

Posted 08 October 2022 - 12:40 PM

Charles,

 

   This almost sounds a little like an international format problem. If ASTAP or PlateSolve2 is seeing a non-numeric value for the BSCALE problem, it could be something to do with numeric formats between different countries. If I may ask, are you in the US or in Europe?

 

   As a test, can you go into your Windows settings and search for Region settings. Change the Format: setting to English (United States) temporarily. Close and restart NINA and then do a sample capture for plate solving. If ASTAP or PlateSolve2 doesn't complain now, then you know you are on the right track. Check with the NINA developers on Discord to see if this might be a bug. When you finish this test, change the Formats setting back to your native country as it was before.

 

   By the way, my NINA installation does not appear to write a BSCALE parameter into the FITs Header at all. If you open one of the images in PixInsight, what does the FITsHeader process show? (I think I have seen you mention that you use PixInsight.)

 

 

John

 

Thanks for the suggestions. I've tried with fits image captured with AAP and Sharpcap. Both have the BSCALE header (header parsed in Pixinsight) and will fail when loading in Nina. My keyboard is ENG/USA so I don't think this is due to the Region setting.

 

Yes it seems the Nina Fits header structure is different and may work fine as long as I stick to Nina (I'll test this tonight as I finally have a clear sky). The problem is that I will often use the AAP in the field, or use the AAP for a second setup,  and it will give me some headache if I decide to platesolve from AAP acquired previously.  

 

Note that the OP said the images solve in ASTAP if loaded directly.  When NINA passes an image to ASTAP, at least as far as I am aware, it reads the image and rewrites it, it is not just passing it on as a file pointer. The error as described sounds like it is failing when it tries to read the image, so changes in bin and scale will not help.

 

I think as the OP suggested capturing the image to solve in NINA will resolve the issue.

 

As to bin: 

 

Note also there are two rescalings that can occur, one is by setting downsample on the platesolve -- this affects only new images NINA takes for plate solving.  My recommendation is to leave that the same as you use for most of your light images, so if your normal images taken are bin 1, keep your plate solve at bin 1.  The reason for this is that one of the most useful features of NINA's advanced sequencer is the center-after-drift, which helps recover from cloud (or other) induced offsets. It by definition is going to solve the image at your normal bin, so might as well have everything in the plate solve pipeline already binned that way.  It is not necessary to leave it the same, if you follow the next recommendation, but it does mean your plate solves are from consistent sizes and so any issues will show up (or be avoided) in both lights and plate solve specific captures. 

 

The other setting is the downsample. You can force ASTAP to downsample the resulting image before it solves by setting this (platesolve options under ASTAP specifically, the one above is generally platesolve not astap specific).  This occurs AFTER any downsampling you put in the plate solve bin.  The current recommendation for that is zero, which means "let ASTAP decide". 

 

But generally speaking if NINA is not able to read the image, all this is moot -- if the original problem stems from NINA finding the image unreadable, address that first either by capturing the image yourself, or find out why and fix the source

 

Good point on the xisf format. I've tried to re-save as fits in pixinsight and that didn't work, but perhaps changing format to xisf would work and fix the header.

 

Either way, seems something is odd with the Nina fits header parser (compared to sharpcap and AAP). I'll sync up with the Dev team on Discord after a bit more testing on my side.

 

Thanks all!



#12 charles.tremblay.darveau

charles.tremblay.darveau

    Messenger

  • *****
  • topic starter
  • Posts: 436
  • Joined: 16 Oct 2020

Posted 09 October 2022 - 12:27 AM

Just wanted to provide a quick update. Platesolving seems to work fine with the Fits files acquired directly in Nina. This is a problem only if you import fits generated from a different acquisition module. I'll still follow up with the Nina team on this.



#13 charles.tremblay.darveau

charles.tremblay.darveau

    Messenger

  • *****
  • topic starter
  • Posts: 436
  • Joined: 16 Oct 2020

Posted 12 October 2022 - 10:27 AM

Quick update, I had a chat with the Devs on Discord and they identified the issue in Nina (seems Nina parses all unused fits parameters as strings). They will work on a bug fix at some later point. 




CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.


Recent Topics






Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics